summarylogtreecommitdiffstats
path: root/.pre-commit-config.yaml
diff options
context:
space:
mode:
authorWenxuan Zhang2020-09-26 12:57:40 +0800
committerWenxuan Zhang2020-09-26 12:57:40 +0800
commit93abb66a9819368518574f72e6b88d633f9e08d2 (patch)
tree60f265b7f6a9c36500612479109e525db0cbfa05 /.pre-commit-config.yaml
downloadaur-93abb66a9819368518574f72e6b88d633f9e08d2.tar.gz
init commit
Diffstat (limited to '.pre-commit-config.yaml')
-rw-r--r--.pre-commit-config.yaml19
1 files changed, 19 insertions, 0 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
new file mode 100644
index 000000000000..4fc8fc89b900
--- /dev/null
+++ b/.pre-commit-config.yaml
@@ -0,0 +1,19 @@
+# See https://pre-commit.com for more information
+# See https://pre-commit.com/hooks.html for more hooks
+repos:
+- repo: https://github.com/pre-commit/pre-commit-hooks
+ rev: v3.1.0
+ hooks:
+ - id: trailing-whitespace
+ - id: end-of-file-fixer
+ - id: check-added-large-files
+ - id: mixed-line-ending
+- repo: local
+ hooks:
+ - id: makepkg
+ name: makepkg
+ pass_filenames: false
+ always_run: true
+ language: system
+ entry: >
+ sh -c 'make codegen && git add PKGBUILD .SRCINFO'