summarylogtreecommitdiffstats
path: root/.pre-commit-config.yaml
diff options
context:
space:
mode:
authorWenxuan Zhang2020-10-20 17:41:33 +0800
committerWenxuan Zhang2020-10-20 17:41:33 +0800
commit4c36696f53a972d2f08e6ad9889847c3910e1e3a (patch)
tree58149ba762b4e66c1f76a35564001eefd9b13a7d /.pre-commit-config.yaml
downloadaur-4c36696f53a972d2f08e6ad9889847c3910e1e3a.tar.gz
init commit
Diffstat (limited to '.pre-commit-config.yaml')
-rw-r--r--.pre-commit-config.yaml22
1 files changed, 22 insertions, 0 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
new file mode 100644
index 000000000000..1322305dfbeb
--- /dev/null
+++ b/.pre-commit-config.yaml
@@ -0,0 +1,22 @@
+# See https://pre-commit.com for more information
+# See https://pre-commit.com/hooks.html for more hooks
+repos:
+- repo: https://github.com/pre-commit/pre-commit-hooks
+ rev: v3.1.0
+ hooks:
+ - id: trailing-whitespace
+ - id: end-of-file-fixer
+ - id: check-added-large-files
+ - id: mixed-line-ending
+- repo: local
+ hooks:
+ - id: makepkg
+ name: makepkg
+ pass_filenames: false
+ always_run: true
+ language: system
+ entry: |
+ sh -c '
+ makepkg --printsrcinfo > .SRCINFO &&
+ git add PKGBUILD .SRCINFO
+ '