summarylogtreecommitdiffstats
path: root/.travis.yml
diff options
context:
space:
mode:
authorbartus2019-06-16 14:46:01 +0200
committerbartus2019-06-16 14:52:28 +0200
commit9fcf3ae97150b10a0ecb49015eb84948e154fbe2 (patch)
treec22c6cd5866231c91bc89624c9e303aefbd17716 /.travis.yml
parenteb96d2a5ffaec1eec9be9dbff085897f20eb69df (diff)
downloadaur-9fcf3ae97150b10a0ecb49015eb84948e154fbe2.tar.gz
use bartoszek/arch-travis-bartus:latest docker image
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml9
1 files changed, 4 insertions, 5 deletions
diff --git a/.travis.yml b/.travis.yml
index f93049d22ce5..dd6388c80abf 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -25,9 +25,9 @@ arch:
repos:
- bartus=https://github.com/bartoszek/AUR-repo/raw/master
packages:
-# disable to prevent `package-cleanup.hook`
-# - ccache
-# - moreutils
+ - ccache
+ - moreutils
+ - bc
script:
# prepare ENV:
# 1. multithreading:
@@ -39,7 +39,6 @@ arch:
echo 'COMPRESSXZ=(xz -T 0 -c -z -)' >> PKGBUILD
echo "MAKEFLAGS='-j2'" >> PKGBUILD
sudo mkdir /etc/pacman.d/hooks/ && sudo ln -s /dev/null /etc/pacman.d/hooks/package-cleanup.hook
- sudo pacman -S --noconfirm ccache moreutils bc
# check interval update
- |
update_offset=$(. PKGBUILD; sha1sum <<< "$pkgname"|sed -e "s/[a-z -]//g" -e "s/^0*//"|echo `cat`%$update_interval|bc)
@@ -73,7 +72,7 @@ arch:
exit $makepkg_ret
script:
-- "curl -s https://raw.githubusercontent.com/bartoszek/arch-travis/pacman-pkg-cache/arch-travis.sh | bash"
+- "curl -s https://raw.githubusercontent.com/bartoszek/arch-travis/pacman-pkg-cache/arch-travis.sh |sed 's:mikkeloscar/arch-travis:bartoszek/arch-travis-bartus:'| bash"
- "echo 'pacman pkg cache size: ' $(du -h ~/.pkg-cache|cut -f1) in $(ls ~/.pkg-cache|wc -l) files"
deploy: