summarylogtreecommitdiffstats
path: root/.travis_deploy.sh
diff options
context:
space:
mode:
authorbartoszek2019-06-15 10:15:22 +0200
committerbartoszek2019-06-15 10:16:45 +0200
commiteb96d2a5ffaec1eec9be9dbff085897f20eb69df (patch)
treea8ed778da3f7d4e58d100b6a7667bd2a8d98c8ca /.travis_deploy.sh
parentc083b232099a5bbda843198e73b9109f9489427a (diff)
downloadaur-eb96d2a5ffaec1eec9be9dbff085897f20eb69df.tar.gz
deploy: evaluate filename from PKGBUILD
Diffstat (limited to '.travis_deploy.sh')
-rw-r--r--.travis_deploy.sh9
1 files changed, 5 insertions, 4 deletions
diff --git a/.travis_deploy.sh b/.travis_deploy.sh
index d1188d62c723..0f0e819c7c65 100644
--- a/.travis_deploy.sh
+++ b/.travis_deploy.sh
@@ -1,9 +1,10 @@
[ ! -f *pkg.tar.xz ] && exit 0
-. PKGBUILD
+eval "$(. PKGBUILD; epoch=${epoch:-0}; declare -p pkgname epoch pkgver pkgrel 2>/dev/null; )"
+file_name="$pkgname-$([ $epoch -gt 0 ] && echo $epoch:)$pkgver-$pkgrel-x86_64.pkg.tar.xz"
git clone https://$GITHUB_ACCESS_TOKEN@github.com/bartoszek/AUR-repo.git
-cd AUR-repo
-cp $TRAVIS_BUILD_DIR/$pkgname*$pkgver*.pkg.tar.xz $(pwd)
-git add $pkgname*$pkgver*.pkg.tar.xz
+cd AUR-repo || exit 1
+cp "$TRAVIS_BUILD_DIR/$file_name" $(pwd)
+git add "$file_name"
git status
git commit -a -m "$pkgname $pkgver" -m "build_log: $TRAVIS_BUILD_WEB_URL"
git pull --rebase && git push