summarylogtreecommitdiffstats
path: root/.travis_deploy.sh
diff options
context:
space:
mode:
authorbartus2019-10-12 22:00:07 +0200
committerbartus2020-05-30 18:42:19 +0200
commitf7bee5ae021a29148327a4233652967680d9316d (patch)
treecd4dcd53abd949ae34574f2edca2ee882fdbce16 /.travis_deploy.sh
parentf87ff51c52d53c58833e3c485fcd95e68e7ca45c (diff)
downloadaur-f7bee5ae021a29148327a4233652967680d9316d.tar.gz
Travis: init
Diffstat (limited to '.travis_deploy.sh')
-rw-r--r--.travis_deploy.sh8
1 files changed, 8 insertions, 0 deletions
diff --git a/.travis_deploy.sh b/.travis_deploy.sh
new file mode 100644
index 000000000000..ac569f54e1a4
--- /dev/null
+++ b/.travis_deploy.sh
@@ -0,0 +1,8 @@
+. PKGBUILD
+git clone https://$GITHUB_ACCESS_TOKEN@github.com/bartoszek/AUR-repo.git
+cd AUR-repo
+cp $TRAVIS_BUILD_DIR/$pkgname-$pkgver*.pkg.tar.xz $(pwd)
+git add $pkgname-$pkgver*.pkg.tar.xz
+git status
+git commit -a -m "$pkgname $pkgver" -m "build_log: $TRAVIS_BUILD_WEB_URL"
+git push