summarylogtreecommitdiffstats
path: root/00-fix-sbin.patch
diff options
context:
space:
mode:
authorpyamsoft2022-10-18 20:36:08 -0700
committerpyamsoft2022-10-18 20:36:08 -0700
commite0825014a017763ad5079fd311af3c9b7c438b8d (patch)
tree2ee6782627e41ab1d0dd4a06a1a34f50cc791191 /00-fix-sbin.patch
parent22d3b536f79cfae70a27d6831b2d9dcca0f702ed (diff)
downloadaur-e0825014a017763ad5079fd311af3c9b7c438b8d.tar.gz
Patch to fix sbin path to bin
Diffstat (limited to '00-fix-sbin.patch')
-rw-r--r--00-fix-sbin.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/00-fix-sbin.patch b/00-fix-sbin.patch
new file mode 100644
index 000000000000..6ddf8dc17ca4
--- /dev/null
+++ b/00-fix-sbin.patch
@@ -0,0 +1,19 @@
+--- a/Makefile 2022-10-18 20:31:00.780113857 -0700
++++ b/Makefile 2022-10-18 20:31:14.680216830 -0700
+@@ -9,13 +9,13 @@
+ $(CXX) $(CXXFLAGS) $(cppfiles) -o $(name)
+
+ install: $(name)
+- mkdir -p $(DESTDIR)/usr/sbin
++ mkdir -p $(DESTDIR)/usr/bin
+ mkdir -p $(DESTDIR)/usr/lib/systemd/system
+- install -m 540 $(name) $(DESTDIR)/usr/sbin
++ install -m 540 $(name) $(DESTDIR)/usr/bin
+ install -m 644 $(name).service $(DESTDIR)/usr/lib/systemd/system
+
+ uninstall:
+- rm -f $(DESTDIR)/usr/sbin/$(name)
++ rm -f $(DESTDIR)/usr/bin/$(name)
+ rm -f $(DESTDIR)/usr/lib/systemd/system/$(name).service
+
+ clean: