summarylogtreecommitdiffstats
path: root/0000-cgnplp-po-Makefile-quote-spaces.patch
diff options
context:
space:
mode:
authorChris Severance2018-11-05 12:44:57 -0500
committerChris Severance2018-11-05 12:44:57 -0500
commita29a8721f37aff5c609d8e2f09b7058de98d9010 (patch)
treef7c4862305ad6d95ef36807545a738c29aa9a30d /0000-cgnplp-po-Makefile-quote-spaces.patch
parent018abbf0eca7c9bf7e5b0efb3b1a289374975a1c (diff)
downloadaur-a29a8721f37aff5c609d8e2f09b7058de98d9010.tar.gz
autu: Update to 3.60-1 Fix build for paths with spaces
Diffstat (limited to '0000-cgnplp-po-Makefile-quote-spaces.patch')
-rw-r--r--0000-cgnplp-po-Makefile-quote-spaces.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/0000-cgnplp-po-Makefile-quote-spaces.patch b/0000-cgnplp-po-Makefile-quote-spaces.patch
new file mode 100644
index 000000000000..9cab52a5ad33
--- /dev/null
+++ b/0000-cgnplp-po-Makefile-quote-spaces.patch
@@ -0,0 +1,46 @@
+--- cndrvcups-common-4.00/cngplp/po/Makefile.orig 2018-11-03 12:01:57.233864195 -0400
++++ cndrvcups-common-4.00/cngplp/po/Makefile 2018-11-03 11:55:35.019161804 -0400
+@@ -130,36 +130,36 @@ $(srcdir)/$(GETTEXT_PACKAGE).pot: $(POTF
+ install: install-exec install-data
+ install-exec:
+ install-data: install-data-yes
+ install-data-no: all
+ install-data-yes: all
+- $(MKINSTALLDIRS) $(DESTDIR)$(datadir); \
++ $(MKINSTALLDIRS) "$(DESTDIR)$(datadir)"; \
+ catalogs='$(CATALOGS)'; \
+ for cat in $$catalogs; do \
+ cat=`basename $$cat`; \
+ case "$$cat" in \
+ *.gmo) destdir=$(gnulocaledir);; \
+ *) destdir=$(localedir);; \
+ esac; \
+ lang=`echo $$cat | sed 's/\$(CATOBJEXT)$$//'`; \
+- dir=$(DESTDIR)$$destdir/$$lang/LC_MESSAGES; \
+- $(MKINSTALLDIRS) $$dir; \
++ dir="$(DESTDIR)$$destdir/$$lang/LC_MESSAGES"; \
++ $(MKINSTALLDIRS) "$$dir"; \
+ if test -r $$cat; then \
+- $(INSTALL_DATA) $$cat $$dir/$(GETTEXT_PACKAGE)$(INSTOBJEXT); \
++ $(INSTALL_DATA) $$cat "$$dir/$(GETTEXT_PACKAGE)$(INSTOBJEXT)"; \
+ echo "installing $$cat as $$dir/$(GETTEXT_PACKAGE)$(INSTOBJEXT)"; \
+ else \
+- $(INSTALL_DATA) $(srcdir)/$$cat $$dir/$(GETTEXT_PACKAGE)$(INSTOBJEXT); \
++ $(INSTALL_DATA) $(srcdir)/$$cat "$$dir/$(GETTEXT_PACKAGE)$(INSTOBJEXT)"; \
+ echo "installing $(srcdir)/$$cat as" \
+ "$$dir/$(GETTEXT_PACKAGE)$(INSTOBJEXT)"; \
+ fi; \
+ if test -r $$cat.m; then \
+- $(INSTALL_DATA) $$cat.m $$dir/$(GETTEXT_PACKAGE)$(INSTOBJEXT).m; \
++ $(INSTALL_DATA) $$cat.m "$$dir/$(GETTEXT_PACKAGE)$(INSTOBJEXT).m"; \
+ echo "installing $$cat.m as $$dir/$(GETTEXT_PACKAGE)$(INSTOBJEXT).m"; \
+ else \
+ if test -r $(srcdir)/$$cat.m ; then \
+ $(INSTALL_DATA) $(srcdir)/$$cat.m \
+- $$dir/$(GETTEXT_PACKAGE)$(INSTOBJEXT).m; \
++ "$$dir/$(GETTEXT_PACKAGE)$(INSTOBJEXT).m"; \
+ echo "installing $(srcdir)/$$cat as" \
+ "$$dir/$(GETTEXT_PACKAGE)$(INSTOBJEXT).m"; \
+ else \
+ true; \
+ fi; \