summarylogtreecommitdiffstats
path: root/0001-AUR-Pkgbuild-changes.patch
diff options
context:
space:
mode:
authorStelios Tsampas2024-04-15 13:09:25 +0300
committerStelios Tsampas2024-04-15 13:09:25 +0300
commit761b47d407a5df415966458421975373ee9706db (patch)
treeb033d5ccc9cc3220e8d623641354e6a4c225fe2c /0001-AUR-Pkgbuild-changes.patch
parent1387b5b8dbcbb9b8fd0b8266463a9a87effa1771 (diff)
downloadaur-761b47d407a5df415966458421975373ee9706db.tar.gz
[proton-experimental] Version 9.0-20240411
Diffstat (limited to '0001-AUR-Pkgbuild-changes.patch')
-rw-r--r--0001-AUR-Pkgbuild-changes.patch24
1 files changed, 12 insertions, 12 deletions
diff --git a/0001-AUR-Pkgbuild-changes.patch b/0001-AUR-Pkgbuild-changes.patch
index d465c5de540b..133428c14493 100644
--- a/0001-AUR-Pkgbuild-changes.patch
+++ b/0001-AUR-Pkgbuild-changes.patch
@@ -1,7 +1,7 @@
-From ef9011785ef9e93507e1347a2a9dd7882fc3320f Mon Sep 17 00:00:00 2001
+From 6727a5f84148c2a6f8e9fc2b901321dd32d9e3cf Mon Sep 17 00:00:00 2001
From: Stelios Tsampas <loathingkernel@gmail.com>
Date: Wed, 26 Apr 2023 14:22:23 +0300
-Subject: [PATCH 1/7] AUR Pkgbuild changes
+Subject: [PATCH 1/6] AUR Pkgbuild changes
---
Makefile.in | 76 ++++++++++++++++++++++++++--------
@@ -20,7 +20,7 @@ Subject: [PATCH 1/7] AUR Pkgbuild changes
13 files changed, 89 insertions(+), 43 deletions(-)
diff --git a/Makefile.in b/Makefile.in
-index b88483f7..822f0382 100644
+index 0f98d7cf..64f886eb 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -50,11 +50,12 @@ else
@@ -200,7 +200,7 @@ index b88483f7..822f0382 100644
$(eval $(call rules-source,vkd3d-proton,$(SRCDIR)/vkd3d-proton))
$(eval $(call rules-meson,vkd3d-proton,32,CROSS))
$(eval $(call rules-meson,vkd3d-proton,64,CROSS))
-@@ -928,14 +974,14 @@ $(FONTS_OBJ)/source-han/%.ttf: $$(%.ttf_CIDFONT) $$(%.ttf_FEATURES) $$(%.ttf_SEQ
+@@ -919,14 +965,14 @@ $(FONTS_OBJ)/source-han/%.ttf: $$(%.ttf_CIDFONT) $$(%.ttf_FEATURES) $$(%.ttf_SEQ
mkdir -p $(FONTS_OBJ)/source-han
# Do not immediately create the target file, so that make is interrupted
# it will restart again
@@ -218,7 +218,7 @@ index b88483f7..822f0382 100644
mv $@.tmp $@
$(FONTS_OBJ)/ume-gothic/%.ttf: $$(%.ttf_FONT) $$(%.ttf_NAMETABLE_PATCH)
-@@ -945,12 +991,12 @@ $(FONTS_OBJ)/ume-gothic/%.ttf: $$(%.ttf_FONT) $$(%.ttf_NAMETABLE_PATCH)
+@@ -936,12 +982,12 @@ $(FONTS_OBJ)/ume-gothic/%.ttf: $$(%.ttf_FONT) $$(%.ttf_NAMETABLE_PATCH)
ttx -o $@ -m $($(notdir $@)_FONT) $(FONTS_OBJ)/ume-gothic/$(notdir $(basename $($(notdir $@)_NAMETABLE_PATCH))).ttx
$(simsun.ttc): $(simsun.ttf) $(nsimsun.ttf)
@@ -234,7 +234,7 @@ index b88483f7..822f0382 100644
$(micross.ttf): $(FONTS)/scripts/merge.py $(noto_sans.ttf) $(noto_sans_arabic.ttf) $(noto_sans_armenian.ttf) $(noto_sans_bengali.ttf) $(noto_sans_coptic.ttf) \
$(noto_sans_georgian.ttf) $(noto_sans_gujarati.ttf) $(noto_sans_hebrew.ttf) $(noto_sans_khmer.ttf) $(noto_sans_tamil.ttf) \
-@@ -1076,8 +1122,8 @@ all-dist: $(DIST_OVR32) $(DIST_OVR64)
+@@ -1090,8 +1136,8 @@ all-dist: $(DIST_OVR32) $(DIST_OVR64)
##
default_pfx: wine gst_good gst_libav gst_plugins_rs lsteamclient steamexe vrclient wineopenxr dxvk dxvk-nvapi vkd3d-proton
@@ -245,7 +245,7 @@ index b88483f7..822f0382 100644
rm -rf $(abspath $(DIST_PREFIX))
python3 $(SRCDIR)/default_pfx.py $(abspath $(DIST_PREFIX)) $(abspath $(DST_DIR))
-@@ -1209,7 +1255,6 @@ ifeq ($(ENABLE_CCACHE),1)
+@@ -1223,7 +1269,6 @@ ifeq ($(ENABLE_CCACHE),1)
export CCACHE_DIR := $(if $(CCACHE_DIR),$(CCACHE_DIR),$(HOME)/.ccache)
override DOCKER_OPTS := -v $(CCACHE_DIR):$(CCACHE_DIR)$(CONTAINER_MOUNT_OPTS) $(CCACHE_ENV) -e CCACHE_DIR=$(CCACHE_DIR) $(DOCKER_OPTS)
else
@@ -253,7 +253,7 @@ index b88483f7..822f0382 100644
override DOCKER_OPTS := $(CCACHE_ENV) -e CCACHE_DISABLE=1 $(DOCKER_OPTS)
endif
-@@ -1224,9 +1269,6 @@ ifeq ($(CONTAINER_ENGINE),)
+@@ -1238,9 +1283,6 @@ ifeq ($(CONTAINER_ENGINE),)
CONTAINER_ENGINE := docker
endif
@@ -465,10 +465,10 @@ index 5c3b59a3..ed6589e0 100644
winebuild --$(lastword $(subst ., ,$(4))) --fake-module -E "$(basename $(4)).spec" -o "$(4).fake"
mkdir -p $$($(2)_LIBDIR$(3))/$(LIBDIR_WINE_$(3))
diff --git a/proton b/proton
-index 47776ade..115a09b4 100755
+index 16f82b34..8f9d03b0 100755
--- a/proton
+++ b/proton
-@@ -423,7 +423,6 @@ class Proton:
+@@ -424,7 +424,6 @@ class Proton:
self.wine_bin = self.bin_dir + "wine"
self.wine64_bin = self.bin_dir + "wine64"
self.wineserver_bin = self.bin_dir + "wineserver"
@@ -476,7 +476,7 @@ index 47776ade..115a09b4 100755
def path(self, d):
return self.base_dir + d
-@@ -1510,8 +1509,6 @@ if __name__ == "__main__":
+@@ -1537,8 +1536,6 @@ if __name__ == "__main__":
g_proton = Proton(os.path.dirname(sys.argv[0]))
@@ -485,7 +485,7 @@ index 47776ade..115a09b4 100755
g_compatdata = CompatData(os.environ["STEAM_COMPAT_DATA_PATH"])
-@@ -1520,7 +1517,8 @@ if __name__ == "__main__":
+@@ -1547,7 +1544,8 @@ if __name__ == "__main__":
g_session.init_wine()
if g_proton.missing_default_prefix():