summarylogtreecommitdiffstats
path: root/0001-AUR-Pkgbuild-changes.patch
diff options
context:
space:
mode:
authorStelios Tsampas2023-07-08 16:30:27 +0300
committerStelios Tsampas2023-07-08 16:30:27 +0300
commit58a153d770e80cbee5b95f0546cfe7585fef3c2b (patch)
treedd5cccfe98dba98fb134c7af8f57a5d6e9209b02 /0001-AUR-Pkgbuild-changes.patch
parent0380ba6f206f5cdd88a42ed5332da11b0de36cc1 (diff)
downloadaur-58a153d770e80cbee5b95f0546cfe7585fef3c2b.tar.gz
[proton-ge-custom] Try to fix ddraw.dll
Diffstat (limited to '0001-AUR-Pkgbuild-changes.patch')
-rw-r--r--0001-AUR-Pkgbuild-changes.patch19
1 files changed, 14 insertions, 5 deletions
diff --git a/0001-AUR-Pkgbuild-changes.patch b/0001-AUR-Pkgbuild-changes.patch
index 73db6447a7c9..5fd5bfc4e472 100644
--- a/0001-AUR-Pkgbuild-changes.patch
+++ b/0001-AUR-Pkgbuild-changes.patch
@@ -1,10 +1,10 @@
-From b41ec35863a8d8f197dda3b509164663e0bb3db9 Mon Sep 17 00:00:00 2001
+From 7733c5aebe66b9309cb76cacfaec191a1c96e9b5 Mon Sep 17 00:00:00 2001
From: Stelios Tsampas <loathingkernel@gmail.com>
Date: Tue, 7 Feb 2023 22:00:48 +0200
Subject: [PATCH 1/3] AUR Pkgbuild changes
---
- Makefile.in | 78 +++++++++++++++++++++++++++-------
+ Makefile.in | 80 ++++++++++++++++++++++++++--------
compatibilitytool.vdf.template | 2 +-
configure.sh | 2 +
make/rules-autoconf.mk | 4 +-
@@ -16,10 +16,10 @@ Subject: [PATCH 1/3] AUR Pkgbuild changes
make/rules-winemaker.mk | 2 +-
proton | 6 +--
toolmanifest_runtime.vdf | 3 --
- 12 files changed, 90 insertions(+), 40 deletions(-)
+ 12 files changed, 91 insertions(+), 41 deletions(-)
diff --git a/Makefile.in b/Makefile.in
-index 9726d2f1..cbebe144 100644
+index 9726d2f1..86278f43 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -24,7 +24,6 @@ SHELL := /bin/bash
@@ -201,6 +201,15 @@ index 9726d2f1..cbebe144 100644
$(eval $(call rules-source,dxvk-nvapi,$(SRCDIR)/dxvk-nvapi))
$(eval $(call rules-meson,dxvk-nvapi,32,CROSS))
$(eval $(call rules-meson,dxvk-nvapi,64,CROSS))
+@@ -741,7 +788,7 @@ VKD3D_CONFIGURE_ARGS = \
+ --disable-demos \
+ --without-ncurses \
+
+-VKD3D_LDFLAGS = -static-libgcc $(CROSSLDFLAGS)
++VKD3D_LDFLAGS = -static -static-libgcc -static-libstdc++ $(CROSSLDFLAGS)
+ VKD3D_DEPENDS = vulkan-loader vulkan-headers spirv-headers
+
+ $(eval $(call rules-source,vkd3d,$(SRCDIR)/vkd3d))
@@ -772,6 +819,9 @@ VKD3D_PROTON_MESON_ARGS32 = --bindir=$(VKD3D_PROTON_DST32)/lib/wine/vkd3d-proton
VKD3D_PROTON_MESON_ARGS64 = --bindir=$(VKD3D_PROTON_DST64)/lib64/wine/vkd3d-proton
VKD3D_PROTON_DEPENDS = glslang
@@ -460,7 +469,7 @@ index 5c3b59a3..ed6589e0 100644
winebuild --$(lastword $(subst ., ,$(4))) --fake-module -E "$(basename $(4)).spec" -o "$(4).fake"
mkdir -p $$($(2)_LIBDIR$(3))/$(LIBDIR_WINE_$(3))
diff --git a/proton b/proton
-index 0e6fde18..789e1cec 100755
+index 35b0d144..c581144f 100755
--- a/proton
+++ b/proton
@@ -423,7 +423,6 @@ class Proton: