summarylogtreecommitdiffstats
path: root/0001-AUR-Pkgbuild-changes.patch
diff options
context:
space:
mode:
authorStelios Tsampas2023-11-07 22:01:16 +0200
committerStelios Tsampas2023-11-07 22:01:16 +0200
commita892d824bc77d10aef1a3e7ad5c180c16f3b5c30 (patch)
tree6a56e6f64e96725e0bfc4e123bcc62efda7ab8c5 /0001-AUR-Pkgbuild-changes.patch
parent60649805ebd3c59d514c1682637c95ab1f162a7f (diff)
downloadaur-a892d824bc77d10aef1a3e7ad5c180c16f3b5c30.tar.gz
[proton-ge-custom] Version GE-Proton8-23
Diffstat (limited to '0001-AUR-Pkgbuild-changes.patch')
-rw-r--r--0001-AUR-Pkgbuild-changes.patch127
1 files changed, 50 insertions, 77 deletions
diff --git a/0001-AUR-Pkgbuild-changes.patch b/0001-AUR-Pkgbuild-changes.patch
index b4df46c058ac..bd077dfb1278 100644
--- a/0001-AUR-Pkgbuild-changes.patch
+++ b/0001-AUR-Pkgbuild-changes.patch
@@ -1,26 +1,26 @@
-From 86358fc89a591b7f070765e350583280b27ee538 Mon Sep 17 00:00:00 2001
+From 39953a51fd4f7a0753a9c0f9834e5713ae3e7419 Mon Sep 17 00:00:00 2001
From: Stelios Tsampas <loathingkernel@gmail.com>
Date: Tue, 7 Feb 2023 22:00:48 +0200
Subject: [PATCH 1/6] AUR Pkgbuild changes
---
- Makefile.in | 89 +++++++++++++++++++++++++++-------
+ Makefile.in | 73 ++++++++++++++++++++++++++--------
compatibilitytool.vdf.template | 2 +-
configure.sh | 2 +
make/rules-autoconf.mk | 4 +-
make/rules-cargo.mk | 4 +-
make/rules-cmake.mk | 4 +-
- make/rules-common.mk | 18 ++++---
+ make/rules-common.mk | 18 +++++----
make/rules-configure.mk | 4 +-
make/rules-makedep.mk | 4 +-
make/rules-meson.mk | 3 +-
make/rules-winemaker.mk | 2 +-
proton | 6 +--
toolmanifest_runtime.vdf | 3 --
- 13 files changed, 102 insertions(+), 43 deletions(-)
+ 13 files changed, 87 insertions(+), 42 deletions(-)
diff --git a/Makefile.in b/Makefile.in
-index 7fdf6e70..314da018 100644
+index 20a1bffc..e8b625e8 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -50,11 +50,12 @@ else
@@ -67,25 +67,21 @@ index 7fdf6e70..314da018 100644
GST_ORC_MESON_ARGS := \
+ $(GST_LTO) \
- -Dorc-test=disabled \
-Dexamples=disabled \
-Dtests=disabled \
-@@ -125,10 +135,14 @@ $(eval $(call rules-meson,gst_orc,64))
+ -Dbenchmarks=disabled \
+@@ -125,7 +135,10 @@ $(eval $(call rules-meson,gst_orc,64))
##
GSTREAMER_MESON_ARGS := \
+ $(GST_LTO) \
-+ -Ddoc=disabled \
-Dgst_parse=false \
- -Dbenchmarks=disabled \
- -Dtools=disabled \
- -Dbash-completion=disabled \
+ -Dptp-helper-permissions=capabilities \
+ -Ddbghelp=disabled \
- -Dexamples=disabled \
- -Dtests=disabled \
-Dintrospection=disabled \
-@@ -149,6 +163,11 @@ $(eval $(call rules-meson,gstreamer,64))
+ -Dgobject-cast-checks=disabled \
+ -Dglib-asserts=disabled \
+@@ -149,6 +162,11 @@ $(eval $(call rules-meson,gstreamer,64))
## graphene
##
@@ -97,39 +93,31 @@ index 7fdf6e70..314da018 100644
$(eval $(call rules-source,graphene,$(SRCDIR)/graphene))
$(eval $(call rules-meson,graphene,32))
$(eval $(call rules-meson,graphene,64))
-@@ -159,6 +178,10 @@ $(eval $(call rules-meson,graphene,64))
+@@ -159,6 +177,7 @@ $(eval $(call rules-meson,graphene,64))
##
GST_BASE_MESON_ARGS := \
+ $(GST_LTO) \
-+ -Ddoc=disabled \
+ -Dauto_features=disabled \
+ -Dintrospection=disabled \
+ -Dgobject-cast-checks=disabled \
+@@ -168,6 +187,7 @@ GST_BASE_MESON_ARGS := \
+ -Dexamples=disabled \
+ -Dtests=disabled \
+ -Ddoc=disabled \
+ -Dtools=disabled \
-+ -Dauto_features=disabled \
- -Dalsa=disabled \
- -Daudiomixer=disabled \
- -Daudiorate=disabled \
-@@ -189,7 +212,9 @@ GST_BASE_MESON_ARGS := \
- -Dorc=enabled \
- -Dx11=enabled \
- -Dgl=enabled \
-- -Dgl-graphene=enabled
-+ -Dgl-graphene=enabled \
-+ -Dgl_platform=glx,egl \
-+ --wrap-mode nodownload \
-
- GST_BASE_DEPENDS = gst_orc graphene gstreamer
-
-@@ -203,6 +228,9 @@ $(eval $(call rules-meson,gst_base,64))
+ -Dadder=enabled \
+ -Dapp=enabled \
+ -Daudioconvert=enabled \
+@@ -200,6 +220,7 @@ $(eval $(call rules-meson,gst_base,64))
##
GST_GOOD_MESON_ARGS := \
+ $(GST_LTO) \
-+ -Ddoc=disabled \
-+ -Dauto_features=disabled \
- -Daalib=disabled \
- -Dalpha=disabled \
- -Dapetag=disabled \
-@@ -277,6 +305,7 @@ $(eval $(call rules-meson,gst_good,64))
+ -Dauto_features=disabled \
+ -Dgobject-cast-checks=disabled \
+ -Dglib-asserts=disabled \
+@@ -246,6 +267,7 @@ $(eval $(call rules-meson,gst_good,64))
FFMPEG_CONFIGURE_ARGS := \
--enable-shared \
@@ -137,7 +125,7 @@ index 7fdf6e70..314da018 100644
--disable-static \
--disable-everything \
--disable-programs \
-@@ -300,6 +329,11 @@ FFMPEG_CONFIGURE_ARGS := \
+@@ -269,6 +291,11 @@ FFMPEG_CONFIGURE_ARGS := \
--enable-decoder=aac \
--enable-demuxer=xwma
@@ -146,41 +134,26 @@ index 7fdf6e70..314da018 100644
+FFMPEG_CONFIGURE_ARGS64 = --optflags="$(COMMON_FLAGS) $(COMMON_FLAGS64)" $(FFMPEG_LTO_OPTS64)
+FFMPEG_CONFIGURE_ARGS32 = --optflags="$(COMMON_FLAGS) $(COMMON_FLAGS32)" $(FFMPEG_LTO_OPTS32)
+
- $(eval $(call rules-source,ffmpeg,$(SRCDIR)/FFmpeg))
+ $(eval $(call rules-source,ffmpeg,$(SRCDIR)/ffmpeg))
$(eval $(call rules-configure,ffmpeg,32))
$(eval $(call rules-configure,ffmpeg,64))
-@@ -344,6 +378,8 @@ $(OBJ)/.gst_plugins_rs-post-build32:
+@@ -313,6 +340,7 @@ $(OBJ)/.gst_plugins_rs-post-build32:
##
GST_BAD_MESON_ARGS := \
+ $(GST_LTO) \
-+ -Ddoc=disabled \
- -Dfbdev=disabled \
- -Ddecklink=disabled \
- -Dcurl=disabled \
-@@ -362,7 +398,13 @@ GST_BAD_MESON_ARGS := \
- -Dvoamrwbenc=disabled \
- -Dnvcodec=disabled \
- -Dx265=disabled \
-+ -Dopenexr=disabled \
-+ -Dzxing=disabled \
-+ -Dva=disabled \
-+ -Dqsv=disabled \
-+ -Dexamples=disabled \
- -Dtests=disabled \
-+ -Dintrospection=disabled \
+ -Dauto_features=disabled \
+ -Dintrospection=disabled \
-Dgobject-cast-checks=disabled \
- -Dglib-asserts=disabled \
- -Dglib-checks=disabled \
-@@ -380,6 +422,7 @@ $(eval $(call rules-meson,gst_bad,64))
+@@ -425,6 +453,7 @@ $(eval $(call rules-meson,gst_bad,64))
##
GST_UGLY_MESON_ARGS := \
+ $(GST_LTO) \
- -Ddoc='disabled' \
- -Dtests=disabled \
+ -Dauto_features=disabled \
-Dgobject-cast-checks=disabled \
-@@ -464,7 +507,7 @@ $(eval $(call rules-cmake,openxr,64))
+ -Dglib-asserts=disabled \
+@@ -514,7 +543,7 @@ $(eval $(call rules-cmake,openxr,64))
## Note 32-bit is not supported by SteamVR, so we don't build it.
##
@@ -189,7 +162,7 @@ index 7fdf6e70..314da018 100644
WINEOPENXR_DEPENDS = wine openxr
$(eval $(call rules-source,wineopenxr,$(SRCDIR)/wineopenxr))
-@@ -542,6 +585,9 @@ OPENFST_CONFIGURE_ARGS = \
+@@ -592,6 +621,9 @@ OPENFST_CONFIGURE_ARGS = \
--with-pic \
--disable-bin \
@@ -199,7 +172,7 @@ index 7fdf6e70..314da018 100644
$(eval $(call rules-source,openfst,$(SRCDIR)/openfst))
$(eval $(call rules-autoconf,openfst,32))
$(eval $(call rules-autoconf,openfst,64))
-@@ -604,7 +650,11 @@ WINE_SOURCE_ARGS = \
+@@ -654,7 +686,11 @@ WINE_SOURCE_ARGS = \
--exclude dlls/winevulkan/winevulkan.spec
WINE_CONFIGURE_ARGS = \
@@ -211,7 +184,7 @@ index 7fdf6e70..314da018 100644
--disable-tests
WINE_CONFIGURE_ARGS32 = \
-@@ -661,6 +711,9 @@ DXVK_MESON_ARGS32 = --bindir=$(DXVK_DST32)/lib/wine/dxvk
+@@ -711,6 +747,9 @@ DXVK_MESON_ARGS32 = --bindir=$(DXVK_DST32)/lib/wine/dxvk
DXVK_MESON_ARGS64 = --bindir=$(DXVK_DST64)/lib64/wine/dxvk
DXVK_DEPENDS = glslang
@@ -221,7 +194,7 @@ index 7fdf6e70..314da018 100644
$(eval $(call rules-source,dxvk,$(SRCDIR)/dxvk))
$(eval $(call rules-meson,dxvk,32,CROSS))
$(eval $(call rules-meson,dxvk,64,CROSS))
-@@ -688,6 +741,9 @@ $(OBJ)/.dxvk-post-build32:
+@@ -738,6 +777,9 @@ $(OBJ)/.dxvk-post-build32:
DXVK_NVAPI_MESON_ARGS32 = --bindir=$(DXVK_NVAPI_DST32)/lib/wine/nvapi
DXVK_NVAPI_MESON_ARGS64 = --bindir=$(DXVK_NVAPI_DST64)/lib64/wine/nvapi
@@ -231,7 +204,7 @@ index 7fdf6e70..314da018 100644
$(eval $(call rules-source,dxvk-nvapi,$(SRCDIR)/dxvk-nvapi))
$(eval $(call rules-meson,dxvk-nvapi,32,CROSS))
$(eval $(call rules-meson,dxvk-nvapi,64,CROSS))
-@@ -762,6 +818,9 @@ ifneq ($(UNSTRIPPED_BUILD),)
+@@ -812,6 +854,9 @@ ifneq ($(UNSTRIPPED_BUILD),)
VKD3D_PROTON_MESON_ARGS = -Denable_trace=true
endif
@@ -241,7 +214,7 @@ index 7fdf6e70..314da018 100644
$(eval $(call rules-source,vkd3d-proton,$(SRCDIR)/vkd3d-proton))
$(eval $(call rules-meson,vkd3d-proton,32,CROSS))
$(eval $(call rules-meson,vkd3d-proton,64,CROSS))
-@@ -1058,14 +1117,14 @@ $(FONTS_OBJ)/source-han/%.ttf: $$(%.ttf_CIDFONT) $$(%.ttf_FEATURES) $$(%.ttf_SEQ
+@@ -1108,14 +1153,14 @@ $(FONTS_OBJ)/source-han/%.ttf: $$(%.ttf_CIDFONT) $$(%.ttf_FEATURES) $$(%.ttf_SEQ
mkdir -p $(FONTS_OBJ)/source-han
# Do not immediately create the target file, so that make is interrupted
# it will restart again
@@ -259,7 +232,7 @@ index 7fdf6e70..314da018 100644
mv $@.tmp $@
$(FONTS_OBJ)/ume-gothic/%.ttf: $$(%.ttf_FONT) $$(%.ttf_NAMETABLE_PATCH)
-@@ -1075,12 +1134,12 @@ $(FONTS_OBJ)/ume-gothic/%.ttf: $$(%.ttf_FONT) $$(%.ttf_NAMETABLE_PATCH)
+@@ -1125,12 +1170,12 @@ $(FONTS_OBJ)/ume-gothic/%.ttf: $$(%.ttf_FONT) $$(%.ttf_NAMETABLE_PATCH)
ttx -o $@ -m $($(notdir $@)_FONT) $(FONTS_OBJ)/ume-gothic/$(notdir $(basename $($(notdir $@)_NAMETABLE_PATCH))).ttx
$(simsun.ttc): $(simsun.ttf) $(nsimsun.ttf)
@@ -275,7 +248,7 @@ index 7fdf6e70..314da018 100644
$(micross.ttf): $(FONTS)/scripts/merge.py $(noto_sans.ttf) $(noto_sans_arabic.ttf) $(noto_sans_armenian.ttf) $(noto_sans_bengali.ttf) $(noto_sans_coptic.ttf) \
$(noto_sans_georgian.ttf) $(noto_sans_gujarati.ttf) $(noto_sans_hebrew.ttf) $(noto_sans_khmer.ttf) $(noto_sans_tamil.ttf) \
-@@ -1206,8 +1265,8 @@ all-dist: $(DIST_OVR32) $(DIST_OVR64)
+@@ -1256,8 +1301,8 @@ all-dist: $(DIST_OVR32) $(DIST_OVR64)
##
default_pfx: wine gst_good gst_libav gst_plugins_rs lsteamclient steamexe vrclient wineopenxr dxvk dxvk-nvapi vkd3d-proton
@@ -286,7 +259,7 @@ index 7fdf6e70..314da018 100644
rm -rf $(abspath $(DIST_PREFIX))
python3 $(SRCDIR)/default_pfx.py $(abspath $(DIST_PREFIX)) $(abspath $(DST_DIR))
-@@ -1349,7 +1408,6 @@ ifeq ($(ENABLE_CCACHE),1)
+@@ -1399,7 +1444,6 @@ ifeq ($(ENABLE_CCACHE),1)
export CCACHE_DIR := $(if $(CCACHE_DIR),$(CCACHE_DIR),$(HOME)/.ccache)
override DOCKER_OPTS := -v $(CCACHE_DIR):$(CCACHE_DIR)$(CONTAINER_MOUNT_OPTS) $(CCACHE_ENV) -e CCACHE_DIR=$(CCACHE_DIR) $(DOCKER_OPTS)
else
@@ -294,7 +267,7 @@ index 7fdf6e70..314da018 100644
override DOCKER_OPTS := $(CCACHE_ENV) -e CCACHE_DISABLE=1 $(DOCKER_OPTS)
endif
-@@ -1364,9 +1422,6 @@ ifeq ($(CONTAINER_ENGINE),)
+@@ -1414,9 +1458,6 @@ ifeq ($(CONTAINER_ENGINE),)
CONTAINER_ENGINE := docker
endif
@@ -318,7 +291,7 @@ index 5ac60e8b..e580cd20 100644
"from_oslist" "windows"
"to_oslist" "linux"
diff --git a/configure.sh b/configure.sh
-index 7b7ccf9c..cae93541 100755
+index 3b5f7a4a..d9297162 100755
--- a/configure.sh
+++ b/configure.sh
@@ -128,6 +128,7 @@ function configure() {
@@ -506,7 +479,7 @@ index 5c3b59a3..ed6589e0 100644
winebuild --$(lastword $(subst ., ,$(4))) --fake-module -E "$(basename $(4)).spec" -o "$(4).fake"
mkdir -p $$($(2)_LIBDIR$(3))/$(LIBDIR_WINE_$(3))
diff --git a/proton b/proton
-index 1fc072b1..eef65ead 100755
+index 8e061c39..64d25dc4 100755
--- a/proton
+++ b/proton
@@ -423,7 +423,6 @@ class Proton:
@@ -517,7 +490,7 @@ index 1fc072b1..eef65ead 100755
def path(self, d):
return self.base_dir + d
-@@ -1888,8 +1887,6 @@ if __name__ == "__main__":
+@@ -1894,8 +1893,6 @@ if __name__ == "__main__":
g_proton = Proton(os.path.dirname(sys.argv[0]))
@@ -526,7 +499,7 @@ index 1fc072b1..eef65ead 100755
g_compatdata = CompatData(os.environ["STEAM_COMPAT_DATA_PATH"])
-@@ -1898,7 +1895,8 @@ if __name__ == "__main__":
+@@ -1904,7 +1901,8 @@ if __name__ == "__main__":
g_session.init_wine()
if g_proton.missing_default_prefix():
@@ -549,5 +522,5 @@ index beddcbbb..b6f36788 100644
- "compatmanager_layer_name" "proton"
}
--
-2.42.0
+2.42.1