summarylogtreecommitdiffstats
path: root/0001-AUR-pkgbuild-changes.patch
diff options
context:
space:
mode:
authorStelios Tsampas2022-05-19 20:21:02 +0300
committerStelios Tsampas2022-05-19 20:21:02 +0300
commit24a8b9bcf716bb7a03e0ae07d1d70d38d33b053b (patch)
treec653b21a5402aa759a7bd7de288deb2d2c6a6e7e /0001-AUR-pkgbuild-changes.patch
parentff8921c62c347d5ff07ea8b9ce6560a2bf93a028 (diff)
downloadaur-24a8b9bcf716bb7a03e0ae07d1d70d38d33b053b.tar.gz
Disable inline asm for x86 ffmpeg
Diffstat (limited to '0001-AUR-pkgbuild-changes.patch')
-rw-r--r--0001-AUR-pkgbuild-changes.patch41
1 files changed, 29 insertions, 12 deletions
diff --git a/0001-AUR-pkgbuild-changes.patch b/0001-AUR-pkgbuild-changes.patch
index 910f03b85153..4fc722ad56e6 100644
--- a/0001-AUR-pkgbuild-changes.patch
+++ b/0001-AUR-pkgbuild-changes.patch
@@ -1,23 +1,23 @@
-From 1a751fb41cafa3e4ddef8de47d10cb1893977077 Mon Sep 17 00:00:00 2001
+From 7b588c7238904a574ed18d474e6e8e85887c774b Mon Sep 17 00:00:00 2001
From: Stelios Tsampas <loathingkernel@gmail.com>
Date: Mon, 18 Oct 2021 21:31:31 +0300
Subject: [PATCH 1/2] AUR pkgbuild changes
---
- Makefile.in | 46 ++++++++++++++++++++++++++++++-----------
+ Makefile.in | 51 +++++++++++++++++++++++++++++++----------
configure.sh | 2 ++
make/rules-autoconf.mk | 4 ++--
make/rules-cargo.mk | 4 +++-
make/rules-cmake.mk | 4 ++--
- make/rules-common.mk | 18 +++++++++-------
+ make/rules-common.mk | 18 +++++++++------
make/rules-configure.mk | 4 ++--
make/rules-meson.mk | 2 +-
make/rules-winemaker.mk | 2 +-
- proton | 6 ++----
- 10 files changed, 60 insertions(+), 32 deletions(-)
+ proton | 6 ++---
+ 10 files changed, 65 insertions(+), 32 deletions(-)
diff --git a/Makefile.in b/Makefile.in
-index 6e1b4d1..da46c76 100644
+index 6e1b4d1..eb459b8 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -63,7 +63,6 @@ ifeq ($(ENABLE_CCACHE),1)
@@ -84,7 +84,24 @@ index 6e1b4d1..da46c76 100644
$(GST_COMMON_MESON_ARGS)
GSTREAMER_DEPENDS = gst_orc
-@@ -692,7 +699,13 @@ WINE_SOURCE_ARGS = \
+@@ -519,11 +526,16 @@ $(eval $(call rules-meson,gst_good,64))
+
+ FFMPEG_CONFIGURE_ARGS := \
+ --enable-shared \
++ --enable-lto \
++ --disable-optimizations \
+ --disable-static \
+ --disable-everything \
+ --disable-programs \
+ --disable-doc \
+
++FFMPEG_CONFIGURE_ARGS64 = --optflags="$(COMMON_FLAGS) $(COMMON_FLAGS64)"
++FFMPEG_CONFIGURE_ARGS32 = --optflags="$(COMMON_FLAGS) $(COMMON_FLAGS32)" --disable-inline-asm
++
+ $(eval $(call rules-source,ffmpeg,$(SRCDIR)/ffmpeg))
+ $(eval $(call rules-configure,ffmpeg,32))
+ $(eval $(call rules-configure,ffmpeg,64))
+@@ -692,7 +704,13 @@ WINE_SOURCE_ARGS = \
--exclude include/config.h.in \
WINE_CONFIGURE_ARGS = \
@@ -98,7 +115,7 @@ index 6e1b4d1..da46c76 100644
--disable-tests
WINE_CONFIGURE_ARGS64 = --enable-win64
-@@ -755,6 +768,9 @@ $(OBJ)/.vrclient-post-source:
+@@ -755,6 +773,9 @@ $(OBJ)/.vrclient-post-source:
DXVK_MESON_ARGS32 = --bindir=$(DXVK_DST32)/lib/wine/dxvk
DXVK_MESON_ARGS64 = --bindir=$(DXVK_DST64)/lib64/wine/dxvk
@@ -108,7 +125,7 @@ index 6e1b4d1..da46c76 100644
$(eval $(call rules-source,dxvk,$(SRCDIR)/dxvk))
$(eval $(call rules-meson,dxvk,32,CROSS))
$(eval $(call rules-meson,dxvk,64,CROSS))
-@@ -777,6 +793,9 @@ $(OBJ)/.dxvk-post-build32:
+@@ -777,6 +798,9 @@ $(OBJ)/.dxvk-post-build32:
DXVK_NVAPI_MESON_ARGS32 = --bindir=$(DXVK_NVAPI_DST32)/lib/wine/nvapi
DXVK_NVAPI_MESON_ARGS64 = --bindir=$(DXVK_NVAPI_DST64)/lib64/wine/nvapi
@@ -118,7 +135,7 @@ index 6e1b4d1..da46c76 100644
$(eval $(call rules-source,dxvk-nvapi,$(SRCDIR)/dxvk-nvapi))
$(eval $(call rules-meson,dxvk-nvapi,32,CROSS))
$(eval $(call rules-meson,dxvk-nvapi,64,CROSS))
-@@ -840,10 +859,13 @@ VKD3D_PROTON_SOURCE_ARGS = \
+@@ -840,10 +864,13 @@ VKD3D_PROTON_SOURCE_ARGS = \
--exclude vkd3d_build.h.in \
--exclude vkd3d_version.h.in \
@@ -133,7 +150,7 @@ index 6e1b4d1..da46c76 100644
$(eval $(call rules-source,vkd3d-proton,$(SRCDIR)/vkd3d-proton))
$(eval $(call rules-meson,vkd3d-proton,32,CROSS))
$(eval $(call rules-meson,vkd3d-proton,64,CROSS))
-@@ -1081,14 +1103,14 @@ $(FONTS_OBJ)/source-han/%.ttf: $$(%.ttf_CIDFONT) $$(%.ttf_FEATURES) $$(%.ttf_SEQ
+@@ -1081,14 +1108,14 @@ $(FONTS_OBJ)/source-han/%.ttf: $$(%.ttf_CIDFONT) $$(%.ttf_FEATURES) $$(%.ttf_SEQ
mkdir -p $(FONTS_OBJ)/source-han
# Do not immediately create the target file, so that make is interrupted
# it will restart again
@@ -151,7 +168,7 @@ index 6e1b4d1..da46c76 100644
mv $@.tmp $@
$(FONTS_OBJ)/ume-gothic/%.ttf: $$(%.ttf_FONT) $$(%.ttf_NAMETABLE_PATCH)
-@@ -1098,10 +1120,10 @@ $(FONTS_OBJ)/ume-gothic/%.ttf: $$(%.ttf_FONT) $$(%.ttf_NAMETABLE_PATCH)
+@@ -1098,10 +1125,10 @@ $(FONTS_OBJ)/ume-gothic/%.ttf: $$(%.ttf_FONT) $$(%.ttf_NAMETABLE_PATCH)
ttx -o $@ -m $($(notdir $@)_FONT) $(FONTS_OBJ)/ume-gothic/$(notdir $(basename $($(notdir $@)_NAMETABLE_PATCH))).ttx
$(simsun.ttc): $(simsun.ttf) $(nsimsun.ttf)