summarylogtreecommitdiffstats
path: root/0001-AUR-pkgbuild-changes.patch
diff options
context:
space:
mode:
authorStelios Tsampas2022-08-17 12:54:16 +0300
committerStelios Tsampas2022-08-17 12:54:16 +0300
commit28a5cf31fbae9a8d0e27960689867755cb9811e4 (patch)
tree58247227a2bbca62c178c0cbe1f41705006a198d /0001-AUR-pkgbuild-changes.patch
parent12e48d5c65b57da85d660ec0640e123a1a29dea2 (diff)
downloadaur-28a5cf31fbae9a8d0e27960689867755cb9811e4.tar.gz
version: 7.0-4
Diffstat (limited to '0001-AUR-pkgbuild-changes.patch')
-rw-r--r--0001-AUR-pkgbuild-changes.patch114
1 files changed, 71 insertions, 43 deletions
diff --git a/0001-AUR-pkgbuild-changes.patch b/0001-AUR-pkgbuild-changes.patch
index 4fc722ad56e6..b3eb70c52714 100644
--- a/0001-AUR-pkgbuild-changes.patch
+++ b/0001-AUR-pkgbuild-changes.patch
@@ -1,23 +1,23 @@
-From 7b588c7238904a574ed18d474e6e8e85887c774b Mon Sep 17 00:00:00 2001
+From edeae15db607e337d0a83117efcd75025e425791 Mon Sep 17 00:00:00 2001
From: Stelios Tsampas <loathingkernel@gmail.com>
Date: Mon, 18 Oct 2021 21:31:31 +0300
-Subject: [PATCH 1/2] AUR pkgbuild changes
+Subject: [PATCH] AUR pkgbuild changes
---
- Makefile.in | 51 +++++++++++++++++++++++++++++++----------
+ Makefile.in | 60 +++++++++++++++++++++++++++++++++--------
configure.sh | 2 ++
- make/rules-autoconf.mk | 4 ++--
- make/rules-cargo.mk | 4 +++-
- make/rules-cmake.mk | 4 ++--
- make/rules-common.mk | 18 +++++++++------
- make/rules-configure.mk | 4 ++--
+ make/rules-autoconf.mk | 4 +--
+ make/rules-cargo.mk | 4 ++-
+ make/rules-cmake.mk | 4 +--
+ make/rules-common.mk | 18 ++++++++-----
+ make/rules-configure.mk | 4 +--
make/rules-meson.mk | 2 +-
make/rules-winemaker.mk | 2 +-
proton | 6 ++---
- 10 files changed, 65 insertions(+), 32 deletions(-)
+ 10 files changed, 75 insertions(+), 31 deletions(-)
diff --git a/Makefile.in b/Makefile.in
-index 6e1b4d1..eb459b8 100644
+index 4b0b98c..a4eb810 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -63,7 +63,6 @@ ifeq ($(ENABLE_CCACHE),1)
@@ -37,7 +37,7 @@ index 6e1b4d1..eb459b8 100644
endif
-@@ -175,11 +174,12 @@ else
+@@ -175,13 +174,24 @@ else
endif
CROSSLDFLAGS += -Wl,--file-alignment,4096
@@ -51,8 +51,20 @@ index 6e1b4d1..eb459b8 100644
+COMMON_FLAGS32 := -mstackrealign -mno-avx
CARGO_BUILD_ARG := --release
++ifneq ($(USE_LTO), 1)
++ GST_LTO :=
++ FFMPEG_LTO :=
++ FFMPEG_LTO_OPTS32 :=
++else
++ GST_LTO := -Db_lto=true
++ FFMPEG_LTO := --enable-lto
++ FFMPEG_LTO_OPTS32 := --disable-inline-asm
++endif
++
+ ##
+ ## Target configs
##
-@@ -364,8 +364,8 @@ ALL_TARGETS += dist
+@@ -364,8 +374,8 @@ ALL_TARGETS += dist
GOAL_TARGETS += dist
dist_prefix: wine gst_good gst_libav gst_plugins_rs
@@ -63,59 +75,76 @@ index 6e1b4d1..eb459b8 100644
rm -rf $(abspath $(DIST_PREFIX))
python3 $(SRCDIR)/default_pfx.py $(abspath $(DIST_PREFIX)) $(abspath $(DST_DIR)) $(STEAM_RUNTIME_RUNSH)
-@@ -431,6 +431,11 @@ $(eval $(call rules-meson,dav1d,64))
+@@ -431,6 +441,7 @@ $(eval $(call rules-meson,dav1d,64))
##
- GST_COMMON_MESON_ARGS := \
-+ -Db_lto=true \
-+ -Db_pie=true \
-+ -Ddoc=disabled \
-+ -Dintrospection=disabled \
-+ -Dgobject-cast-checks=disabled \
- -Dorc=enabled
-
GST_ORC_MESON_ARGS := \
-@@ -451,6 +456,8 @@ GSTREAMER_MESON_ARGS := \
++ $(GST_LTO) \
+ -Dorc-test=disabled
+
+ $(eval $(call rules-source,gst_orc,$(SRCDIR)/gst-orc))
+@@ -443,9 +454,14 @@ $(eval $(call rules-meson,gst_orc,64))
+ ##
+
+ GSTREAMER_MESON_ARGS := \
++ $(GST_LTO) \
++ -Ddoc=disabled \
+ -Dgst_parse=false \
-Dbenchmarks=disabled \
-Dtools=disabled \
- -Dbash-completion=disabled \
+ -Dptp-helper-permissions=capabilities \
+ -Ddbghelp=disabled \
- $(GST_COMMON_MESON_ARGS)
++ -Dintrospection=disabled \
+ -Dbash-completion=disabled
GSTREAMER_DEPENDS = gst_orc
-@@ -519,11 +526,16 @@ $(eval $(call rules-meson,gst_good,64))
+@@ -460,6 +476,8 @@ $(eval $(call rules-meson,gstreamer,64))
+ ##
+
+ GST_BASE_MESON_ARGS := \
++ $(GST_LTO) \
++ -Ddoc=disabled \
+ -Dauto_features=disabled \
+ -Dadder=enabled \
+ -Dapp=enabled \
+@@ -488,6 +506,8 @@ $(eval $(call rules-meson,gst_base,64))
+ ##
+
+ GST_GOOD_MESON_ARGS := \
++ $(GST_LTO) \
++ -Ddoc=disabled \
+ -Dauto_features=disabled \
+ -Daudioparsers=enabled \
+ -Dautodetect=enabled \
+@@ -517,11 +537,15 @@ $(eval $(call rules-meson,gst_good,64))
FFMPEG_CONFIGURE_ARGS := \
--enable-shared \
-+ --enable-lto \
-+ --disable-optimizations \
++ $(FFMPEG_LTO) \
--disable-static \
--disable-everything \
--disable-programs \
--disable-doc \
+FFMPEG_CONFIGURE_ARGS64 = --optflags="$(COMMON_FLAGS) $(COMMON_FLAGS64)"
-+FFMPEG_CONFIGURE_ARGS32 = --optflags="$(COMMON_FLAGS) $(COMMON_FLAGS32)" --disable-inline-asm
++FFMPEG_CONFIGURE_ARGS32 = --optflags="$(COMMON_FLAGS) $(COMMON_FLAGS32)" $(FFMPEG_LTO_OPTS32)
+
$(eval $(call rules-source,ffmpeg,$(SRCDIR)/ffmpeg))
$(eval $(call rules-configure,ffmpeg,32))
$(eval $(call rules-configure,ffmpeg,64))
-@@ -692,7 +704,13 @@ WINE_SOURCE_ARGS = \
+@@ -690,7 +714,11 @@ WINE_SOURCE_ARGS = \
--exclude include/config.h.in \
WINE_CONFIGURE_ARGS = \
+ --with-x \
+ --with-gstreamer \
-+ --with-faudio \
--with-mingw \
-+ --without-vkd3d \
+ --without-oss \
+ --disable-win16 \
--disable-tests
WINE_CONFIGURE_ARGS64 = --enable-win64
-@@ -755,6 +773,9 @@ $(OBJ)/.vrclient-post-source:
+@@ -753,6 +781,9 @@ $(OBJ)/.vrclient-post-source:
DXVK_MESON_ARGS32 = --bindir=$(DXVK_DST32)/lib/wine/dxvk
DXVK_MESON_ARGS64 = --bindir=$(DXVK_DST64)/lib64/wine/dxvk
@@ -125,7 +154,7 @@ index 6e1b4d1..eb459b8 100644
$(eval $(call rules-source,dxvk,$(SRCDIR)/dxvk))
$(eval $(call rules-meson,dxvk,32,CROSS))
$(eval $(call rules-meson,dxvk,64,CROSS))
-@@ -777,6 +798,9 @@ $(OBJ)/.dxvk-post-build32:
+@@ -775,6 +806,9 @@ $(OBJ)/.dxvk-post-build32:
DXVK_NVAPI_MESON_ARGS32 = --bindir=$(DXVK_NVAPI_DST32)/lib/wine/nvapi
DXVK_NVAPI_MESON_ARGS64 = --bindir=$(DXVK_NVAPI_DST64)/lib64/wine/nvapi
@@ -135,11 +164,10 @@ index 6e1b4d1..eb459b8 100644
$(eval $(call rules-source,dxvk-nvapi,$(SRCDIR)/dxvk-nvapi))
$(eval $(call rules-meson,dxvk-nvapi,32,CROSS))
$(eval $(call rules-meson,dxvk-nvapi,64,CROSS))
-@@ -840,10 +864,13 @@ VKD3D_PROTON_SOURCE_ARGS = \
+@@ -838,9 +872,13 @@ VKD3D_PROTON_SOURCE_ARGS = \
--exclude vkd3d_build.h.in \
--exclude vkd3d_version.h.in \
--VKD3D_PROTON_MESON_ARGS = -Denable_standalone_d3d12=true
+VKD3D_PROTON_MESON_ARGS = -Denable_d3d12=true
VKD3D_PROTON_MESON_ARGS32 = --bindir=$(VKD3D_PROTON_DST32)/lib/wine/vkd3d-proton
VKD3D_PROTON_MESON_ARGS64 = --bindir=$(VKD3D_PROTON_DST64)/lib64/wine/vkd3d-proton
@@ -150,7 +178,7 @@ index 6e1b4d1..eb459b8 100644
$(eval $(call rules-source,vkd3d-proton,$(SRCDIR)/vkd3d-proton))
$(eval $(call rules-meson,vkd3d-proton,32,CROSS))
$(eval $(call rules-meson,vkd3d-proton,64,CROSS))
-@@ -1081,14 +1108,14 @@ $(FONTS_OBJ)/source-han/%.ttf: $$(%.ttf_CIDFONT) $$(%.ttf_FEATURES) $$(%.ttf_SEQ
+@@ -1078,14 +1116,14 @@ $(FONTS_OBJ)/source-han/%.ttf: $$(%.ttf_CIDFONT) $$(%.ttf_FEATURES) $$(%.ttf_SEQ
mkdir -p $(FONTS_OBJ)/source-han
# Do not immediately create the target file, so that make is interrupted
# it will restart again
@@ -168,7 +196,7 @@ index 6e1b4d1..eb459b8 100644
mv $@.tmp $@
$(FONTS_OBJ)/ume-gothic/%.ttf: $$(%.ttf_FONT) $$(%.ttf_NAMETABLE_PATCH)
-@@ -1098,10 +1125,10 @@ $(FONTS_OBJ)/ume-gothic/%.ttf: $$(%.ttf_FONT) $$(%.ttf_NAMETABLE_PATCH)
+@@ -1095,10 +1133,10 @@ $(FONTS_OBJ)/ume-gothic/%.ttf: $$(%.ttf_FONT) $$(%.ttf_NAMETABLE_PATCH)
ttx -o $@ -m $($(notdir $@)_FONT) $(FONTS_OBJ)/ume-gothic/$(notdir $(basename $($(notdir $@)_NAMETABLE_PATCH))).ttx
$(simsun.ttc): $(simsun.ttf) $(nsimsun.ttf)
@@ -182,7 +210,7 @@ index 6e1b4d1..eb459b8 100644
$(micross.ttf): $(noto_sans.ttf) $(noto_sans_arabic.ttf) $(noto_sans_armenian.ttf) $(noto_sans_bengali.ttf) $(noto_sans_coptic.ttf) \
$(noto_sans_georgian.ttf) $(noto_sans_gujarati.ttf) $(noto_sans_hebrew.ttf) $(noto_sans_khmer.ttf) $(noto_sans_tamil.ttf) \
diff --git a/configure.sh b/configure.sh
-index 7000c86..a41c52b 100755
+index d743876..90b7aae 100755
--- a/configure.sh
+++ b/configure.sh
@@ -126,6 +126,7 @@ function configure() {
@@ -346,10 +374,10 @@ index 69688a0..1c0d1d3 100644
winebuild --$(lastword $(subst ., ,$(4))) --fake-module -E "$(basename $(4)).spec" -o "$(4).fake"
mkdir -p $$($(2)_LIBDIR$(3))/$(LIBDIR_WINE_$(3))
diff --git a/proton b/proton
-index 399b21a..40cd918 100755
+index df4efd4..1089acb 100755
--- a/proton
+++ b/proton
-@@ -356,7 +356,6 @@ class Proton:
+@@ -417,7 +417,6 @@ class Proton:
self.wine_bin = self.bin_dir + "wine"
self.wine64_bin = self.bin_dir + "wine64"
self.wineserver_bin = self.bin_dir + "wineserver"
@@ -357,7 +385,7 @@ index 399b21a..40cd918 100755
def path(self, d):
return self.base_dir + d
-@@ -1377,8 +1376,6 @@ if __name__ == "__main__":
+@@ -1493,8 +1492,6 @@ if __name__ == "__main__":
g_proton = Proton(os.path.dirname(sys.argv[0]))
@@ -366,7 +394,7 @@ index 399b21a..40cd918 100755
g_compatdata = CompatData(os.environ["STEAM_COMPAT_DATA_PATH"])
-@@ -1387,7 +1384,8 @@ if __name__ == "__main__":
+@@ -1503,7 +1500,8 @@ if __name__ == "__main__":
g_session.init_wine()
if g_proton.missing_default_prefix():
@@ -377,5 +405,5 @@ index 399b21a..40cd918 100755
g_session.init_session(sys.argv[1] != "runinprefix")
--
-2.36.1
+2.37.2