summarylogtreecommitdiffstats
path: root/0001-Add-Arch-Linux-PAM-config-files.patch
diff options
context:
space:
mode:
authorgS6442015-07-25 17:22:18 +0200
committergS6442015-07-25 17:22:18 +0200
commit28066ea93d830fa9cba5c851454591e442fe3a8d (patch)
tree5e86e0fb18bda0ebbac1db07971799cd63666e20 /0001-Add-Arch-Linux-PAM-config-files.patch
downloadaur-28066ea93d830fa9cba5c851454591e442fe3a8d.tar.gz
Initial import
Diffstat (limited to '0001-Add-Arch-Linux-PAM-config-files.patch')
-rw-r--r--0001-Add-Arch-Linux-PAM-config-files.patch155
1 files changed, 155 insertions, 0 deletions
diff --git a/0001-Add-Arch-Linux-PAM-config-files.patch b/0001-Add-Arch-Linux-PAM-config-files.patch
new file mode 100644
index 000000000000..f94ba6dfa05a
--- /dev/null
+++ b/0001-Add-Arch-Linux-PAM-config-files.patch
@@ -0,0 +1,155 @@
+diff -urN gdm-3.17.4.orig/configure.ac gdm-3.17.4/configure.ac
+--- gdm-3.17.4.orig/configure.ac 2015-07-25 16:52:56.977983878 +0200
++++ gdm-3.17.4/configure.ac 2015-07-25 16:55:05.835278107 +0200
+@@ -195,7 +195,8 @@
+ fi
+
+ AC_ARG_WITH(default-pam-config,
+- AS_HELP_STRING([--with-default-pam-config: One of redhat, openembedded, exherbo, lfs, none @<:@default=auto@:>@]))
++ AS_HELP_STRING([--with-default-pam-config: One of redhat, openembedded, exherbo, lfs, arch, none
++@<:@default=auto@:>@]))
+ dnl If not given, try autodetecting from release files (see NetworkManager source)
+ if test x$with_default_pam_config = x; then
+ AC_CHECK_FILE(/etc/redhat-release,with_default_pam_config="redhat")
+@@ -208,7 +209,7 @@
+ fi
+ fi
+ case x$with_default_pam_config in
+- xredhat|xopenembedded|xexherbo|xlfs|xnone) ;;
++ xredhat|xopenembedded|xexherbo|xlfs|xarch|xnone) ;;
+ *)
+ AC_MSG_ERROR([Invalid --with-default-pam-config ${with_default_pam_config}])
+ exit 1
+@@ -218,6 +219,7 @@
+ AM_CONDITIONAL(ENABLE_OPENEMBEDDED_PAM_CONFIG, test x$with_default_pam_config = xopenembedded)
+ AM_CONDITIONAL(ENABLE_EXHERBO_PAM_CONFIG, test x$with_default_pam_config = xexherbo)
+ AM_CONDITIONAL(ENABLE_LFS_PAM_CONFIG, test x$with_default_pam_config = xlfs)
++AM_CONDITIONAL(ENABLE_ARCH_PAM_CONFIG, test x$with_default_pam_config = xarch)
+
+ AC_ARG_ENABLE(console-helper,
+ AS_HELP_STRING([--enable-console-helper],
+diff -urN gdm-3.17.4.orig/data/Makefile.am gdm-3.17.4/data/Makefile.am
+--- gdm-3.17.4.orig/data/Makefile.am 2015-07-25 16:52:56.976983884 +0200
++++ gdm-3.17.4/data/Makefile.am 2015-07-25 16:57:24.129520056 +0200
+@@ -125,6 +125,15 @@
+ $(NULL)
+ EXTRA_DIST += $(pam_lfs_files)
+
++pam_arch_files = pam-arch/gdm-autologin.pam \
++ pam-arch/gdm-launch-environment.pam \
++ pam-arch/gdm-fingerprint.pam \
++ pam-arch/gdm-smartcard.pam \
++ pam-arch/gdm-password.pam \
++ pam-arch/gdm-pin.pam \
++ $(NULL)
++EXTRA_DIST += $(pam_arch_files)
++
+ if ENABLE_REDHAT_PAM_CONFIG
+ pam_files = $(pam_redhat_files)
+ endif
+@@ -137,6 +146,9 @@
+ if ENABLE_LFS_PAM_CONFIG
+ pam_files = $(pam_lfs_files)
+ endif
++if ENABLE_ARCH_PAM_CONFIG
++pam_files = $(pam_arch_files)
++endif
+
+ EXTRA_DIST += \
+ $(dconf_db_files) \
+diff -urN gdm-3.17.4.orig/data/pam-arch/gdm-autologin.pam gdm-3.17.4/data/pam-arch/gdm-autologin.pam
+--- gdm-3.17.4.orig/data/pam-arch/gdm-autologin.pam 1970-01-01 01:00:00.000000000 +0100
++++ gdm-3.17.4/data/pam-arch/gdm-autologin.pam 2015-07-25 16:58:54.784015841 +0200
+@@ -0,0 +1,10 @@
++auth requisite pam_nologin.so
++auth required pam_env.so
++auth optional pam_permit.so
++
++account include system-local-login
++
++password include system-local-login
++
++session optional pam_keyinit.so force revoke
++session include system-local-login
+diff -urN gdm-3.17.4.orig/data/pam-arch/gdm-fingerprint.pam gdm-3.17.4/data/pam-arch/gdm-fingerprint.pam
+--- gdm-3.17.4.orig/data/pam-arch/gdm-fingerprint.pam 1970-01-01 01:00:00.000000000 +0100
++++ gdm-3.17.4/data/pam-arch/gdm-fingerprint.pam 2015-07-25 16:59:29.494812089 +0200
+@@ -0,0 +1,14 @@
++auth required pam_tally.so onerr=succeed file=/var/log/faillog
++auth required pam_shells.so
++auth requisite pam_nologin.so
++auth required pam_env.so
++auth required pam_fprintd.so
++auth optional pam_permit.so
++
++account include system-local-login
++
++password required pam_fprintd.so
++password optional pam_permit.so
++
++session optional pam_keyinit.so force revoke
++session include system-local-login
+diff -urN gdm-3.17.4.orig/data/pam-arch/gdm-launch-environment.pam gdm-3.17.4/data/pam-arch/gdm-launch-environment.pam
+--- gdm-3.17.4.orig/data/pam-arch/gdm-launch-environment.pam 1970-01-01 01:00:00.000000000 +0100
++++ gdm-3.17.4/data/pam-arch/gdm-launch-environment.pam 2015-07-25 17:00:04.135609150 +0200
+@@ -0,0 +1,10 @@
++auth required pam_env.so
++auth optional pam_permit.so
++
++account include system-local-login
++
++password required pam_deny.so
++
++session optional pam_keyinit.so force revoke
++session required pam_systemd.so
++session optional pam_permit.so
+diff -urN gdm-3.17.4.orig/data/pam-arch/gdm-password.pam gdm-3.17.4/data/pam-arch/gdm-password.pam
+--- gdm-3.17.4.orig/data/pam-arch/gdm-password.pam 1970-01-01 01:00:00.000000000 +0100
++++ gdm-3.17.4/data/pam-arch/gdm-password.pam 2015-07-25 17:00:28.295467846 +0200
+@@ -0,0 +1,11 @@
++auth include system-local-login
++auth optional pam_gnome_keyring.so
++
++account include system-local-login
++
++password include system-local-login
++password optional pam_gnome_keyring.so use_authtok
++
++session optional pam_keyinit.so force revoke
++session include system-local-login
++session optional pam_gnome_keyring.so auto_start
+diff -urN gdm-3.17.4.orig/data/pam-arch/gdm-pin.pam gdm-3.17.4/data/pam-arch/gdm-pin.pam
+--- gdm-3.17.4.orig/data/pam-arch/gdm-pin.pam 1970-01-01 01:00:00.000000000 +0100
++++ gdm-3.17.4/data/pam-arch/gdm-pin.pam 2015-07-25 17:00:51.430332710 +0200
+@@ -0,0 +1,13 @@
++auth requisite pam_pin.so
++auth include system-local-login
++auth optional pam_gnome_keyring.so
++
++account include system-local-login
++
++password include system-local-login
++password optional pam_pin.so
++password optional pam_gnome_keyring.so use_authtok
++
++session optional pam_keyinit.so force revoke
++session include system-local-login
++session optional pam_gnome_keyring.so auto_star
+diff -urN gdm-3.17.4.orig/data/pam-arch/gdm-smartcard.pam gdm-3.17.4/data/pam-arch/gdm-smartcard.pam
+--- gdm-3.17.4.orig/data/pam-arch/gdm-smartcard.pam 1970-01-01 01:00:00.000000000 +0100
++++ gdm-3.17.4/data/pam-arch/gdm-smartcard.pam 2015-07-25 17:01:16.614185794 +0200
+@@ -0,0 +1,14 @@
++auth required pam_tally.so onerr=succeed file=/var/log/faillog
++auth required pam_shells.so
++auth requisite pam_nologin.so
++auth required pam_env.so
++auth required pam_pkcs11.so wait_for_card card_only
++auth optional pam_permit.so
++
++account include system-local-login
++
++password required pam_pkcs11.so
++password optional pam_permit.so
++
++session optional pam_keyinit.so force revoke
++session include system-local-login