summarylogtreecommitdiffstats
path: root/0001-Allow-building-without-tools.patch
diff options
context:
space:
mode:
author0x9fff002024-03-25 00:52:48 +0100
committer0x9fff002024-03-25 00:52:48 +0100
commitdbf00edf8802165f0cd378720ba85983d91051e9 (patch)
treee1f38752ceb9104c164d08fbaa430800b51b45c0 /0001-Allow-building-without-tools.patch
parentfb1168f8455967b0cea2edbf2e628755d5f503b5 (diff)
downloadaur-dbf00edf8802165f0cd378720ba85983d91051e9.tar.gz
libirecovery-1.0-3
Diffstat (limited to '0001-Allow-building-without-tools.patch')
-rw-r--r--0001-Allow-building-without-tools.patch63
1 files changed, 63 insertions, 0 deletions
diff --git a/0001-Allow-building-without-tools.patch b/0001-Allow-building-without-tools.patch
new file mode 100644
index 000000000000..1b05ad21b59c
--- /dev/null
+++ b/0001-Allow-building-without-tools.patch
@@ -0,0 +1,63 @@
+From f2a166b01445fe412b5bff1b71256aebd62d1fcb Mon Sep 17 00:00:00 2001
+From: Daniel VanBritsom <danthemann15@yahoo.com>
+Date: Fri, 6 Oct 2023 21:10:09 -0400
+Subject: [PATCH] Allow building --without-tools
+
+---
+ configure.ac | 18 +++++++++++++-----
+ tools/Makefile.am | 2 ++
+ 2 files changed, 15 insertions(+), 5 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index e15231f..2b12d8f 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -47,11 +47,6 @@ AC_TYPE_UINT8_T
+ # Checks for library functions.
+ AC_CHECK_FUNCS([strdup strerror strcasecmp strndup malloc realloc calloc])
+
+-# Checks for libraries.
+-AC_CHECK_HEADERS([readline/readline.h], [],
+- [AC_MSG_ERROR([Please install readline development headers])]
+-)
+-
+ # Check additional platform flags
+ AC_MSG_CHECKING([for platform-specific build settings])
+ case ${host_os} in
+@@ -100,6 +95,19 @@ if test "$ac_cv_attribute_constructor" = "yes"; then
+ AC_DEFINE(HAVE_ATTRIBUTE_CONSTRUCTOR, 1, [Define if the C compiler supports constructor/destructor attributes])
+ fi
+
++AC_ARG_WITH([tools],
++ [AS_HELP_STRING([--with-tools], [Build irecovery tools. (requires readline) [default=yes]])],
++ [],
++ [with_tools=yes])
++
++AS_IF([test "x$with_tools" = "xyes"], [
++ AC_DEFINE(BUILD_TOOLS, 1, [Define if we are building irecovery tools])
++ AC_CHECK_HEADERS([readline/readline.h], [],
++ [AC_MSG_ERROR([Please install readline development headers])]
++ )]
++)
++AM_CONDITIONAL(BUILD_TOOLS, test "x$with_tools" = "xyes")
++
+ AC_ARG_WITH([dummy],
+ [AS_HELP_STRING([--with-dummy], [Use no USB driver at all [default=no]. This is only useful if you just want to query the device list by product type or hardware model. All other operations are no-ops or will return IRECV_E_UNSUPPORTED.])],
+ [],
+diff --git a/tools/Makefile.am b/tools/Makefile.am
+index 03728b2..ebb085c 100644
+--- a/tools/Makefile.am
++++ b/tools/Makefile.am
+@@ -1,3 +1,4 @@
++if BUILD_TOOLS
+ AM_CPPFLAGS = -I$(top_srcdir)/include
+
+ AM_CFLAGS = $(GLOBAL_CFLAGS) $(libusb_CFLAGS)
+@@ -9,3 +10,4 @@ irecovery_SOURCES = irecovery.c
+ irecovery_CFLAGS = $(AM_CFLAGS)
+ irecovery_LDFLAGS = $(AM_LDFLAGS)
+ irecovery_LDADD = $(top_builddir)/src/libirecovery-1.0.la
++endif
+--
+2.44.0
+