summarylogtreecommitdiffstats
path: root/0001-Cairo-backend-added-to-Qt5-wrapper.patch
diff options
context:
space:
mode:
authorPaul Gideon Dann2019-02-04 11:07:14 +0000
committerPaul Gideon Dann2019-02-04 11:07:14 +0000
commit09ad4a011f43f4fd69dbb822cc44f788feed6f08 (patch)
tree33a48cc940ca045bf4668f515167f2ccaa6acf0d /0001-Cairo-backend-added-to-Qt5-wrapper.patch
parentc3bbfc7e8197d429bbad1eff1b79e487a0a2c2e3 (diff)
downloadaur-09ad4a011f43f4fd69dbb822cc44f788feed6f08.tar.gz
Update for Poppler 0.73.0
Diffstat (limited to '0001-Cairo-backend-added-to-Qt5-wrapper.patch')
-rw-r--r--0001-Cairo-backend-added-to-Qt5-wrapper.patch36
1 files changed, 18 insertions, 18 deletions
diff --git a/0001-Cairo-backend-added-to-Qt5-wrapper.patch b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
index 8aa701e5d22e..589d8845aa43 100644
--- a/0001-Cairo-backend-added-to-Qt5-wrapper.patch
+++ b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
@@ -1,7 +1,7 @@
-From a9dd02eec6b1d6ed4e1fbc90cc865e3fea73bc5b Mon Sep 17 00:00:00 2001
+From 590cf73ca1deb80558c30f7d1bd27c987006e640 Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Wed, 4 Apr 2018 16:36:56 +0100
-Subject: [PATCH 1/5] Cairo backend added to Qt5 wrapper
+Subject: [PATCH 1/4] Cairo backend added to Qt5 wrapper
---
qt5/src/CMakeLists.txt | 15 ++++++++
@@ -12,7 +12,7 @@ Subject: [PATCH 1/5] Cairo backend added to Qt5 wrapper
5 files changed, 95 insertions(+), 1 deletion(-)
diff --git a/qt5/src/CMakeLists.txt b/qt5/src/CMakeLists.txt
-index de565b23..6a482fcc 100644
+index c94390c5..2f3d8671 100644
--- a/qt5/src/CMakeLists.txt
+++ b/qt5/src/CMakeLists.txt
@@ -8,6 +8,11 @@ include_directories(
@@ -27,9 +27,9 @@ index de565b23..6a482fcc 100644
set(CMAKE_C_VISIBILITY_PRESET hidden)
set(CMAKE_CXX_VISIBILITY_PRESET hidden)
set(CMAKE_VISIBILITY_INLINES_HIDDEN 1)
-@@ -34,6 +39,13 @@ set(poppler_qt5_SRCS
- poppler-media.cc
+@@ -37,6 +42,13 @@ set(poppler_qt5_SRCS
ArthurOutputDev.cc
+ poppler-version.cpp
)
+if (HAVE_CAIRO)
+ set(poppler_qt5_SRCS ${poppler_qt5_SRCS}
@@ -39,12 +39,12 @@ index de565b23..6a482fcc 100644
+ )
+endif(HAVE_CAIRO)
add_library(poppler-qt5 ${poppler_qt5_SRCS})
- set_target_properties(poppler-qt5 PROPERTIES VERSION 1.17.0 SOVERSION 1)
- if(MINGW)
-@@ -41,6 +53,9 @@ if(MINGW)
+ set_target_properties(poppler-qt5 PROPERTIES VERSION 1.18.0 SOVERSION 1)
+ if(MINGW AND BUILD_SHARED_LIBS)
+@@ -44,6 +56,9 @@ if(MINGW AND BUILD_SHARED_LIBS)
set_target_properties(poppler-qt5 PROPERTIES SUFFIX "-${POPPLER_QT5_SOVERSION}${CMAKE_SHARED_LIBRARY_SUFFIX}")
endif()
- target_link_libraries(poppler-qt5 poppler ${Qt5Core_LIBRARIES} ${Qt5Gui_LIBRARIES} ${Qt5Xml_LIBRARIES})
+ target_link_libraries(poppler-qt5 poppler ${Qt5Core_LIBRARIES} ${Qt5Gui_LIBRARIES} ${Qt5Xml_LIBRARIES} ${FREETYPE_LIBRARIES})
+if (HAVE_CAIRO)
+ target_link_libraries(poppler-qt5 ${CAIRO_LIBRARIES})
+endif (HAVE_CAIRO)
@@ -52,10 +52,10 @@ index de565b23..6a482fcc 100644
target_link_libraries(poppler-qt5 poppler ${poppler_LIBS})
endif()
diff --git a/qt5/src/poppler-document.cc b/qt5/src/poppler-document.cc
-index ea2fd7e6..50bd94f4 100644
+index 216ef582..65fce04f 100644
--- a/qt5/src/poppler-document.cc
+++ b/qt5/src/poppler-document.cc
-@@ -677,6 +677,9 @@ namespace Poppler {
+@@ -678,6 +678,9 @@ namespace Poppler {
ret << Document::SplashBackend;
#endif
ret << Document::ArthurBackend;
@@ -66,10 +66,10 @@ index ea2fd7e6..50bd94f4 100644
}
diff --git a/qt5/src/poppler-page.cc b/qt5/src/poppler-page.cc
-index 68802bab..833126d2 100644
+index 1e5e1ae2..e0a131b4 100644
--- a/qt5/src/poppler-page.cc
+++ b/qt5/src/poppler-page.cc
-@@ -47,6 +47,7 @@
+@@ -48,6 +48,7 @@
#include <QtGui/QPainter>
#include <config.h>
@@ -77,7 +77,7 @@ index 68802bab..833126d2 100644
#include <PDFDoc.h>
#include <Catalog.h>
#include <Form.h>
-@@ -60,6 +61,9 @@
+@@ -61,6 +62,9 @@
#include <SplashOutputDev.h>
#include <splash/SplashBitmap.h>
#endif
@@ -87,7 +87,7 @@ index 68802bab..833126d2 100644
#include "poppler-private.h"
#include "poppler-page-transition-private.h"
-@@ -623,6 +627,70 @@ QImage Page::renderToImage(double xres, double yres, int x, int y, int w, int h,
+@@ -624,6 +628,70 @@ QImage Page::renderToImage(double xres, double yres, int x, int y, int w, int h,
img = tmpimg;
break;
}
@@ -158,7 +158,7 @@ index 68802bab..833126d2 100644
}
if (shouldAbortRenderCallback && shouldAbortRenderCallback(payload))
-@@ -645,6 +713,8 @@ bool Page::renderToPainter(QPainter* painter, double xres, double yres, int x, i
+@@ -646,6 +714,8 @@ bool Page::renderToPainter(QPainter* painter, double xres, double yres, int x, i
QImageDumpingArthurOutputDev arthur_output(painter, nullptr);
return renderToArthur(&arthur_output, painter, m_page, xres, yres, x, y, w, h, rotate, flags);
}
@@ -168,10 +168,10 @@ index 68802bab..833126d2 100644
return false;
}
diff --git a/qt5/src/poppler-qt5.h b/qt5/src/poppler-qt5.h
-index ed189701..2e8ca01f 100644
+index 5373a3a1..a81f4fda 100644
--- a/qt5/src/poppler-qt5.h
+++ b/qt5/src/poppler-qt5.h
-@@ -1061,7 +1061,8 @@ delete it;
+@@ -1065,7 +1065,8 @@ delete it;
*/
enum RenderBackend {
SplashBackend, ///< Splash backend