summarylogtreecommitdiffstats
path: root/0001-Cairo-backend-added-to-Qt5-wrapper.patch
diff options
context:
space:
mode:
authorPaul Dann2021-06-18 11:23:28 +0100
committerPaul Dann2021-06-18 11:23:28 +0100
commit5c66849c0c01dc8c80de2db4ad1a27231e145dbb (patch)
tree028ec90a32d5dec9caa3a423616c3e7d4e9a5deb /0001-Cairo-backend-added-to-Qt5-wrapper.patch
parentbbda99d08a412ab15ef5bf3868c8ae11f5da5a38 (diff)
downloadaur-5c66849c0c01dc8c80de2db4ad1a27231e145dbb.tar.gz
Update for Poppler 21.06.1
Diffstat (limited to '0001-Cairo-backend-added-to-Qt5-wrapper.patch')
-rw-r--r--0001-Cairo-backend-added-to-Qt5-wrapper.patch16
1 files changed, 8 insertions, 8 deletions
diff --git a/0001-Cairo-backend-added-to-Qt5-wrapper.patch b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
index 405e7a84110c..4d0f87b2acb1 100644
--- a/0001-Cairo-backend-added-to-Qt5-wrapper.patch
+++ b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
@@ -1,4 +1,4 @@
-From 694376bd60615815ef99af3b21a4addd64718354 Mon Sep 17 00:00:00 2001
+From 5e8da09c84843f940cffb0266c24482132753b83 Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Wed, 4 Apr 2018 16:36:56 +0100
Subject: [PATCH 1/3] Cairo backend added to Qt5 wrapper
@@ -12,7 +12,7 @@ Subject: [PATCH 1/3] Cairo backend added to Qt5 wrapper
5 files changed, 95 insertions(+), 1 deletion(-)
diff --git a/qt5/src/CMakeLists.txt b/qt5/src/CMakeLists.txt
-index 564cf270..cd5c4280 100644
+index d80c81f3..39d6f9ae 100644
--- a/qt5/src/CMakeLists.txt
+++ b/qt5/src/CMakeLists.txt
@@ -5,6 +5,11 @@ include_directories(
@@ -40,7 +40,7 @@ index 564cf270..cd5c4280 100644
+endif(HAVE_CAIRO)
add_library(poppler-qt5 ${poppler_qt5_SRCS})
generate_export_header(poppler-qt5 BASE_NAME poppler-qt5 EXPORT_FILE_NAME "${CMAKE_CURRENT_BINARY_DIR}/poppler-export.h")
- set_target_properties(poppler-qt5 PROPERTIES VERSION 1.28.0 SOVERSION 1)
+ set_target_properties(poppler-qt5 PROPERTIES VERSION 1.29.0 SOVERSION 1)
@@ -44,6 +56,9 @@ if(MINGW AND BUILD_SHARED_LIBS)
set_target_properties(poppler-qt5 PROPERTIES SUFFIX "-${POPPLER_QT5_SOVERSION}${CMAKE_SHARED_LIBRARY_SUFFIX}")
endif()
@@ -52,10 +52,10 @@ index 564cf270..cd5c4280 100644
target_link_libraries(poppler-qt5 poppler ${poppler_LIBS})
endif()
diff --git a/qt5/src/poppler-document.cc b/qt5/src/poppler-document.cc
-index 762eba9f..64e75a3b 100644
+index 574f2431..dc53dbc2 100644
--- a/qt5/src/poppler-document.cc
+++ b/qt5/src/poppler-document.cc
-@@ -696,6 +696,9 @@ QSet<Document::RenderBackend> Document::availableRenderBackends()
+@@ -697,6 +697,9 @@ QSet<Document::RenderBackend> Document::availableRenderBackends()
#endif
ret << Document::QPainterBackend;
ret << Document::ArthurBackend; // For backward compatibility
@@ -168,10 +168,10 @@ index bae438b7..f60e2469 100644
return false;
}
diff --git a/qt5/src/poppler-qt5.h b/qt5/src/poppler-qt5.h
-index a3163572..68482722 100644
+index a55fb9a4..3d83610d 100644
--- a/qt5/src/poppler-qt5.h
+++ b/qt5/src/poppler-qt5.h
-@@ -1177,7 +1177,8 @@ public:
+@@ -1180,7 +1180,8 @@ public:
{
SplashBackend, ///< Splash backend
ArthurBackend, ///< \deprecated The old name of the QPainter backend
@@ -198,5 +198,5 @@ index c3decb92..95d7f325 100644
string(REPLACE "-" "" test_name ${exe})
set(${test_name}_SOURCES
--
-2.31.1
+2.32.0