summarylogtreecommitdiffstats
path: root/0001-Cairo-backend-added-to-Qt5-wrapper.patch
diff options
context:
space:
mode:
authorPaul Dann2022-05-10 13:45:24 +0100
committerPaul Dann2022-05-10 13:45:24 +0100
commit7e0aa34e85ac477ff5a18eb1c9ed5c0869c0d0e5 (patch)
treea0b7dcd04fce32efbb903c1a7ec60ac3c013a3cb /0001-Cairo-backend-added-to-Qt5-wrapper.patch
parent07d27db39451ef73843f34b62ed4935a330a5d63 (diff)
downloadaur-7e0aa34e85ac477ff5a18eb1c9ed5c0869c0d0e5.tar.gz
Update for Poppler 22.05.0
Diffstat (limited to '0001-Cairo-backend-added-to-Qt5-wrapper.patch')
-rw-r--r--0001-Cairo-backend-added-to-Qt5-wrapper.patch28
1 files changed, 14 insertions, 14 deletions
diff --git a/0001-Cairo-backend-added-to-Qt5-wrapper.patch b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
index c2930a274d57..22971c516868 100644
--- a/0001-Cairo-backend-added-to-Qt5-wrapper.patch
+++ b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
@@ -1,4 +1,4 @@
-From ce29c8af8baf6b6e93c6836436ea20e1ee892899 Mon Sep 17 00:00:00 2001
+From e2e83d1872c64b788d33eea4e64b4c3a150fc6d8 Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Wed, 4 Apr 2018 16:36:56 +0100
Subject: [PATCH 1/3] Cairo backend added to Qt5 wrapper
@@ -12,7 +12,7 @@ Subject: [PATCH 1/3] Cairo backend added to Qt5 wrapper
5 files changed, 95 insertions(+), 1 deletion(-)
diff --git a/qt5/src/CMakeLists.txt b/qt5/src/CMakeLists.txt
-index 55671715..acf8e6a6 100644
+index 638505e6..9fe2c1d4 100644
--- a/qt5/src/CMakeLists.txt
+++ b/qt5/src/CMakeLists.txt
@@ -5,6 +5,11 @@ include_directories(
@@ -48,14 +48,14 @@ index 55671715..acf8e6a6 100644
+if (HAVE_CAIRO)
+ target_link_libraries(poppler-qt5 ${CAIRO_LIBRARIES})
+endif (HAVE_CAIRO)
- if(MSVC)
- target_link_libraries(poppler-qt5 poppler ${poppler_LIBS})
+ if (ENABLE_NSS3)
+ target_include_directories(poppler-qt5 SYSTEM PRIVATE ${NSS3_INCLUDE_DIRS})
endif()
diff --git a/qt5/src/poppler-document.cc b/qt5/src/poppler-document.cc
-index 6ee0a474..d409ba45 100644
+index 6daed698..09d7ac96 100644
--- a/qt5/src/poppler-document.cc
+++ b/qt5/src/poppler-document.cc
-@@ -701,6 +701,9 @@ QSet<Document::RenderBackend> Document::availableRenderBackends()
+@@ -710,6 +710,9 @@ QSet<Document::RenderBackend> Document::availableRenderBackends()
ret << Document::SplashBackend;
ret << Document::QPainterBackend;
ret << Document::ArthurBackend; // For backward compatibility
@@ -66,10 +66,10 @@ index 6ee0a474..d409ba45 100644
}
diff --git a/qt5/src/poppler-page.cc b/qt5/src/poppler-page.cc
-index eedc580f..1993927f 100644
+index b2cea93b..d28fdfa6 100644
--- a/qt5/src/poppler-page.cc
+++ b/qt5/src/poppler-page.cc
-@@ -54,6 +54,7 @@
+@@ -55,6 +55,7 @@
#include <config.h>
#include <cfloat>
#include <poppler-config.h>
@@ -77,7 +77,7 @@ index eedc580f..1993927f 100644
#include <PDFDoc.h>
#include <Catalog.h>
#include <Form.h>
-@@ -65,6 +66,9 @@
+@@ -66,6 +67,9 @@
#include <Rendition.h>
#include <SplashOutputDev.h>
#include <splash/SplashBitmap.h>
@@ -87,7 +87,7 @@ index eedc580f..1993927f 100644
#include "poppler-private.h"
#include "poppler-page-transition-private.h"
-@@ -583,6 +587,69 @@ QImage Page::renderToImage(double xres, double yres, int xPos, int yPos, int w,
+@@ -596,6 +600,69 @@ QImage Page::renderToImage(double xres, double yres, int xPos, int yPos, int w,
img = tmpimg;
break;
}
@@ -156,8 +156,8 @@ index eedc580f..1993927f 100644
+ }
}
- if (shouldAbortRenderCallback && shouldAbortRenderCallback(payload))
-@@ -606,6 +673,9 @@ bool Page::renderToPainter(QPainter *painter, double xres, double yres, int x, i
+ if (shouldAbortRenderCallback && shouldAbortRenderCallback(payload)) {
+@@ -621,6 +688,9 @@ bool Page::renderToPainter(QPainter *painter, double xres, double yres, int x, i
return renderToQPainter(&qpainter_output, painter, m_page, xres, yres, x, y, w, h, rotate, flags);
}
@@ -182,7 +182,7 @@ index abeb4fdb..380461a3 100644
/**
diff --git a/qt5/tests/CMakeLists.txt b/qt5/tests/CMakeLists.txt
-index 8293a3a1..837c2331 100644
+index baadd428..4f2c1506 100644
--- a/qt5/tests/CMakeLists.txt
+++ b/qt5/tests/CMakeLists.txt
@@ -7,6 +7,11 @@ include_directories(
@@ -198,5 +198,5 @@ index 8293a3a1..837c2331 100644
string(REPLACE "-" "" test_name ${exe})
set(${test_name}_SOURCES
--
-2.35.1
+2.36.1