summarylogtreecommitdiffstats
path: root/0001-Cairo-backend-added-to-Qt5-wrapper.patch
diff options
context:
space:
mode:
authorPaul Dann2021-01-11 11:53:22 +0000
committerPaul Dann2021-01-11 11:53:22 +0000
commit8257ef1304ec603db19e12eab32b1d2674e0af5f (patch)
tree44f013766376eaceb05ed8632daeda0845f8b269 /0001-Cairo-backend-added-to-Qt5-wrapper.patch
parentef24c7e511be8a3ba404c33e808ccd86eb4a4c3a (diff)
downloadaur-8257ef1304ec603db19e12eab32b1d2674e0af5f.tar.gz
Update for Poppler 21.01.0
Diffstat (limited to '0001-Cairo-backend-added-to-Qt5-wrapper.patch')
-rw-r--r--0001-Cairo-backend-added-to-Qt5-wrapper.patch16
1 files changed, 8 insertions, 8 deletions
diff --git a/0001-Cairo-backend-added-to-Qt5-wrapper.patch b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
index cc44d2786a24..e63f51776397 100644
--- a/0001-Cairo-backend-added-to-Qt5-wrapper.patch
+++ b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
@@ -1,4 +1,4 @@
-From c9507c38913711b9497b5db03df6ed0eb6627f2f Mon Sep 17 00:00:00 2001
+From 7b9eee38a13275003656b0a625d27786ddc45822 Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Wed, 4 Apr 2018 16:36:56 +0100
Subject: [PATCH 1/3] Cairo backend added to Qt5 wrapper
@@ -12,7 +12,7 @@ Subject: [PATCH 1/3] Cairo backend added to Qt5 wrapper
5 files changed, 95 insertions(+), 1 deletion(-)
diff --git a/qt5/src/CMakeLists.txt b/qt5/src/CMakeLists.txt
-index ae055a12..8cc1f540 100644
+index afacd2c3..4c9ee018 100644
--- a/qt5/src/CMakeLists.txt
+++ b/qt5/src/CMakeLists.txt
@@ -5,6 +5,11 @@ include_directories(
@@ -39,7 +39,7 @@ index ae055a12..8cc1f540 100644
+ )
+endif(HAVE_CAIRO)
add_library(poppler-qt5 ${poppler_qt5_SRCS})
- set_target_properties(poppler-qt5 PROPERTIES VERSION 1.26.0 SOVERSION 1)
+ set_target_properties(poppler-qt5 PROPERTIES VERSION 1.27.0 SOVERSION 1)
if(MINGW AND BUILD_SHARED_LIBS)
@@ -43,6 +55,9 @@ if(MINGW AND BUILD_SHARED_LIBS)
set_target_properties(poppler-qt5 PROPERTIES SUFFIX "-${POPPLER_QT5_SOVERSION}${CMAKE_SHARED_LIBRARY_SUFFIX}")
@@ -52,10 +52,10 @@ index ae055a12..8cc1f540 100644
target_link_libraries(poppler-qt5 poppler ${poppler_LIBS})
endif()
diff --git a/qt5/src/poppler-document.cc b/qt5/src/poppler-document.cc
-index 87aee4cf..ae76325e 100644
+index 0a2a6ce4..a6d02fa1 100644
--- a/qt5/src/poppler-document.cc
+++ b/qt5/src/poppler-document.cc
-@@ -694,6 +694,9 @@ QSet<Document::RenderBackend> Document::availableRenderBackends()
+@@ -696,6 +696,9 @@ QSet<Document::RenderBackend> Document::availableRenderBackends()
#endif
ret << Document::QPainterBackend;
ret << Document::ArthurBackend; // For backward compatibility
@@ -168,10 +168,10 @@ index 31c60698..94389f9f 100644
return false;
}
diff --git a/qt5/src/poppler-qt5.h b/qt5/src/poppler-qt5.h
-index 6c167b65..f1672888 100644
+index f1b64a9e..5828e12d 100644
--- a/qt5/src/poppler-qt5.h
+++ b/qt5/src/poppler-qt5.h
-@@ -1167,7 +1167,8 @@ public:
+@@ -1170,7 +1170,8 @@ public:
{
SplashBackend, ///< Splash backend
ArthurBackend, ///< \deprecated The old name of the QPainter backend
@@ -198,5 +198,5 @@ index 82ef2139..56860c32 100644
string(REPLACE "-" "" test_name ${exe})
set(${test_name}_SOURCES
--
-2.29.2
+2.30.0