summarylogtreecommitdiffstats
path: root/0001-Cairo-backend-added-to-Qt5-wrapper.patch
diff options
context:
space:
mode:
authorPaul Dann2022-02-07 10:12:56 +0000
committerPaul Dann2022-02-07 10:12:56 +0000
commit8424e17d2284ec13d2f8e6d414df2c52103adb2a (patch)
tree7511fc190998056a2a5feb93d3690d3a6b827fc6 /0001-Cairo-backend-added-to-Qt5-wrapper.patch
parentbe45fcd05c4d0398c77db8bc59232fba737784e5 (diff)
downloadaur-8424e17d2284ec13d2f8e6d414df2c52103adb2a.tar.gz
Update for Poppler 22.02.0
Diffstat (limited to '0001-Cairo-backend-added-to-Qt5-wrapper.patch')
-rw-r--r--0001-Cairo-backend-added-to-Qt5-wrapper.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/0001-Cairo-backend-added-to-Qt5-wrapper.patch b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
index 4dcf2f553f2f..57a9d70f6c35 100644
--- a/0001-Cairo-backend-added-to-Qt5-wrapper.patch
+++ b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
@@ -1,4 +1,4 @@
-From 288d6eb96b6af7f3a89f719ab333bb56e6191123 Mon Sep 17 00:00:00 2001
+From a9b46d68df368a4d4daee072ba090e13af182bde Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Wed, 4 Apr 2018 16:36:56 +0100
Subject: [PATCH 1/3] Cairo backend added to Qt5 wrapper
@@ -12,7 +12,7 @@ Subject: [PATCH 1/3] Cairo backend added to Qt5 wrapper
5 files changed, 95 insertions(+), 1 deletion(-)
diff --git a/qt5/src/CMakeLists.txt b/qt5/src/CMakeLists.txt
-index 625aa759..6e930172 100644
+index 187c3b1f..c758ea40 100644
--- a/qt5/src/CMakeLists.txt
+++ b/qt5/src/CMakeLists.txt
@@ -5,6 +5,11 @@ include_directories(
@@ -40,7 +40,7 @@ index 625aa759..6e930172 100644
+endif(HAVE_CAIRO)
add_library(poppler-qt5 ${poppler_qt5_SRCS})
generate_export_header(poppler-qt5 BASE_NAME poppler-qt5 EXPORT_FILE_NAME "${CMAKE_CURRENT_BINARY_DIR}/poppler-export.h")
- set_target_properties(poppler-qt5 PROPERTIES VERSION 1.30.0 SOVERSION 1)
+ set_target_properties(poppler-qt5 PROPERTIES VERSION 1.31.0 SOVERSION 1)
@@ -44,6 +56,9 @@ if(MINGW AND BUILD_SHARED_LIBS)
set_target_properties(poppler-qt5 PROPERTIES SUFFIX "-${POPPLER_QT5_SOVERSION}${CMAKE_SHARED_LIBRARY_SUFFIX}")
endif()
@@ -168,10 +168,10 @@ index eedc580f..1993927f 100644
return false;
}
diff --git a/qt5/src/poppler-qt5.h b/qt5/src/poppler-qt5.h
-index f307a26e..7dd0f8cf 100644
+index bab846f8..200b69b2 100644
--- a/qt5/src/poppler-qt5.h
+++ b/qt5/src/poppler-qt5.h
-@@ -1181,7 +1181,8 @@ public:
+@@ -1182,7 +1182,8 @@ public:
{
SplashBackend, ///< Splash backend
ArthurBackend, ///< \deprecated The old name of the QPainter backend
@@ -198,5 +198,5 @@ index 8293a3a1..837c2331 100644
string(REPLACE "-" "" test_name ${exe})
set(${test_name}_SOURCES
--
-2.34.1
+2.35.1