summarylogtreecommitdiffstats
path: root/0001-Cairo-backend-added-to-Qt5-wrapper.patch
diff options
context:
space:
mode:
authorPaul Dann2020-12-04 08:30:01 +0000
committerPaul Dann2020-12-04 08:30:01 +0000
commit94fce9fade067f1c069bdc9211f53e64fff9d284 (patch)
tree81747eeb2610ea7debe2fc01ca3aa6599cd44a47 /0001-Cairo-backend-added-to-Qt5-wrapper.patch
parentffc4aba4ece9d991752c3c575fc1d7c1a04bd63d (diff)
downloadaur-94fce9fade067f1c069bdc9211f53e64fff9d284.tar.gz
Update for Poppler 20.12.0
Diffstat (limited to '0001-Cairo-backend-added-to-Qt5-wrapper.patch')
-rw-r--r--0001-Cairo-backend-added-to-Qt5-wrapper.patch44
1 files changed, 22 insertions, 22 deletions
diff --git a/0001-Cairo-backend-added-to-Qt5-wrapper.patch b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
index ef2198c8a88f..f7870de9181e 100644
--- a/0001-Cairo-backend-added-to-Qt5-wrapper.patch
+++ b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
@@ -1,4 +1,4 @@
-From a7ca2281c8b85a842e5a9677dded792135ad121f Mon Sep 17 00:00:00 2001
+From 3ea09a476618ec9c2831449cb668463f47f09e55 Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Wed, 4 Apr 2018 16:36:56 +0100
Subject: [PATCH 1/3] Cairo backend added to Qt5 wrapper
@@ -12,7 +12,7 @@ Subject: [PATCH 1/3] Cairo backend added to Qt5 wrapper
5 files changed, 95 insertions(+), 1 deletion(-)
diff --git a/qt5/src/CMakeLists.txt b/qt5/src/CMakeLists.txt
-index 0247fa3f..f52e4a3b 100644
+index 80f40fca..18059d7a 100644
--- a/qt5/src/CMakeLists.txt
+++ b/qt5/src/CMakeLists.txt
@@ -8,6 +8,11 @@ include_directories(
@@ -28,7 +28,7 @@ index 0247fa3f..f52e4a3b 100644
set(CMAKE_CXX_VISIBILITY_PRESET hidden)
set(CMAKE_VISIBILITY_INLINES_HIDDEN 1)
@@ -39,6 +44,13 @@ set(poppler_qt5_SRCS
- ArthurOutputDev.cc
+ QPainterOutputDev.cc
poppler-version.cpp
)
+if (HAVE_CAIRO)
@@ -39,7 +39,7 @@ index 0247fa3f..f52e4a3b 100644
+ )
+endif(HAVE_CAIRO)
add_library(poppler-qt5 ${poppler_qt5_SRCS})
- set_target_properties(poppler-qt5 PROPERTIES VERSION 1.25.0 SOVERSION 1)
+ set_target_properties(poppler-qt5 PROPERTIES VERSION 1.26.0 SOVERSION 1)
if(MINGW AND BUILD_SHARED_LIBS)
@@ -46,6 +58,9 @@ if(MINGW AND BUILD_SHARED_LIBS)
set_target_properties(poppler-qt5 PROPERTIES SUFFIX "-${POPPLER_QT5_SOVERSION}${CMAKE_SHARED_LIBRARY_SUFFIX}")
@@ -52,13 +52,13 @@ index 0247fa3f..f52e4a3b 100644
target_link_libraries(poppler-qt5 poppler ${poppler_LIBS})
endif()
diff --git a/qt5/src/poppler-document.cc b/qt5/src/poppler-document.cc
-index 6828da4d..37b11229 100644
+index 87aee4cf..ae76325e 100644
--- a/qt5/src/poppler-document.cc
+++ b/qt5/src/poppler-document.cc
-@@ -692,6 +692,9 @@ QSet<Document::RenderBackend> Document::availableRenderBackends()
- ret << Document::SplashBackend;
+@@ -694,6 +694,9 @@ QSet<Document::RenderBackend> Document::availableRenderBackends()
#endif
- ret << Document::ArthurBackend;
+ ret << Document::QPainterBackend;
+ ret << Document::ArthurBackend; // For backward compatibility
+#if defined(HAVE_CAIRO)
+ ret << Document::CairoBackend;
+#endif
@@ -66,18 +66,18 @@ index 6828da4d..37b11229 100644
}
diff --git a/qt5/src/poppler-page.cc b/qt5/src/poppler-page.cc
-index af7e4a11..992e6f00 100644
+index 31c60698..94389f9f 100644
--- a/qt5/src/poppler-page.cc
+++ b/qt5/src/poppler-page.cc
-@@ -50,6 +50,7 @@
- #include <QtGui/QPainter>
+@@ -51,6 +51,7 @@
#include <config.h>
+ #include <poppler-config.h>
+#include <math.h>
#include <PDFDoc.h>
#include <Catalog.h>
#include <Form.h>
-@@ -63,6 +64,9 @@
+@@ -64,6 +65,9 @@
# include <SplashOutputDev.h>
# include <splash/SplashBitmap.h>
#endif
@@ -87,7 +87,7 @@ index af7e4a11..992e6f00 100644
#include "poppler-private.h"
#include "poppler-page-transition-private.h"
-@@ -556,6 +560,69 @@ QImage Page::renderToImage(double xres, double yres, int xPos, int yPos, int w,
+@@ -564,6 +568,69 @@ QImage Page::renderToImage(double xres, double yres, int xPos, int yPos, int w,
img = tmpimg;
break;
}
@@ -157,9 +157,9 @@ index af7e4a11..992e6f00 100644
}
if (shouldAbortRenderCallback && shouldAbortRenderCallback(payload))
-@@ -579,6 +646,9 @@ bool Page::renderToPainter(QPainter *painter, double xres, double yres, int x, i
+@@ -587,6 +654,9 @@ bool Page::renderToPainter(QPainter *painter, double xres, double yres, int x, i
- return renderToArthur(&arthur_output, painter, m_page, xres, yres, x, y, w, h, rotate, flags);
+ return renderToQPainter(&qpainter_output, painter, m_page, xres, yres, x, y, w, h, rotate, flags);
}
+ case Poppler::Document::CairoBackend: {
+ return false;
@@ -168,21 +168,21 @@ index af7e4a11..992e6f00 100644
return false;
}
diff --git a/qt5/src/poppler-qt5.h b/qt5/src/poppler-qt5.h
-index 5e78c9e5..386b5562 100644
+index 6c167b65..f1672888 100644
--- a/qt5/src/poppler-qt5.h
+++ b/qt5/src/poppler-qt5.h
-@@ -1166,7 +1166,8 @@ public:
- enum RenderBackend
+@@ -1167,7 +1167,8 @@ public:
{
SplashBackend, ///< Splash backend
-- ArthurBackend ///< Arthur (Qt) backend
-+ ArthurBackend, ///< Arthur (Qt) backend
+ ArthurBackend, ///< \deprecated The old name of the QPainter backend
+- QPainterBackend = ArthurBackend ///< @since 20.11
++ QPainterBackend = ArthurBackend, ///< @since 20.11
+ CairoBackend ///< Cairo backend
};
/**
diff --git a/qt5/tests/CMakeLists.txt b/qt5/tests/CMakeLists.txt
-index b01d0835..561cb5dd 100644
+index b8b5a399..caee9525 100644
--- a/qt5/tests/CMakeLists.txt
+++ b/qt5/tests/CMakeLists.txt
@@ -11,6 +11,11 @@ include_directories(
@@ -198,5 +198,5 @@ index b01d0835..561cb5dd 100644
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Gui_EXECUTABLE_COMPILE_FLAGS}")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Xml_EXECUTABLE_COMPILE_FLAGS}")
--
-2.28.0
+2.29.2