summarylogtreecommitdiffstats
path: root/0001-Cairo-backend-added-to-Qt5-wrapper.patch
diff options
context:
space:
mode:
authorPaul Dann2021-10-20 09:10:14 +0100
committerPaul Dann2021-10-20 09:10:14 +0100
commita57ac6f11bc5bb0eb99d6fa1ff284f647f86faa5 (patch)
treeec65c33b38d98d47b02b3117f64cee62e874a920 /0001-Cairo-backend-added-to-Qt5-wrapper.patch
parent9fa86c65f0d89cbb771faa70d07c5bc73d5a2403 (diff)
downloadaur-a57ac6f11bc5bb0eb99d6fa1ff284f647f86faa5.tar.gz
Update for Poppler 21.10.0
Diffstat (limited to '0001-Cairo-backend-added-to-Qt5-wrapper.patch')
-rw-r--r--0001-Cairo-backend-added-to-Qt5-wrapper.patch24
1 files changed, 12 insertions, 12 deletions
diff --git a/0001-Cairo-backend-added-to-Qt5-wrapper.patch b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
index 18b80f0d0115..67a735a9bd74 100644
--- a/0001-Cairo-backend-added-to-Qt5-wrapper.patch
+++ b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
@@ -1,4 +1,4 @@
-From de98dcd33b731bcb6385eda88ffc8e16730810e0 Mon Sep 17 00:00:00 2001
+From 93a9cbcd59dbb3a221164269886b5d4a45db34a4 Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Wed, 4 Apr 2018 16:36:56 +0100
Subject: [PATCH 1/3] Cairo backend added to Qt5 wrapper
@@ -12,7 +12,7 @@ Subject: [PATCH 1/3] Cairo backend added to Qt5 wrapper
5 files changed, 95 insertions(+), 1 deletion(-)
diff --git a/qt5/src/CMakeLists.txt b/qt5/src/CMakeLists.txt
-index d80c81f3..39d6f9ae 100644
+index 625aa759..6e930172 100644
--- a/qt5/src/CMakeLists.txt
+++ b/qt5/src/CMakeLists.txt
@@ -5,6 +5,11 @@ include_directories(
@@ -40,7 +40,7 @@ index d80c81f3..39d6f9ae 100644
+endif(HAVE_CAIRO)
add_library(poppler-qt5 ${poppler_qt5_SRCS})
generate_export_header(poppler-qt5 BASE_NAME poppler-qt5 EXPORT_FILE_NAME "${CMAKE_CURRENT_BINARY_DIR}/poppler-export.h")
- set_target_properties(poppler-qt5 PROPERTIES VERSION 1.29.0 SOVERSION 1)
+ set_target_properties(poppler-qt5 PROPERTIES VERSION 1.30.0 SOVERSION 1)
@@ -44,6 +56,9 @@ if(MINGW AND BUILD_SHARED_LIBS)
set_target_properties(poppler-qt5 PROPERTIES SUFFIX "-${POPPLER_QT5_SOVERSION}${CMAKE_SHARED_LIBRARY_SUFFIX}")
endif()
@@ -52,7 +52,7 @@ index d80c81f3..39d6f9ae 100644
target_link_libraries(poppler-qt5 poppler ${poppler_LIBS})
endif()
diff --git a/qt5/src/poppler-document.cc b/qt5/src/poppler-document.cc
-index 474f9055..70465c83 100644
+index 4690f313..ecc2da1c 100644
--- a/qt5/src/poppler-document.cc
+++ b/qt5/src/poppler-document.cc
@@ -701,6 +701,9 @@ QSet<Document::RenderBackend> Document::availableRenderBackends()
@@ -66,10 +66,10 @@ index 474f9055..70465c83 100644
}
diff --git a/qt5/src/poppler-page.cc b/qt5/src/poppler-page.cc
-index 65f39bb3..67f54ccf 100644
+index b35894cf..445ebafc 100644
--- a/qt5/src/poppler-page.cc
+++ b/qt5/src/poppler-page.cc
-@@ -53,6 +53,7 @@
+@@ -54,6 +54,7 @@
#include <config.h>
#include <cfloat>
#include <poppler-config.h>
@@ -77,7 +77,7 @@ index 65f39bb3..67f54ccf 100644
#include <PDFDoc.h>
#include <Catalog.h>
#include <Form.h>
-@@ -64,6 +65,9 @@
+@@ -65,6 +66,9 @@
#include <Rendition.h>
#include <SplashOutputDev.h>
#include <splash/SplashBitmap.h>
@@ -87,7 +87,7 @@ index 65f39bb3..67f54ccf 100644
#include "poppler-private.h"
#include "poppler-page-transition-private.h"
-@@ -582,6 +586,69 @@ QImage Page::renderToImage(double xres, double yres, int xPos, int yPos, int w,
+@@ -583,6 +587,69 @@ QImage Page::renderToImage(double xres, double yres, int xPos, int yPos, int w,
img = tmpimg;
break;
}
@@ -157,7 +157,7 @@ index 65f39bb3..67f54ccf 100644
}
if (shouldAbortRenderCallback && shouldAbortRenderCallback(payload))
-@@ -605,6 +672,9 @@ bool Page::renderToPainter(QPainter *painter, double xres, double yres, int x, i
+@@ -606,6 +673,9 @@ bool Page::renderToPainter(QPainter *painter, double xres, double yres, int x, i
return renderToQPainter(&qpainter_output, painter, m_page, xres, yres, x, y, w, h, rotate, flags);
}
@@ -168,10 +168,10 @@ index 65f39bb3..67f54ccf 100644
return false;
}
diff --git a/qt5/src/poppler-qt5.h b/qt5/src/poppler-qt5.h
-index adc97ca1..aa4a6818 100644
+index f307a26e..7dd0f8cf 100644
--- a/qt5/src/poppler-qt5.h
+++ b/qt5/src/poppler-qt5.h
-@@ -1180,7 +1180,8 @@ public:
+@@ -1181,7 +1181,8 @@ public:
{
SplashBackend, ///< Splash backend
ArthurBackend, ///< \deprecated The old name of the QPainter backend
@@ -198,5 +198,5 @@ index 8293a3a1..837c2331 100644
string(REPLACE "-" "" test_name ${exe})
set(${test_name}_SOURCES
--
-2.33.0
+2.33.1