summarylogtreecommitdiffstats
path: root/0001-Cairo-backend-added-to-Qt5-wrapper.patch
diff options
context:
space:
mode:
authorPaul Dann2021-05-09 14:59:38 +0100
committerPaul Dann2021-05-09 15:00:03 +0100
commitbbda99d08a412ab15ef5bf3868c8ae11f5da5a38 (patch)
tree1adc8149fdde8781f29037c7f1b2a58d4773ae9f /0001-Cairo-backend-added-to-Qt5-wrapper.patch
parentef8a3d4a7250b3953f935564778030247edebee9 (diff)
downloadaur-bbda99d08a412ab15ef5bf3868c8ae11f5da5a38.tar.gz
Update for Poppler 21.05.0
Diffstat (limited to '0001-Cairo-backend-added-to-Qt5-wrapper.patch')
-rw-r--r--0001-Cairo-backend-added-to-Qt5-wrapper.patch22
1 files changed, 11 insertions, 11 deletions
diff --git a/0001-Cairo-backend-added-to-Qt5-wrapper.patch b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
index b904d2bd77fc..405e7a84110c 100644
--- a/0001-Cairo-backend-added-to-Qt5-wrapper.patch
+++ b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
@@ -1,4 +1,4 @@
-From e18f0ac0345448e99c9feb10eee62ea03162e6f3 Mon Sep 17 00:00:00 2001
+From 694376bd60615815ef99af3b21a4addd64718354 Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Wed, 4 Apr 2018 16:36:56 +0100
Subject: [PATCH 1/3] Cairo backend added to Qt5 wrapper
@@ -12,7 +12,7 @@ Subject: [PATCH 1/3] Cairo backend added to Qt5 wrapper
5 files changed, 95 insertions(+), 1 deletion(-)
diff --git a/qt5/src/CMakeLists.txt b/qt5/src/CMakeLists.txt
-index 1212bb84..3b3db15a 100644
+index 564cf270..cd5c4280 100644
--- a/qt5/src/CMakeLists.txt
+++ b/qt5/src/CMakeLists.txt
@@ -5,6 +5,11 @@ include_directories(
@@ -40,7 +40,7 @@ index 1212bb84..3b3db15a 100644
+endif(HAVE_CAIRO)
add_library(poppler-qt5 ${poppler_qt5_SRCS})
generate_export_header(poppler-qt5 BASE_NAME poppler-qt5 EXPORT_FILE_NAME "${CMAKE_CURRENT_BINARY_DIR}/poppler-export.h")
- set_target_properties(poppler-qt5 PROPERTIES VERSION 1.27.0 SOVERSION 1)
+ set_target_properties(poppler-qt5 PROPERTIES VERSION 1.28.0 SOVERSION 1)
@@ -44,6 +56,9 @@ if(MINGW AND BUILD_SHARED_LIBS)
set_target_properties(poppler-qt5 PROPERTIES SUFFIX "-${POPPLER_QT5_SOVERSION}${CMAKE_SHARED_LIBRARY_SUFFIX}")
endif()
@@ -66,18 +66,18 @@ index 762eba9f..64e75a3b 100644
}
diff --git a/qt5/src/poppler-page.cc b/qt5/src/poppler-page.cc
-index c433ada4..c2163a23 100644
+index bae438b7..f60e2469 100644
--- a/qt5/src/poppler-page.cc
+++ b/qt5/src/poppler-page.cc
-@@ -51,6 +51,7 @@
-
+@@ -52,6 +52,7 @@
#include <config.h>
+ #include <cfloat>
#include <poppler-config.h>
+#include <math.h>
#include <PDFDoc.h>
#include <Catalog.h>
#include <Form.h>
-@@ -64,6 +65,9 @@
+@@ -65,6 +66,9 @@
# include <SplashOutputDev.h>
# include <splash/SplashBitmap.h>
#endif
@@ -87,7 +87,7 @@ index c433ada4..c2163a23 100644
#include "poppler-private.h"
#include "poppler-page-transition-private.h"
-@@ -568,6 +572,69 @@ QImage Page::renderToImage(double xres, double yres, int xPos, int yPos, int w,
+@@ -585,6 +589,69 @@ QImage Page::renderToImage(double xres, double yres, int xPos, int yPos, int w,
img = tmpimg;
break;
}
@@ -157,7 +157,7 @@ index c433ada4..c2163a23 100644
}
if (shouldAbortRenderCallback && shouldAbortRenderCallback(payload))
-@@ -591,6 +658,9 @@ bool Page::renderToPainter(QPainter *painter, double xres, double yres, int x, i
+@@ -608,6 +675,9 @@ bool Page::renderToPainter(QPainter *painter, double xres, double yres, int x, i
return renderToQPainter(&qpainter_output, painter, m_page, xres, yres, x, y, w, h, rotate, flags);
}
@@ -168,10 +168,10 @@ index c433ada4..c2163a23 100644
return false;
}
diff --git a/qt5/src/poppler-qt5.h b/qt5/src/poppler-qt5.h
-index 2d879f78..cc228b0f 100644
+index a3163572..68482722 100644
--- a/qt5/src/poppler-qt5.h
+++ b/qt5/src/poppler-qt5.h
-@@ -1170,7 +1170,8 @@ public:
+@@ -1177,7 +1177,8 @@ public:
{
SplashBackend, ///< Splash backend
ArthurBackend, ///< \deprecated The old name of the QPainter backend