summarylogtreecommitdiffstats
path: root/0001-Cairo-backend-added-to-Qt5-wrapper.patch
diff options
context:
space:
mode:
authorPaul Gideon Dann2019-08-01 16:22:09 +0100
committerPaul Gideon Dann2019-08-01 16:22:09 +0100
commitd483972d957f2660628006bd29e280de27f080c8 (patch)
treec886a1e88d56d0893f72fa038594c291a5118d94 /0001-Cairo-backend-added-to-Qt5-wrapper.patch
parent0ccbbb07797fbaaa19a8aea207e7b6cfd0418590 (diff)
downloadaur-d483972d957f2660628006bd29e280de27f080c8.tar.gz
Update for Poppler 0.79.0
Diffstat (limited to '0001-Cairo-backend-added-to-Qt5-wrapper.patch')
-rw-r--r--0001-Cairo-backend-added-to-Qt5-wrapper.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/0001-Cairo-backend-added-to-Qt5-wrapper.patch b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
index 0fcdeff46121..b30e86d5d761 100644
--- a/0001-Cairo-backend-added-to-Qt5-wrapper.patch
+++ b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
@@ -1,4 +1,4 @@
-From facc89e9435bfeedd1f38d05c32c95eaf84122cc Mon Sep 17 00:00:00 2001
+From caf6c676532d5767f7d52d589f2d1569f2554af9 Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Wed, 4 Apr 2018 16:36:56 +0100
Subject: [PATCH 1/4] Cairo backend added to Qt5 wrapper
@@ -12,7 +12,7 @@ Subject: [PATCH 1/4] Cairo backend added to Qt5 wrapper
5 files changed, 95 insertions(+), 1 deletion(-)
diff --git a/qt5/src/CMakeLists.txt b/qt5/src/CMakeLists.txt
-index 340a3e43..86627bb9 100644
+index e3b60fcb..a32b6799 100644
--- a/qt5/src/CMakeLists.txt
+++ b/qt5/src/CMakeLists.txt
@@ -8,6 +8,11 @@ include_directories(
@@ -39,7 +39,7 @@ index 340a3e43..86627bb9 100644
+ )
+endif(HAVE_CAIRO)
add_library(poppler-qt5 ${poppler_qt5_SRCS})
- set_target_properties(poppler-qt5 PROPERTIES VERSION 1.19.0 SOVERSION 1)
+ set_target_properties(poppler-qt5 PROPERTIES VERSION 1.20.0 SOVERSION 1)
if(MINGW AND BUILD_SHARED_LIBS)
@@ -45,6 +57,9 @@ if(MINGW AND BUILD_SHARED_LIBS)
set_target_properties(poppler-qt5 PROPERTIES SUFFIX "-${POPPLER_QT5_SOVERSION}${CMAKE_SHARED_LIBRARY_SUFFIX}")
@@ -66,7 +66,7 @@ index 81db4eaf..635e44f9 100644
}
diff --git a/qt5/src/poppler-page.cc b/qt5/src/poppler-page.cc
-index 4676dcd8..7b952d3a 100644
+index bf1f8889..592da057 100644
--- a/qt5/src/poppler-page.cc
+++ b/qt5/src/poppler-page.cc
@@ -48,6 +48,7 @@
@@ -168,7 +168,7 @@ index 4676dcd8..7b952d3a 100644
return false;
}
diff --git a/qt5/src/poppler-qt5.h b/qt5/src/poppler-qt5.h
-index c03fec15..b59a93f1 100644
+index ebbc456a..37adf71a 100644
--- a/qt5/src/poppler-qt5.h
+++ b/qt5/src/poppler-qt5.h
@@ -1144,7 +1144,8 @@ delete it;