summarylogtreecommitdiffstats
path: root/0001-Cairo-backend-added-to-Qt5-wrapper.patch
diff options
context:
space:
mode:
authorPaul Dann2021-04-07 12:09:23 +0100
committerPaul Dann2021-04-07 12:09:23 +0100
commitef8a3d4a7250b3953f935564778030247edebee9 (patch)
tree9e37ecab5d5f0d1c34ddc748eb0795ba47c4333f /0001-Cairo-backend-added-to-Qt5-wrapper.patch
parent0091db97759ddf4053107295d1083c929efd6ac9 (diff)
downloadaur-ef8a3d4a7250b3953f935564778030247edebee9.tar.gz
Update for Poppler 21.04.0
Diffstat (limited to '0001-Cairo-backend-added-to-Qt5-wrapper.patch')
-rw-r--r--0001-Cairo-backend-added-to-Qt5-wrapper.patch24
1 files changed, 12 insertions, 12 deletions
diff --git a/0001-Cairo-backend-added-to-Qt5-wrapper.patch b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
index 971d0c33a129..b904d2bd77fc 100644
--- a/0001-Cairo-backend-added-to-Qt5-wrapper.patch
+++ b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
@@ -1,4 +1,4 @@
-From 8c61ead91cca890bd6307428902e28f27dcdabd1 Mon Sep 17 00:00:00 2001
+From e18f0ac0345448e99c9feb10eee62ea03162e6f3 Mon Sep 17 00:00:00 2001
From: Paul Gideon Dann <pdgiddie@gmail.com>
Date: Wed, 4 Apr 2018 16:36:56 +0100
Subject: [PATCH 1/3] Cairo backend added to Qt5 wrapper
@@ -12,7 +12,7 @@ Subject: [PATCH 1/3] Cairo backend added to Qt5 wrapper
5 files changed, 95 insertions(+), 1 deletion(-)
diff --git a/qt5/src/CMakeLists.txt b/qt5/src/CMakeLists.txt
-index afacd2c3..4c9ee018 100644
+index 1212bb84..3b3db15a 100644
--- a/qt5/src/CMakeLists.txt
+++ b/qt5/src/CMakeLists.txt
@@ -5,6 +5,11 @@ include_directories(
@@ -39,9 +39,9 @@ index afacd2c3..4c9ee018 100644
+ )
+endif(HAVE_CAIRO)
add_library(poppler-qt5 ${poppler_qt5_SRCS})
+ generate_export_header(poppler-qt5 BASE_NAME poppler-qt5 EXPORT_FILE_NAME "${CMAKE_CURRENT_BINARY_DIR}/poppler-export.h")
set_target_properties(poppler-qt5 PROPERTIES VERSION 1.27.0 SOVERSION 1)
- if(MINGW AND BUILD_SHARED_LIBS)
-@@ -43,6 +55,9 @@ if(MINGW AND BUILD_SHARED_LIBS)
+@@ -44,6 +56,9 @@ if(MINGW AND BUILD_SHARED_LIBS)
set_target_properties(poppler-qt5 PROPERTIES SUFFIX "-${POPPLER_QT5_SOVERSION}${CMAKE_SHARED_LIBRARY_SUFFIX}")
endif()
target_link_libraries(poppler-qt5 poppler Qt5::Core Qt5::Gui Qt5::Xml ${FREETYPE_LIBRARIES})
@@ -52,7 +52,7 @@ index afacd2c3..4c9ee018 100644
target_link_libraries(poppler-qt5 poppler ${poppler_LIBS})
endif()
diff --git a/qt5/src/poppler-document.cc b/qt5/src/poppler-document.cc
-index 0a2a6ce4..a6d02fa1 100644
+index 762eba9f..64e75a3b 100644
--- a/qt5/src/poppler-document.cc
+++ b/qt5/src/poppler-document.cc
@@ -696,6 +696,9 @@ QSet<Document::RenderBackend> Document::availableRenderBackends()
@@ -66,7 +66,7 @@ index 0a2a6ce4..a6d02fa1 100644
}
diff --git a/qt5/src/poppler-page.cc b/qt5/src/poppler-page.cc
-index 31c60698..94389f9f 100644
+index c433ada4..c2163a23 100644
--- a/qt5/src/poppler-page.cc
+++ b/qt5/src/poppler-page.cc
@@ -51,6 +51,7 @@
@@ -87,7 +87,7 @@ index 31c60698..94389f9f 100644
#include "poppler-private.h"
#include "poppler-page-transition-private.h"
-@@ -564,6 +568,69 @@ QImage Page::renderToImage(double xres, double yres, int xPos, int yPos, int w,
+@@ -568,6 +572,69 @@ QImage Page::renderToImage(double xres, double yres, int xPos, int yPos, int w,
img = tmpimg;
break;
}
@@ -157,7 +157,7 @@ index 31c60698..94389f9f 100644
}
if (shouldAbortRenderCallback && shouldAbortRenderCallback(payload))
-@@ -587,6 +654,9 @@ bool Page::renderToPainter(QPainter *painter, double xres, double yres, int x, i
+@@ -591,6 +658,9 @@ bool Page::renderToPainter(QPainter *painter, double xres, double yres, int x, i
return renderToQPainter(&qpainter_output, painter, m_page, xres, yres, x, y, w, h, rotate, flags);
}
@@ -182,11 +182,11 @@ index 2d879f78..cc228b0f 100644
/**
diff --git a/qt5/tests/CMakeLists.txt b/qt5/tests/CMakeLists.txt
-index 82ef2139..56860c32 100644
+index c3decb92..95d7f325 100644
--- a/qt5/tests/CMakeLists.txt
+++ b/qt5/tests/CMakeLists.txt
-@@ -6,6 +6,11 @@ include_directories(
- ${CMAKE_CURRENT_BINARY_DIR}
+@@ -7,6 +7,11 @@ include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}/../src
)
+if (HAVE_CAIRO)
@@ -198,5 +198,5 @@ index 82ef2139..56860c32 100644
string(REPLACE "-" "" test_name ${exe})
set(${test_name}_SOURCES
--
-2.30.1
+2.31.1