summarylogtreecommitdiffstats
path: root/0001-Cairo-backend-added-to-Qt5-wrapper.patch
diff options
context:
space:
mode:
authorKevin Slagle2018-03-31 14:49:56 -0400
committerKevin Slagle2018-03-31 14:49:56 -0400
commita80b5aad867b62cd149f6a8d0db52c0d3fb2d66d (patch)
tree13cc8a56cf21dd6ab71a8608ab8497aa273bbd7c /0001-Cairo-backend-added-to-Qt5-wrapper.patch
downloadaur-a80b5aad867b62cd149f6a8d0db52c0d3fb2d66d.tar.gz
version 0.61.1
Diffstat (limited to '0001-Cairo-backend-added-to-Qt5-wrapper.patch')
-rw-r--r--0001-Cairo-backend-added-to-Qt5-wrapper.patch202
1 files changed, 202 insertions, 0 deletions
diff --git a/0001-Cairo-backend-added-to-Qt5-wrapper.patch b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
new file mode 100644
index 000000000000..482c3cfef632
--- /dev/null
+++ b/0001-Cairo-backend-added-to-Qt5-wrapper.patch
@@ -0,0 +1,202 @@
+From b338ffeaa1cd104dd6c64d2361c3deb981efd0de Mon Sep 17 00:00:00 2001
+From: Kevin Slagle <kjslag@gmail.com>
+Date: Sat, 31 Mar 2018 14:13:25 -0400
+Subject: [PATCH 1/3] Cairo backend added to Qt5 wrapper
+
+---
+ qt5/src/CMakeLists.txt | 15 ++++++++++
+ qt5/src/poppler-document.cc | 3 ++
+ qt5/src/poppler-page.cc | 70 +++++++++++++++++++++++++++++++++++++++++++++
+ qt5/src/poppler-qt5.h | 3 +-
+ qt5/tests/CMakeLists.txt | 5 ++++
+ 5 files changed, 95 insertions(+), 1 deletion(-)
+
+diff --git a/qt5/src/CMakeLists.txt b/qt5/src/CMakeLists.txt
+index 7993c33b..80a3c054 100644
+--- a/qt5/src/CMakeLists.txt
++++ b/qt5/src/CMakeLists.txt
+@@ -7,6 +7,11 @@ include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ )
+
++if (HAVE_CAIRO)
++ include_directories(${CAIRO_INCLUDE_DIRS})
++ add_definitions(${CAIRO_CFLAGS})
++endif (HAVE_CAIRO)
++
+ set(poppler_qt5_SRCS
+ poppler-annotation.cc
+ poppler-document.cc
+@@ -29,6 +34,13 @@ set(poppler_qt5_SRCS
+ poppler-media.cc
+ ArthurOutputDev.cc
+ )
++if (HAVE_CAIRO)
++ set(poppler_qt5_SRCS ${poppler_qt5_SRCS}
++ ${CMAKE_SOURCE_DIR}/poppler/CairoOutputDev.cc
++ ${CMAKE_SOURCE_DIR}/poppler/CairoRescaleBox.cc
++ ${CMAKE_SOURCE_DIR}/poppler/CairoFontEngine.cc
++ )
++endif(HAVE_CAIRO)
+ add_library(poppler-qt5 SHARED ${poppler_qt5_SRCS})
+ set_target_properties(poppler-qt5 PROPERTIES VERSION 1.11.0 SOVERSION 1)
+ if(MINGW)
+@@ -36,6 +48,9 @@ if(MINGW)
+ set_target_properties(poppler-qt5 PROPERTIES SUFFIX "-${POPPLER_QT5_SOVERSION}${CMAKE_SHARED_LIBRARY_SUFFIX}")
+ endif()
+ target_link_libraries(poppler-qt5 poppler ${Qt5Core_LIBRARIES} ${Qt5Gui_LIBRARIES} ${Qt5Xml_LIBRARIES})
++if (HAVE_CAIRO)
++ target_link_libraries(poppler-qt5 ${CAIRO_LIBRARIES})
++endif (HAVE_CAIRO)
+ if(MSVC)
+ target_link_libraries(poppler-qt5 poppler ${poppler_LIBS})
+ endif()
+diff --git a/qt5/src/poppler-document.cc b/qt5/src/poppler-document.cc
+index 03077f99..8f67ad80 100644
+--- a/qt5/src/poppler-document.cc
++++ b/qt5/src/poppler-document.cc
+@@ -675,6 +675,9 @@ namespace Poppler {
+ ret << Document::SplashBackend;
+ #endif
+ ret << Document::ArthurBackend;
++#if defined(HAVE_CAIRO)
++ ret << Document::CairoBackend;
++#endif
+ return ret;
+ }
+
+diff --git a/qt5/src/poppler-page.cc b/qt5/src/poppler-page.cc
+index 9dcdaad9..2706e83a 100644
+--- a/qt5/src/poppler-page.cc
++++ b/qt5/src/poppler-page.cc
+@@ -44,6 +44,7 @@
+ #include <QtGui/QPainter>
+
+ #include <config.h>
++#include <math.h>
+ #include <PDFDoc.h>
+ #include <Catalog.h>
+ #include <Form.h>
+@@ -57,6 +58,9 @@
+ #include <SplashOutputDev.h>
+ #include <splash/SplashBitmap.h>
+ #endif
++#if defined(HAVE_CAIRO)
++#include <CairoOutputDev.h>
++#endif
+
+ #include "poppler-private.h"
+ #include "poppler-page-transition-private.h"
+@@ -440,6 +444,70 @@ QImage Page::renderToImage(double xres, double yres, int x, int y, int w, int h,
+ img = tmpimg;
+ break;
+ }
++ case Poppler::Document::CairoBackend:
++ {
++#if defined(HAVE_CAIRO)
++ CairoOutputDev *output_dev = new CairoOutputDev();
++ output_dev->startDoc(m_page->parentDoc->doc);
++ int buffer_width, buffer_height, rotate;
++ cairo_surface_t *surface;
++ cairo_t *cairo;
++
++ // If w or h are -1, that indicates the whole page, so we need to
++ // calculate how many pixels that corresponds to. Otherwise, we can use w
++ // or h directly for our buffer size.
++ const QSize pageSize = this->pageSize();
++ if (w == -1) {
++ const double xscale = xres / 72.0;
++ const double width = pageSize.width();;
++ buffer_width = (int) ceil(width * xscale);
++ } else {
++ buffer_width = w;
++ }
++ if (h == -1) {
++ const double yscale = yres / 72.0;
++ const double height = pageSize.height();
++ buffer_height = (int) ceil(height * yscale);
++ } else {
++ buffer_height = h;
++ }
++
++ rotate = rotation + m_page->page->getRotate();
++
++ // FIXME: Okular never provides a rotation value, so I don't have any way
++ // of testing this right now. The result is that subpixels are ordered
++ // incorrectly when the page is rotated.
++
++ //if (rotate == 90 || rotate == 270) {
++ // const double temp = height;
++ // height = width;
++ // width = temp;
++ //}
++
++ img = QImage(buffer_width, buffer_height, QImage::Format_ARGB32);
++ img.fill(Qt::white); // Never transparent
++
++ surface = cairo_image_surface_create_for_data(
++ img.bits(),
++ CAIRO_FORMAT_ARGB32,
++ buffer_width, buffer_height,
++ img.bytesPerLine());
++
++ cairo = cairo_create(surface);
++ output_dev->setCairo(cairo);
++
++ m_page->parentDoc->doc->displayPageSlice(
++ output_dev, m_page->index + 1, xres, yres, rotation, false, true,
++ false, x, y, w, h);
++
++ // Clean up
++ output_dev->setCairo(NULL);
++ cairo_destroy(cairo);
++ cairo_surface_destroy(surface);
++ delete output_dev;
++#endif
++ break;
++ }
+ }
+
+ return img;
+@@ -499,6 +567,8 @@ bool Page::renderToPainter(QPainter* painter, double xres, double yres, int x, i
+ painter->restore();
+ return true;
+ }
++ case Poppler::Document::CairoBackend:
++ return false;
+ }
+ return false;
+ }
+diff --git a/qt5/src/poppler-qt5.h b/qt5/src/poppler-qt5.h
+index fcfe2d31..1da12e9b 100644
+--- a/qt5/src/poppler-qt5.h
++++ b/qt5/src/poppler-qt5.h
+@@ -878,7 +878,8 @@ delete it;
+ */
+ enum RenderBackend {
+ SplashBackend, ///< Splash backend
+- ArthurBackend ///< Arthur (Qt) backend
++ ArthurBackend, ///< Arthur (Qt) backend
++ CairoBackend ///< Cairo backend
+ };
+
+ /**
+diff --git a/qt5/tests/CMakeLists.txt b/qt5/tests/CMakeLists.txt
+index 01a1a970..d6d241c6 100644
+--- a/qt5/tests/CMakeLists.txt
++++ b/qt5/tests/CMakeLists.txt
+@@ -11,6 +11,11 @@ include_directories(
+ ${Qt5Widgets_INCLUDE_DIRS}
+ )
+
++if (HAVE_CAIRO)
++ include_directories(${CAIRO_INCLUDE_DIRS})
++ add_definitions(${CAIRO_CFLAGS})
++endif (HAVE_CAIRO)
++
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Core_EXECUTABLE_COMPILE_FLAGS}")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Gui_EXECUTABLE_COMPILE_FLAGS}")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Xml_EXECUTABLE_COMPILE_FLAGS}")
+--
+2.16.2
+