summarylogtreecommitdiffstats
path: root/0001-Compile-JudyTablesGen-for-the-build-system.patch
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2025-03-15 15:55:20 -0300
committerGonzalo Exequiel Pedone2025-03-15 15:55:20 -0300
commit49e96fcad33b81991e1c65ca9887453ad2faf636 (patch)
treef640fba6e99abec8f3291ad7aec52441b45bcd38 /0001-Compile-JudyTablesGen-for-the-build-system.patch
downloadaur-49e96fcad33b81991e1c65ca9887453ad2faf636.tar.gz
Package updated.
Diffstat (limited to '0001-Compile-JudyTablesGen-for-the-build-system.patch')
-rw-r--r--0001-Compile-JudyTablesGen-for-the-build-system.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/0001-Compile-JudyTablesGen-for-the-build-system.patch b/0001-Compile-JudyTablesGen-for-the-build-system.patch
new file mode 100644
index 000000000000..4829a2c7681a
--- /dev/null
+++ b/0001-Compile-JudyTablesGen-for-the-build-system.patch
@@ -0,0 +1,22 @@
+--- a/src/Judy1/Makefile.in
++++ b/src/Judy1/Makefile.in
+@@ -560,7 +560,7 @@
+
+
+ Judy1Tables.c: Judy1TablesGen.c
+- $(CC) $(INCLUDES) $(AM_CFLAGS) @CFLAGS@ -o Judy1TablesGen Judy1TablesGen.c; ./Judy1TablesGen
++ clang $(INCLUDES) $(AM_CFLAGS) @CFLAGS@ -o Judy1TablesGen Judy1TablesGen.c; ./Judy1TablesGen
+
+ Judy1ByCount.c:../JudyCommon/JudyByCount.c
+ cp -f ../JudyCommon/JudyByCount.c Judy1ByCount.c
+--- a/src/JudyL/Makefile.in
++++ b/src/JudyL/Makefile.in
+@@ -560,7 +560,7 @@
+
+
+ JudyLTables.c: JudyLTablesGen.c
+- $(CC) $(INCLUDES) $(AM_CFLAGS) @CFLAGS@ -o JudyLTablesGen JudyLTablesGen.c; ./JudyLTablesGen
++ clang $(INCLUDES) $(AM_CFLAGS) @CFLAGS@ -o JudyLTablesGen JudyLTablesGen.c; ./JudyLTablesGen
+
+ JudyLByCount.c: ../JudyCommon/JudyByCount.c
+ cp -f ../JudyCommon/JudyByCount.c JudyLByCount.c