summarylogtreecommitdiffstats
path: root/0001-Emit-the-correct-LIBNAME-to-.pc-files.patch
diff options
context:
space:
mode:
authorAndrew Sun2018-06-16 20:55:22 -0400
committerAndrew Sun2018-06-16 20:55:22 -0400
commit106aa184cacf7b064cf89a531c26cdbf848a517c (patch)
treeeb6bc40b7fb6514f876559fd709e211176e5aca3 /0001-Emit-the-correct-LIBNAME-to-.pc-files.patch
parent4790a49942103e9ff188cc365e9d49f3b0c172c0 (diff)
downloadaur-106aa184cacf7b064cf89a531c26cdbf848a517c.tar.gz
add missing patch
Diffstat (limited to '0001-Emit-the-correct-LIBNAME-to-.pc-files.patch')
-rw-r--r--0001-Emit-the-correct-LIBNAME-to-.pc-files.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/0001-Emit-the-correct-LIBNAME-to-.pc-files.patch b/0001-Emit-the-correct-LIBNAME-to-.pc-files.patch
new file mode 100644
index 000000000000..2d09e8b1f2ad
--- /dev/null
+++ b/0001-Emit-the-correct-LIBNAME-to-.pc-files.patch
@@ -0,0 +1,47 @@
+From d06589f55c87370d388dec333f4bff35c29762f3 Mon Sep 17 00:00:00 2001
+From: Ray Donnelly <mingw.android@gmail.com>
+Date: Fri, 8 Jan 2016 16:46:01 +0000
+Subject: [PATCH] Emit the correct LIBNAME to .pc files
+
+Irrespective of "FREEGLUT_REPLACE_GLUT" being set to "No" or being on
+Win32 where this variable does not even exist, the .pc file contained
+Libs: -L${libdir} -lglut
+
+Instead, emit the correct value.
+---
+ freeglut/freeglut/CMakeLists.txt | 5 ++---
+ 1 file changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/freeglut/freeglut/CMakeLists.txt b/freeglut/freeglut/CMakeLists.txt
+index 71f4ef5..7fae09a 100644
+--- a/freeglut/freeglut/CMakeLists.txt
++++ b/freeglut/freeglut/CMakeLists.txt
+@@ -389,6 +389,7 @@ IF(FREEGLUT_BUILD_STATIC_LIBS)
+ ENDIF()
+
+
++SET(LIBNAME freeglut)
+ IF(WIN32)
+ LIST(APPEND LIBS winmm)
+ IF(FREEGLUT_BUILD_SHARED_LIBS)
+@@ -424,8 +425,6 @@ ELSE()
+ ELSE()
+ IF(FREEGLUT_REPLACE_GLUT)
+ SET(LIBNAME glut)
+- ELSE()
+- SET(LIBNAME freeglut)
+ ENDIF()
+ ENDIF()
+
+@@ -563,7 +562,7 @@ ELSE()
+ ENDIF()
+ # Client applications need to define FreeGLUT GLES version to
+ # bootstrap headers inclusion in freeglut_std.h:
+-SET(PC_LIBNAME "glut")
++SET(PC_LIBNAME ${LIBNAME})
+ SET(PC_FILENAME "freeglut.pc")
+ IF(FREEGLUT_GLES)
+ SET(PC_CFLAGS "-DFREEGLUT_GLES")
+--
+2.6.3
+