summarylogtreecommitdiffstats
path: root/0001-Exclude-qmltime-when-cross-compiling.patch
diff options
context:
space:
mode:
authorMartchus2021-06-10 15:44:17 +0200
committerMartchus2021-06-10 15:44:17 +0200
commit7a45902580089775f536a4e60beda3289f17fe6e (patch)
tree4026c0d2ef6d3d2f0804e8353111356b7cffe57b /0001-Exclude-qmltime-when-cross-compiling.patch
parent45502e96d0e1c90ca9bfb0f5f320f88ff5a488af (diff)
downloadaur-7a45902580089775f536a4e60beda3289f17fe6e.tar.gz
Update to 6.1.1
Diffstat (limited to '0001-Exclude-qmltime-when-cross-compiling.patch')
-rw-r--r--0001-Exclude-qmltime-when-cross-compiling.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/0001-Exclude-qmltime-when-cross-compiling.patch b/0001-Exclude-qmltime-when-cross-compiling.patch
new file mode 100644
index 000000000000..4215bd2f1960
--- /dev/null
+++ b/0001-Exclude-qmltime-when-cross-compiling.patch
@@ -0,0 +1,33 @@
+From 09f7c0b03aa26e1e7862f57bf9cc4105665ce879 Mon Sep 17 00:00:00 2001
+From: Martchus <martchus@gmx.net>
+Date: Fri, 5 Feb 2021 02:22:45 +0100
+Subject: [PATCH] Exclude qmltime when cross compiling
+
+as the build script would attempt to set the property of a target
+which does not exist (leading to a configuration error).
+
+This tool seems not really requird and is already disabled when
+compiling for Android or when compiling static libraries anyways.
+That's likely also why upstream did not notice this problem so far.
+---
+ tools/CMakeLists.txt | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
+index 8438e8c6fa..23753dd0dc 100644
+--- a/tools/CMakeLists.txt
++++ b/tools/CMakeLists.txt
+@@ -30,7 +30,9 @@ if(QT_FEATURE_qml_preview AND QT_FEATURE_thread AND NOT ANDROID AND NOT WASM AND
+ endif()
+ if(QT_BUILD_SHARED_LIBS AND QT_FEATURE_thread AND TARGET Qt::Quick AND NOT ANDROID AND NOT WASM AND NOT rtems)
+ add_subdirectory(qmlscene)
+- add_subdirectory(qmltime)
++ if(NOT CMAKE_CROSSCOMPILING)
++ add_subdirectory(qmltime)
++ endif()
+ endif()
+ if(QT_BUILD_SHARED_LIBS AND QT_FEATURE_process AND QT_FEATURE_regularexpression AND QT_FEATURE_thread AND TARGET Qt::Quick AND NOT ANDROID AND NOT WASM AND NOT rtems)
+ add_subdirectory(qmlplugindump)
+--
+2.32.0
+