summarylogtreecommitdiffstats
path: root/0001-Fix-libs-install.patch
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2024-11-10 09:25:41 -0300
committerGonzalo Exequiel Pedone2024-11-10 09:25:41 -0300
commit1acb2ba1d1c309ad865e7d9400a2ab2bbb078cbf (patch)
tree51388851535b37767afdd8de71c68d4e27165254 /0001-Fix-libs-install.patch
parentfa016efa166c828dcdf3c2ed7cff8c3ee07c4212 (diff)
downloadaur-1acb2ba1d1c309ad865e7d9400a2ab2bbb078cbf.tar.gz
Package updated to 2.8.
Diffstat (limited to '0001-Fix-libs-install.patch')
-rw-r--r--0001-Fix-libs-install.patch21
1 files changed, 14 insertions, 7 deletions
diff --git a/0001-Fix-libs-install.patch b/0001-Fix-libs-install.patch
index e857077dffcf..9efe4fe162ab 100644
--- a/0001-Fix-libs-install.patch
+++ b/0001-Fix-libs-install.patch
@@ -1,10 +1,7 @@
--- a/src/Makefile
+++ b/src/Makefile
-@@ -19,11 +19,12 @@
- LINK_FLAGS=-Wl,-z,defs
- LINK_FLAGS+=$(LDFLAGS)
+@@ -19,9 +19,9 @@
ENABLE_SHARED ?= 1
-+DESTDIR ?= /usr
soname=liburing.so.$(VERSION_MAJOR)
-libname=liburing.so.$(VERSION)
@@ -15,14 +12,23 @@
all_targets += liburing.a
all_targets += liburing-ffi.a
-@@ -85,20 +86,16 @@
- $(QUIET_CC)$(CC) $(SO_CFLAGS) -shared -Wl,--version-script=liburing-ffi.map -Wl,-soname=$(ffi_soname) -o $@ $(liburing_sobjs) $(liburing_ffi_sobjs) $(LINK_FLAGS)
+@@ -91,27 +91,23 @@
+ $(QUIET_RANLIB)$(RANLIB) liburing-ffi.a
+
+ $(libname): $(liburing_sobjs) liburing.map
+- $(QUIET_CC)$(CC) $(SO_CFLAGS) -shared -Wl,--version-script=liburing.map -Wl,-soname=$(soname) -o $@ $(liburing_sobjs) $(LINK_FLAGS)
++ $(CC) $(SO_CFLAGS) -shared -o $@ $(liburing_sobjs) $(LINK_FLAGS)
+
+ $(ffi_libname): $(liburing_ffi_objs) $(liburing_ffi_sobjs) $(liburing_sobjs) liburing-ffi.map
+- $(QUIET_CC)$(CC) $(SO_CFLAGS) -shared -Wl,--version-script=liburing-ffi.map -Wl,-soname=$(ffi_soname) -o $@ $(liburing_sobjs) $(liburing_ffi_sobjs) $(LINK_FLAGS)
++ $(CC) $(SO_CFLAGS) -shared -o $@ $(liburing_sobjs) $(liburing_ffi_sobjs) $(LINK_FLAGS)
install: $(all_targets)
- install -D -m 644 include/liburing/io_uring.h $(includedir)/liburing/io_uring.h
- install -D -m 644 include/liburing.h $(includedir)/liburing.h
- install -D -m 644 include/liburing/compat.h $(includedir)/liburing/compat.h
- install -D -m 644 include/liburing/barrier.h $(includedir)/liburing/barrier.h
+- install -D -m 644 include/liburing/sanitize.h $(includedir)/liburing/sanitize.h
- install -D -m 644 include/liburing/io_uring_version.h $(includedir)/liburing/io_uring_version.h
- install -D -m 644 liburing.a $(libdevdir)/liburing.a
- install -D -m 644 liburing-ffi.a $(libdevdir)/liburing-ffi.a
@@ -30,6 +36,7 @@
+ install -D -m 644 include/liburing.h $(DESTDIR)$(includedir)/liburing.h
+ install -D -m 644 include/liburing/compat.h $(DESTDIR)$(includedir)/liburing/compat.h
+ install -D -m 644 include/liburing/barrier.h $(DESTDIR)$(includedir)/liburing/barrier.h
++ install -D -m 644 include/liburing/sanitize.h $(DESTDIR)$(includedir)/liburing/sanitize.h
+ install -D -m 644 include/liburing/io_uring_version.h $(DESTDIR)$(includedir)/liburing/io_uring_version.h
+ install -D -m 644 liburing.a $(DESTDIR)$(libdevdir)/liburing.a
+ install -D -m 644 liburing-ffi.a $(DESTDIR)$(libdevdir)/liburing-ffi.a
@@ -44,4 +51,4 @@
+ install -D -m 755 $(ffi_libname) $(DESTDIR)$(libdir)/$(ffi_libname)
endif
- clean:
+ uninstall: