summarylogtreecommitdiffstats
path: root/0001-Remove-strdup-implementation.patch
diff options
context:
space:
mode:
authorMaxime Arthaud2018-12-10 20:52:28 -0800
committerMaxime Arthaud2018-12-10 20:52:28 -0800
commit8e22c82f43e71ff9899e59d68a5f38447ddcdee9 (patch)
treef0f7c4d8bca8400213ad264b3c5a3cda0d52fdcc /0001-Remove-strdup-implementation.patch
downloadaur-8e22c82f43e71ff9899e59d68a5f38447ddcdee9.tar.gz
Import PKGBUILD from apron-ppl-svn
Diffstat (limited to '0001-Remove-strdup-implementation.patch')
-rw-r--r--0001-Remove-strdup-implementation.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/0001-Remove-strdup-implementation.patch b/0001-Remove-strdup-implementation.patch
new file mode 100644
index 000000000000..f17354a6a047
--- /dev/null
+++ b/0001-Remove-strdup-implementation.patch
@@ -0,0 +1,20 @@
+--- apron/ap_config.h 2009-09-11 11:00:27.000000000 -0700
++++ apron/ap_config.h 2018-12-10 20:40:51.914905968 -0800
+@@ -23,17 +23,6 @@
+ static const bool true = 1;
+ #endif
+
+-#if !(defined __USE_SVID || defined __USE_BSD || defined __USE_XOPEN_EXTENDED || defined __APPLE__ || defined __CYGWIN__)
+-
+-static inline char* strdup(const char* s){
+- char* s2;
+-
+- s2 = malloc(strlen(s)+1);
+- strcpy(s2,s);
+- return s2;
+-}
+-#endif
+-
+ #ifdef __cplusplus
+ }
+ #endif