summarylogtreecommitdiffstats
path: root/0001-Unset-EDITOR-env-var-in-test_run_hook_edit.patch
diff options
context:
space:
mode:
authorCarl Smedstad2022-01-04 15:55:04 +0100
committerCarl Smedstad2022-01-04 15:55:04 +0100
commit94c952de02f8c528a1f18013b6d6338239e9b395 (patch)
treedd453e51e64cc12428b6257f57b9c10099c69ba7 /0001-Unset-EDITOR-env-var-in-test_run_hook_edit.patch
parente8a97b4ce35d3134e83a9dce21326c2a47d2eeec (diff)
downloadaur-94c952de02f8c528a1f18013b6d6338239e9b395.tar.gz
Update to version 0.17.0 and refactor PKGBUILD
Diffstat (limited to '0001-Unset-EDITOR-env-var-in-test_run_hook_edit.patch')
-rw-r--r--0001-Unset-EDITOR-env-var-in-test_run_hook_edit.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/0001-Unset-EDITOR-env-var-in-test_run_hook_edit.patch b/0001-Unset-EDITOR-env-var-in-test_run_hook_edit.patch
new file mode 100644
index 000000000000..c70a5b1de521
--- /dev/null
+++ b/0001-Unset-EDITOR-env-var-in-test_run_hook_edit.patch
@@ -0,0 +1,27 @@
+From 46bc5ab843d9f83d8fa6869ba04de7adc4320dfb Mon Sep 17 00:00:00 2001
+From: Carl Smedstad <carl.smedstad@protonmail.com>
+Date: Tue, 4 Jan 2022 14:02:04 +0100
+Subject: [PATCH] Unset EDITOR env var in test_run_hook_edit
+
+Without this the test will fail if the EDITOR env var is set to
+something different than 'vim -n'.
+---
+ gitlint-core/gitlint/tests/cli/test_cli_hooks.py | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/gitlint-core/gitlint/tests/cli/test_cli_hooks.py b/gitlint-core/gitlint/tests/cli/test_cli_hooks.py
+index 825345f..6cb03de 100644
+--- a/gitlint-core/gitlint/tests/cli/test_cli_hooks.py
++++ b/gitlint-core/gitlint/tests/cli/test_cli_hooks.py
+@@ -132,6 +132,8 @@ class CLIHookTests(BaseTestCase):
+ for i in range(0, len(set_editors)):
+ if set_editors[i]:
+ os.environ['EDITOR'] = set_editors[i]
++ else:
++ os.environ.pop('EDITOR', None)
+
+ with self.patch_input(['e', 'e', 'n']):
+ with self.tempdir() as tmpdir:
+--
+2.34.1
+