summarylogtreecommitdiffstats
path: root/0001-Use-Arch-Linux-device-access-groups.patch
diff options
context:
space:
mode:
authorYurii Kolesnykov2021-07-04 07:33:35 +0300
committerYurii Kolesnykov2021-07-04 07:33:35 +0300
commit395a17eee8f209ffe04d5a3e7dc0fa3324fdf0f7 (patch)
treeaad34a3b79d6c759aa915f7faa5b3e93602839a8 /0001-Use-Arch-Linux-device-access-groups.patch
parent8d8190882adce2a6a7c4896348334392f443b1fc (diff)
downloadaur-395a17eee8f209ffe04d5a3e7dc0fa3324fdf0f7.tar.gz
sync with testing/systemd
Signed-off-by: Yurii Kolesnykov <root@yurikoles.com>
Diffstat (limited to '0001-Use-Arch-Linux-device-access-groups.patch')
-rw-r--r--0001-Use-Arch-Linux-device-access-groups.patch98
1 files changed, 85 insertions, 13 deletions
diff --git a/0001-Use-Arch-Linux-device-access-groups.patch b/0001-Use-Arch-Linux-device-access-groups.patch
index 8211de9f3b4d..6449c017db0c 100644
--- a/0001-Use-Arch-Linux-device-access-groups.patch
+++ b/0001-Use-Arch-Linux-device-access-groups.patch
@@ -1,14 +1,88 @@
-From cd141e77470b2b2dc7c630ed2f65c3111710aaf9 Mon Sep 17 00:00:00 2001
-From: Yurii Kolesnykov <root@yurikoles.com>
-Date: Thu, 17 Jun 2021 20:09:14 +0300
+From f7d07e298c819a81eab965efbdbf53a2ce67fc0e Mon Sep 17 00:00:00 2001
+From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
+Date: Tue, 6 Mar 2018 23:39:47 +0100
Subject: [PATCH] Use Arch Linux' device access groups
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
-Signed-off-by: Yurii Kolesnykov <root@yurikoles.com>
+ cdrom → optical
+ dialout → uucp
+ tape → storage
---
+ meson.build | 6 +++---
+ meson_options.txt | 12 ++++++------
rules.d/50-udev-default.rules.in | 14 +++++++-------
sysusers.d/basic.conf.in | 6 +++---
- 2 files changed, 10 insertions(+), 10 deletions(-)
+ 4 files changed, 19 insertions(+), 19 deletions(-)
+diff --git a/meson.build b/meson.build
+index 32e5413a62..f781e06fed 100644
+--- a/meson.build
++++ b/meson.build
+@@ -796,19 +796,19 @@ conf.set_quoted('NOBODY_GROUP_NAME', nobody_group)
+ static_ugids = []
+ foreach option : ['adm-gid',
+ 'audio-gid',
+- 'cdrom-gid',
+- 'dialout-gid',
+ 'disk-gid',
+ 'input-gid',
+ 'kmem-gid',
+ 'kvm-gid',
+ 'lp-gid',
++ 'optical-gid',
+ 'render-gid',
+ 'sgx-gid',
+- 'tape-gid',
++ 'storage-gid',
+ 'tty-gid',
+ 'users-gid',
+ 'utmp-gid',
++ 'uucp-gid',
+ 'video-gid',
+ 'wheel-gid',
+ 'systemd-journal-gid',
+diff --git a/meson_options.txt b/meson_options.txt
+index 5048de755d..676e5e2e0d 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -235,10 +235,6 @@ option('adm-gid', type : 'integer', value : '-1',
+ description : 'soft-static allocation for the "adm" group')
+ option('audio-gid', type : 'integer', value : '-1',
+ description : 'soft-static allocation for the "audio" group')
+-option('cdrom-gid', type : 'integer', value : '-1',
+- description : 'soft-static allocation for the "cdrom" group')
+-option('dialout-gid', type : 'integer', value : '-1',
+- description : 'soft-static allocation for the "dialout" group')
+ option('disk-gid', type : 'integer', value : '-1',
+ description : 'soft-static allocation for the "disk" group')
+ option('input-gid', type : 'integer', value : '-1',
+@@ -249,18 +245,22 @@ option('kvm-gid', type : 'integer', value : '-1',
+ description : 'soft-static allocation for the "kvm" group')
+ option('lp-gid', type : 'integer', value : '-1',
+ description : 'soft-static allocation for the "lp" group')
++option('optical-gid', type : 'integer', value : '-1',
++ description : 'soft-static allocation for the "optical" group')
+ option('render-gid', type : 'integer', value : '-1',
+ description : 'soft-static allocation for the "render" group')
+ option('sgx-gid', type : 'integer', value : '-1',
+ description : 'soft-static allocation for the "sgx" group')
+-option('tape-gid', type : 'integer', value : '-1',
+- description : 'soft-static allocation for the "tape" group')
++option('storage-gid', type : 'integer', value : '-1',
++ description : 'soft-static allocation for the "storage" group')
+ option('tty-gid', type : 'integer', value : 5,
+ description : 'the numeric GID of the "tty" group')
+ option('users-gid', type : 'integer', value : '-1',
+ description : 'soft-static allocation for the "users" group')
+ option('utmp-gid', type : 'integer', value : '-1',
+ description : 'soft-static allocation for the "utmp" group')
++option('uucp-gid', type : 'integer', value : '-1',
++ description : 'soft-static allocation for the "uucp" group')
+ option('video-gid', type : 'integer', value : '-1',
+ description : 'soft-static allocation for the "video" group')
+ option('wheel-gid', type : 'integer', value : '-1',
diff --git a/rules.d/50-udev-default.rules.in b/rules.d/50-udev-default.rules.in
index 18a3cf46bf..f3c440fd89 100644
--- a/rules.d/50-udev-default.rules.in
@@ -43,10 +117,10 @@ index 18a3cf46bf..f3c440fd89 100644
KERNEL=="qft[0-9]*|nqft[0-9]*|zqft[0-9]*|nzqft[0-9]*|rawqft[0-9]*|nrawqft[0-9]*", GROUP="disk"
KERNEL=="loop-control", GROUP="disk", OPTIONS+="static_node=loop-control"
diff --git a/sysusers.d/basic.conf.in b/sysusers.d/basic.conf.in
-index 8cc1a7cad2..be12c76ab6 100644
+index 8cc1a7cad2..21bb6d8948 100644
--- a/sysusers.d/basic.conf.in
+++ b/sysusers.d/basic.conf.in
-@@ -22,16 +22,16 @@ g utmp {{UTMP_GID }} - -
+@@ -22,17 +22,17 @@ g utmp {{UTMP_GID }} - -
# Physical and virtual hardware access groups
g audio {{AUDIO_GID }} - -
@@ -57,15 +131,13 @@ index 8cc1a7cad2..be12c76ab6 100644
g kmem {{KMEM_GID }} - -
g kvm {{KVM_GID }} - -
g lp {{LP_GID }} - -
-+g optical - - -
++g optical {{OPTICAL_GID}} - -
g render {{RENDER_GID }} - -
g sgx {{SGX_GID }} - -
-g tape {{TAPE_GID }} - -
-+g storage - - -
-+g uucp - - -
++g storage {{STORAGE_GID}} - -
g tty {{TTY_GID }} - -
++g uucp {{UUCP_GID }} - -
g video {{VIDEO_GID }} - -
---
-2.32.0
-
+ # Default group for normal users