summarylogtreecommitdiffstats
path: root/0001-Use-Arch-Linux-device-access-groups.patch
diff options
context:
space:
mode:
authorNicolas Iooss2021-07-14 16:37:47 +0200
committerNicolas Iooss2021-07-14 16:37:47 +0200
commit246284c1a558e5065bb1c4d40f1ade4edd9ddf98 (patch)
treef46a13070a05238c9ffa6f77f5b60474f3d3272a /0001-Use-Arch-Linux-device-access-groups.patch
parentcf4b50d3f368f61095e8deefb1ac4cf1bf4c14aa (diff)
downloadaur-246284c1a558e5065bb1c4d40f1ade4edd9ddf98.tar.gz
systemd-selinux 249-3 update
Diffstat (limited to '0001-Use-Arch-Linux-device-access-groups.patch')
-rw-r--r--0001-Use-Arch-Linux-device-access-groups.patch113
1 files changed, 92 insertions, 21 deletions
diff --git a/0001-Use-Arch-Linux-device-access-groups.patch b/0001-Use-Arch-Linux-device-access-groups.patch
index 3abb448bfe92..6449c017db0c 100644
--- a/0001-Use-Arch-Linux-device-access-groups.patch
+++ b/0001-Use-Arch-Linux-device-access-groups.patch
@@ -1,4 +1,4 @@
-From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
+From f7d07e298c819a81eab965efbdbf53a2ce67fc0e Mon Sep 17 00:00:00 2001
From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
Date: Tue, 6 Mar 2018 23:39:47 +0100
Subject: [PATCH] Use Arch Linux' device access groups
@@ -10,12 +10,81 @@ Content-Transfer-Encoding: 8bit
dialout → uucp
tape → storage
---
+ meson.build | 6 +++---
+ meson_options.txt | 12 ++++++------
rules.d/50-udev-default.rules.in | 14 +++++++-------
sysusers.d/basic.conf.in | 6 +++---
- 2 files changed, 10 insertions(+), 10 deletions(-)
+ 4 files changed, 19 insertions(+), 19 deletions(-)
+diff --git a/meson.build b/meson.build
+index 32e5413a62..f781e06fed 100644
+--- a/meson.build
++++ b/meson.build
+@@ -796,19 +796,19 @@ conf.set_quoted('NOBODY_GROUP_NAME', nobody_group)
+ static_ugids = []
+ foreach option : ['adm-gid',
+ 'audio-gid',
+- 'cdrom-gid',
+- 'dialout-gid',
+ 'disk-gid',
+ 'input-gid',
+ 'kmem-gid',
+ 'kvm-gid',
+ 'lp-gid',
++ 'optical-gid',
+ 'render-gid',
+ 'sgx-gid',
+- 'tape-gid',
++ 'storage-gid',
+ 'tty-gid',
+ 'users-gid',
+ 'utmp-gid',
++ 'uucp-gid',
+ 'video-gid',
+ 'wheel-gid',
+ 'systemd-journal-gid',
+diff --git a/meson_options.txt b/meson_options.txt
+index 5048de755d..676e5e2e0d 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -235,10 +235,6 @@ option('adm-gid', type : 'integer', value : '-1',
+ description : 'soft-static allocation for the "adm" group')
+ option('audio-gid', type : 'integer', value : '-1',
+ description : 'soft-static allocation for the "audio" group')
+-option('cdrom-gid', type : 'integer', value : '-1',
+- description : 'soft-static allocation for the "cdrom" group')
+-option('dialout-gid', type : 'integer', value : '-1',
+- description : 'soft-static allocation for the "dialout" group')
+ option('disk-gid', type : 'integer', value : '-1',
+ description : 'soft-static allocation for the "disk" group')
+ option('input-gid', type : 'integer', value : '-1',
+@@ -249,18 +245,22 @@ option('kvm-gid', type : 'integer', value : '-1',
+ description : 'soft-static allocation for the "kvm" group')
+ option('lp-gid', type : 'integer', value : '-1',
+ description : 'soft-static allocation for the "lp" group')
++option('optical-gid', type : 'integer', value : '-1',
++ description : 'soft-static allocation for the "optical" group')
+ option('render-gid', type : 'integer', value : '-1',
+ description : 'soft-static allocation for the "render" group')
+ option('sgx-gid', type : 'integer', value : '-1',
+ description : 'soft-static allocation for the "sgx" group')
+-option('tape-gid', type : 'integer', value : '-1',
+- description : 'soft-static allocation for the "tape" group')
++option('storage-gid', type : 'integer', value : '-1',
++ description : 'soft-static allocation for the "storage" group')
+ option('tty-gid', type : 'integer', value : 5,
+ description : 'the numeric GID of the "tty" group')
+ option('users-gid', type : 'integer', value : '-1',
+ description : 'soft-static allocation for the "users" group')
+ option('utmp-gid', type : 'integer', value : '-1',
+ description : 'soft-static allocation for the "utmp" group')
++option('uucp-gid', type : 'integer', value : '-1',
++ description : 'soft-static allocation for the "uucp" group')
+ option('video-gid', type : 'integer', value : '-1',
+ description : 'soft-static allocation for the "video" group')
+ option('wheel-gid', type : 'integer', value : '-1',
diff --git a/rules.d/50-udev-default.rules.in b/rules.d/50-udev-default.rules.in
-index edfa8bb107..35b8d4ba41 100644
+index 18a3cf46bf..f3c440fd89 100644
--- a/rules.d/50-udev-default.rules.in
+++ b/rules.d/50-udev-default.rules.in
@@ -22,7 +22,7 @@ SUBSYSTEM=="tty", KERNEL=="sclp_line[0-9]*", GROUP="tty", MODE="0620"
@@ -27,7 +96,7 @@ index edfa8bb107..35b8d4ba41 100644
SUBSYSTEM=="mem", KERNEL=="mem|kmem|port", GROUP="kmem", MODE="0640"
-@@ -62,13 +62,13 @@ KERNEL=="irlpt[0-9]*", GROUP="lp"
+@@ -67,13 +67,13 @@ KERNEL=="irlpt[0-9]*", GROUP="lp"
SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", ENV{ID_USB_INTERFACES}=="*:0701??:*", GROUP="lp"
SUBSYSTEM=="block", GROUP="disk"
@@ -48,25 +117,27 @@ index edfa8bb107..35b8d4ba41 100644
KERNEL=="qft[0-9]*|nqft[0-9]*|zqft[0-9]*|nzqft[0-9]*|rawqft[0-9]*|nrawqft[0-9]*", GROUP="disk"
KERNEL=="loop-control", GROUP="disk", OPTIONS+="static_node=loop-control"
diff --git a/sysusers.d/basic.conf.in b/sysusers.d/basic.conf.in
-index 4be0bd869e..cc3721b58a 100644
+index 8cc1a7cad2..21bb6d8948 100644
--- a/sysusers.d/basic.conf.in
+++ b/sysusers.d/basic.conf.in
-@@ -24,15 +24,15 @@ g utmp - - -
+@@ -22,17 +22,17 @@ g utmp {{UTMP_GID }} - -
- # Hardware access groups
- g audio - - -
--g cdrom - - -
--g dialout - - -
- g disk - - -
- g input - - -
- g kvm - - -
- g lp - - -
-+g optical - - -
- g render - - -
- g sgx - - -
--g tape - - -
-+g storage - - -
-+g uucp - - -
- g video - - -
+ # Physical and virtual hardware access groups
+ g audio {{AUDIO_GID }} - -
+-g cdrom {{CDROM_GID }} - -
+-g dialout {{DIALOUT_GID}} - -
+ g disk {{DISK_GID }} - -
+ g input {{INPUT_GID }} - -
+ g kmem {{KMEM_GID }} - -
+ g kvm {{KVM_GID }} - -
+ g lp {{LP_GID }} - -
++g optical {{OPTICAL_GID}} - -
+ g render {{RENDER_GID }} - -
+ g sgx {{SGX_GID }} - -
+-g tape {{TAPE_GID }} - -
++g storage {{STORAGE_GID}} - -
+ g tty {{TTY_GID }} - -
++g uucp {{UUCP_GID }} - -
+ g video {{VIDEO_GID }} - -
# Default group for normal users