summarylogtreecommitdiffstats
path: root/0001-archlinux-openssl-1.0.patch
diff options
context:
space:
mode:
authorHaruue Icymoon2017-12-06 18:44:10 +0800
committerHaruue Icymoon2017-12-06 18:46:52 +0800
commit0725824fbb0ef6aeb6b3ddcb745aad102326396d (patch)
treefd47c086bba6845be779ee4fb21fbe24800a208f /0001-archlinux-openssl-1.0.patch
parent7d1d269fb218f26aa1fd7267054005d3d777ffca (diff)
downloadaur-0725824fbb0ef6aeb6b3ddcb745aad102326396d.tar.gz
migrate: git version
- fix: compile against openssl-1.0 - fix: service failed with SIGBUS for permission problem Signed-off-by: Haruue Icymoon <haruue@caoyue.com.cn>
Diffstat (limited to '0001-archlinux-openssl-1.0.patch')
-rw-r--r--0001-archlinux-openssl-1.0.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/0001-archlinux-openssl-1.0.patch b/0001-archlinux-openssl-1.0.patch
new file mode 100644
index 000000000000..771e7c904f45
--- /dev/null
+++ b/0001-archlinux-openssl-1.0.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index 4f6e6465..9ebd3706 100644
+--- a/Makefile
++++ b/Makefile
+@@ -64,7 +64,7 @@ release-all:
+
+ release-static:
+ mkdir -p build/release
+- cd build/release && cmake -D STATIC=ON -D ARCH="x86-64" -D BUILD_64=ON -D CMAKE_BUILD_TYPE=release ../.. && $(MAKE)
++ cd build/release && cmake -D STATIC=ON -D ARCH="x86-64" -D BUILD_64=ON -D CMAKE_BUILD_TYPE=release -DOPENSSL_INCLUDE_DIR=/usr/include/openssl-1.0 -DOPENSSL_SSL_LIBRARY=/usr/lib/libssl.so.1.0.0 -DOPENSSL_CRYPTO_LIBRARY=/usr/lib/libcrypto.so.1.0.0 ../.. && $(MAKE)
+
+ coverage:
+ mkdir -p build/debug