summarylogtreecommitdiffstats
path: root/0001-build-Remove-forced-Werror-option.patch
diff options
context:
space:
mode:
authorMatt Coffin2020-01-19 17:00:40 -0700
committerMatt Coffin2020-01-19 17:26:20 -0700
commit7ffc2ddc104c3b55a67673080ac078488c1ba115 (patch)
tree3a8439427adb339eb59261b196e58055f4d0dee5 /0001-build-Remove-forced-Werror-option.patch
parent02ba4fb98a6ea249d3b0d96918a1036b43cc01c4 (diff)
downloadaur-7ffc2ddc104c3b55a67673080ac078488c1ba115.tar.gz
Fix build for xorg cleanup fallout
The xorg cleanup (https://www.archlinux.org/news/xorg-cleanup-requires-manual-intervention/) caused the build to break due to the dependency dri2proto being rolled into xorgproto
Diffstat (limited to '0001-build-Remove-forced-Werror-option.patch')
-rw-r--r--0001-build-Remove-forced-Werror-option.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/0001-build-Remove-forced-Werror-option.patch b/0001-build-Remove-forced-Werror-option.patch
new file mode 100644
index 000000000000..a666c148e457
--- /dev/null
+++ b/0001-build-Remove-forced-Werror-option.patch
@@ -0,0 +1,40 @@
+From b37631a8216051f4c5916f48570ff4ad3c1091c4 Mon Sep 17 00:00:00 2001
+From: Matt Coffin <mcoffin13@gmail.com>
+Date: Sat, 9 Nov 2019 10:50:55 -0700
+Subject: [PATCH] build: Remove forced -Werror option
+
+---
+ CMakeLists.txt | 3 ---
+ 1 file changed, 3 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index fb44edb..5ec3b72 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -83,7 +83,6 @@ if(UNIX)
+ -fvisibility-inlines-hidden
+ -fcolor-diagnostics
+ -Wall
+- -Werror
+ -Wno-invalid-offsetof
+ -Wno-missing-braces
+ )
+@@ -460,7 +459,6 @@ if(UNIX)
+ -fvisibility-inlines-hidden
+ -fcolor-diagnostics
+ -Wall
+- -Werror
+ )
+ target_compile_options(vfx PRIVATE $<$<COMPILE_LANGUAGE:CXX>:
+ -std=c++14
+@@ -542,7 +540,6 @@ if(UNIX)
+ -fvisibility-inlines-hidden
+ -fcolor-diagnostics
+ -Wall
+- -Werror
+ -Wno-missing-braces
+ )
+ target_compile_options(amdllpc PRIVATE $<$<COMPILE_LANGUAGE:CXX>:
+--
+2.23.0
+