summarylogtreecommitdiffstats
path: root/0001-focus-fix.patch
diff options
context:
space:
mode:
authorDimitrios Misdanitis2016-09-27 20:09:12 +0100
committerDimitrios Misdanitis2016-09-27 20:09:12 +0100
commit2e3885329776288b758bb14c926b595817640cda (patch)
treee7e31fa7a7418fc8c95ae96af279b3ae3d5aa17a /0001-focus-fix.patch
downloadaur-2e3885329776288b758bb14c926b595817640cda.tar.gz
created basic PKGBUILD to download yakuake from KDE repo and apply the focus patch
Diffstat (limited to '0001-focus-fix.patch')
-rw-r--r--0001-focus-fix.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/0001-focus-fix.patch b/0001-focus-fix.patch
new file mode 100644
index 000000000000..9a0a79b8004d
--- /dev/null
+++ b/0001-focus-fix.patch
@@ -0,0 +1,18 @@
+diff --git a/app/terminal.cpp b/app/terminal.cpp
+index 6b9681f..ac83213 100644
+--- a/app/terminal.cpp
++++ b/app/terminal.cpp
+@@ -109,9 +109,11 @@ bool Terminal::eventFilter(QObject* /* watched */, QEvent* event)
+ {
+ if (event->type() == QEvent::FocusIn)
+ {
+- emit activated(m_terminalId);
+-
+ QFocusEvent* focusEvent = static_cast<QFocusEvent*>(event);
++ if (!terminalWidget()->isVisible())
++ return false;
++
++ emit activated(m_terminalId);
+
+ if (focusEvent->reason() == Qt::MouseFocusReason || focusEvent->reason() == Qt::OtherFocusReason
+ || focusEvent->reason() == Qt::BacktabFocusReason)