summarylogtreecommitdiffstats
path: root/0001-lsblk-force-to-print-PKNAME-for-partition.patch
diff options
context:
space:
mode:
authorNarrat2020-01-12 21:03:27 +0100
committerNarrat2020-01-12 21:03:27 +0100
commit733b8a0b2bfbecc8a0a4997d4e5d5d45d75c074b (patch)
treee639743d8502c178c7af9b214d5a9c99c2eff826 /0001-lsblk-force-to-print-PKNAME-for-partition.patch
parent396d5559939421d51801e3266bc68b3b5aae5166 (diff)
downloadaur-733b8a0b2bfbecc8a0a4997d4e5d5d45d75c074b.tar.gz
Follow Arch to 2.34-8
Minimized the differences with the repo PKGBUILD as much as possible.
Diffstat (limited to '0001-lsblk-force-to-print-PKNAME-for-partition.patch')
-rw-r--r--0001-lsblk-force-to-print-PKNAME-for-partition.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/0001-lsblk-force-to-print-PKNAME-for-partition.patch b/0001-lsblk-force-to-print-PKNAME-for-partition.patch
new file mode 100644
index 000000000000..3fc342b3732a
--- /dev/null
+++ b/0001-lsblk-force-to-print-PKNAME-for-partition.patch
@@ -0,0 +1,31 @@
+From e3bb9bfb76c17b1d05814436ced62c05c4011f48 Mon Sep 17 00:00:00 2001
+From: Karel Zak <kzak@redhat.com>
+Date: Thu, 27 Jun 2019 09:22:18 +0200
+Subject: [PATCH 1/1] lsblk: force to print PKNAME for partition
+
+PKNAME (parent kernel device name) is based on printed tree according
+to parent -> child relationship. The tree is optional and not printed
+if partition specified (.e.g "lsblk -o+PKNAME /dev/sda1"), but old
+versions print the PKNAME also in this case.
+
+Addresses: https://github.com/karelzak/util-linux/issues/813
+Signed-off-by: Karel Zak <kzak@redhat.com>
+Signed-off-by: Christian Hesse <mail@eworm.de>
+---
+ misc-utils/lsblk.c | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/misc-utils/lsblk.c b/misc-utils/lsblk.c
+index e95af7af0..3ce6da730 100644
+--- a/misc-utils/lsblk.c
++++ b/misc-utils/lsblk.c
+@@ -1019,6 +1019,9 @@ static void device_to_scols(
+ DBG(DEV, ul_debugobj(dev, "add '%s' to scols", dev->name));
+ ON_DBG(DEV, if (ul_path_isopen_dirfd(dev->sysfs)) ul_debugobj(dev, " %s ---> is open!", dev->name));
+
++ if (!parent && dev->wholedisk)
++ parent = dev->wholedisk;
++
+ /* Do not print device more than one in --list mode */
+ if (!(lsblk->flags & LSBLK_TREE) && dev->is_printed)
+ return;