summarylogtreecommitdiffstats
path: root/0001-nsync-export.patch
diff options
context:
space:
mode:
authorChih-Hsuan Yen2022-07-23 20:09:39 +0800
committerChih-Hsuan Yen2022-07-23 20:09:39 +0800
commitfdeffaa0607ba7bb6607038fa64d5b45177431d9 (patch)
treebef002f2ed9ffc93e7a5a2d919f3d600b45a252f /0001-nsync-export.patch
parentceaf3f9c252124d46c7d5763ef61cbc3744b9222 (diff)
downloadaur-fdeffaa0607ba7bb6607038fa64d5b45177431d9.tar.gz
prepare for python-onnxruntime 1.12
By cherry-picking a patch from MSYS2 to make `find_package(nsync_cpp)` work.
Diffstat (limited to '0001-nsync-export.patch')
-rw-r--r--0001-nsync-export.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/0001-nsync-export.patch b/0001-nsync-export.patch
new file mode 100644
index 000000000000..c70066abd6f8
--- /dev/null
+++ b/0001-nsync-export.patch
@@ -0,0 +1,29 @@
+diff -urN -x '*.orig' nsync-1.20.2.orig/CMakeLists.txt nsync-1.20.2/CMakeLists.txt
+--- nsync-1.20.2.orig/CMakeLists.txt 2019-01-04 05:29:33.000000000 +0800
++++ nsync-1.20.2/CMakeLists.txt 2019-03-03 17:41:18.480996400 +0800
+@@ -398,11 +402,11 @@
+
+ set (CMAKE_SKIP_INSTALL_ALL_DEPENDENCY ON)
+
+-install (TARGETS nsync
++install (TARGETS nsync EXPORT nsync
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR} COMPONENT RuntimeLibraries
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR} COMPONENT Development)
+
+-install (TARGETS nsync_cpp OPTIONAL
++install (TARGETS nsync_cpp EXPORT nsync_cpp OPTIONAL
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR} COMPONENT RuntimeLibraries
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR} COMPONENT Development)
+
+@@ -427,3 +433,11 @@
+ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
+ COMPONENT Development)
+ endforeach ()
++
++install(EXPORT nsync
++ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/nsync
++ FILE nsyncConfig.cmake)
++
++install(EXPORT nsync_cpp
++ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/nsync_cpp
++ FILE nsync_cppConfig.cmake)