summarylogtreecommitdiffstats
path: root/0001-optional-pyinstaller.patch
diff options
context:
space:
mode:
authorAlexander Fasching2019-08-14 19:57:46 +0200
committerAlexander Fasching2019-08-14 19:57:46 +0200
commit6a89295a19e92d9690cac6f7ed25adfe386d7657 (patch)
treea29667195108f47f54b57242f705e2e2dc22d57b /0001-optional-pyinstaller.patch
parent960681b0af14661948dccf68623db9f8a9bac5b4 (diff)
downloadaur-6a89295a19e92d9690cac6f7ed25adfe386d7657.tar.gz
upgpkg: python-pyxel 1.2.4-2
Patch setup.py to make pyinstaller an optional dependency for pyxelpackager.
Diffstat (limited to '0001-optional-pyinstaller.patch')
-rw-r--r--0001-optional-pyinstaller.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/0001-optional-pyinstaller.patch b/0001-optional-pyinstaller.patch
new file mode 100644
index 000000000000..c6388c46c2c0
--- /dev/null
+++ b/0001-optional-pyinstaller.patch
@@ -0,0 +1,20 @@
+diff --git a/setup.py b/setup.py
+index 91b4bdb..6b45047 100644
+--- a/setup.py
++++ b/setup.py
+@@ -40,12 +40,13 @@ setuptools.setup(
+ "pyxel.examples.assets",
+ ],
+ package_data={"": ["*.pyxres", "*.png", "*.gif", "*.dylib", "*.dll", "*.so"]},
+- install_requires=["numpy", "pyinstaller"],
++ install_requires=["numpy"],
++ extras_require={"packager": ["pyinstaller"]},
+ python_requires=">=3.7",
+ entry_points={
+ "console_scripts": [
+ "pyxeleditor=pyxel.editor:run",
+- "pyxelpackager=pyxel.packager:run",
++ "pyxelpackager=pyxel.packager:run [packager]",
+ "install_pyxel_examples=pyxel.examples:install",
+ ]
+ },