summarylogtreecommitdiffstats
path: root/0001_makefile.patch
diff options
context:
space:
mode:
authorSammysHP2017-05-02 13:43:43 +0200
committerSammysHP2017-05-02 13:43:43 +0200
commite86938fb305f866e33517e26f5fa6deb4cf86e7b (patch)
treef839b65d5f24e954bb2a69947b42ffc306592600 /0001_makefile.patch
parentf9fd8ff630439f4425f2f138a48eb0f883e7e5bc (diff)
downloadaur-e86938fb305f866e33517e26f5fa6deb4cf86e7b.tar.gz
Add patch for system-wide skins
Diffstat (limited to '0001_makefile.patch')
-rw-r--r--0001_makefile.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/0001_makefile.patch b/0001_makefile.patch
new file mode 100644
index 000000000000..9ff19fd89c84
--- /dev/null
+++ b/0001_makefile.patch
@@ -0,0 +1,26 @@
+commit beed37d53acc35b20340cf09bbe4c79516a4d758
+Author: SammysHP <sven@sammyshp.de>
+Date: Tue May 2 11:04:31 2017 +0200
+
+ Fix Makefile to compile on Arch Linux
+
+diff --git a/gtk/Makefile b/gtk/Makefile
+index c8210b6..01c0daf 100644
+--- a/gtk/Makefile
++++ b/gtk/Makefile
+@@ -19,6 +19,7 @@ CFLAGS = -MMD \
+ -Wall \
+ -Wno-parentheses \
+ -Wno-write-strings \
++ -Wno-narrowing \
+ -g \
+ -I/usr/X11R6/include \
+ $(shell pkg-config --cflags gtk+-2.0) \
+@@ -40,6 +41,7 @@ LIBS = gcc111libbid.a -lXmu $(shell pkg-config --libs gtk+-2.0)
+ ifeq "$(shell uname -s)" "Linux"
+ LDFLAGS += -Wl,--hash-style=both
+ LIBS += -lpthread
++LIBS := ${LIBS} -lX11
+ endif
+
+ SRCS = shell_main.cc shell_skin.cc skins.cc keymap.cc shell_loadimage.cc \