summarylogtreecommitdiffstats
path: root/0002-Fix-dangling-pointer-compiler-bug.patch
diff options
context:
space:
mode:
authorboogie2023-07-21 00:12:50 +0200
committerboogie2023-07-21 02:18:56 +0200
commit14a0a8705f127a23347fcbdfbde4dbb058b13182 (patch)
tree056405c80516964dd4941fbc062a57666775abb4 /0002-Fix-dangling-pointer-compiler-bug.patch
parenta001021fbecb1867e9b443501c783700d47f5010 (diff)
downloadaur-14a0a8705f127a23347fcbdfbde4dbb058b13182.tar.gz
update to rkr4.1 and deliver libmali together
Diffstat (limited to '0002-Fix-dangling-pointer-compiler-bug.patch')
-rw-r--r--0002-Fix-dangling-pointer-compiler-bug.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/0002-Fix-dangling-pointer-compiler-bug.patch b/0002-Fix-dangling-pointer-compiler-bug.patch
new file mode 100644
index 000000000000..69d2c5512120
--- /dev/null
+++ b/0002-Fix-dangling-pointer-compiler-bug.patch
@@ -0,0 +1,33 @@
+From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
+From: Yuntian Zhang <yt@radxa.com>
+Date: Mon, 16 May 2022 19:16:48 +0800
+Subject: [PATCH] Fix dangling-pointer compiler bug
+
+https://bugzilla.kernel.org/show_bug.cgi?id=215851
+
+Signed-off-by: Yuntian Zhang <yt@radxa.com>
+---
+ Makefile | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/Makefile b/Makefile
+index 35533e1411..380f5613a0 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1020,6 +1020,13 @@ KBUILD_CFLAGS += $(call cc-option,-Werror=designated-init)
+ # change __FILE__ to the relative path from the srctree
+ KBUILD_CPPFLAGS += $(call cc-option,-fmacro-prefix-map=$(srctree)/=)
+
++# Workaround the latest gcc bug
++# https://bugzilla.kernel.org/show_bug.cgi?id=215851
++KBUILD_CFLAGS += $(call cc-disable-warning, dangling-pointer)
++KBUILD_CFLAGS += $(call cc-disable-warning, address)
++KBUILD_CFLAGS += $(call cc-disable-warning, array-bounds)
++KBUILD_CFLAGS += $(call cc-disable-warning, stringop-truncatio)
++
+ # include additional Makefiles when needed
+ include-y := scripts/Makefile.extrawarn
+ include-$(CONFIG_KASAN) += scripts/Makefile.kasan
+--
+2.37.0
+