summarylogtreecommitdiffstats
path: root/0002-Makefile-general-fixes.patch
diff options
context:
space:
mode:
authorIvan Shapovalov2017-03-26 11:10:14 +0300
committerIvan Shapovalov2017-03-26 11:10:14 +0300
commit72c6ba3ba65160ec1cee34d0035aa3ad137d4b5a (patch)
treebe63483704c304ca8cb429f335f2a389e74bfbac /0002-Makefile-general-fixes.patch
parentd34268b7458941336ade673483f1b58f70b1494f (diff)
downloadaur-72c6ba3ba65160ec1cee34d0035aa3ad137d4b5a.tar.gz
Bump to 20170325; rebase patches.
Diffstat (limited to '0002-Makefile-general-fixes.patch')
-rw-r--r--0002-Makefile-general-fixes.patch34
1 files changed, 17 insertions, 17 deletions
diff --git a/0002-Makefile-general-fixes.patch b/0002-Makefile-general-fixes.patch
index f98dec4612b9..31af4214bb3f 100644
--- a/0002-Makefile-general-fixes.patch
+++ b/0002-Makefile-general-fixes.patch
@@ -1,4 +1,4 @@
-From 2411c8a67b4ac8d5569b81a5eb1f0e7fadd70511 Mon Sep 17 00:00:00 2001
+From cb30c146369a1397491272653cab9a5190d50041 Mon Sep 17 00:00:00 2001
From: Ivan Shapovalov <intelfx@intelfx.name>
Date: Sun, 23 Oct 2016 10:21:54 +0300
Subject: [PATCH 2/5] Makefile: general fixes
@@ -8,10 +8,10 @@ Subject: [PATCH 2/5] Makefile: general fixes
1 file changed, 29 insertions(+), 29 deletions(-)
diff --git a/Makefile b/Makefile
-index ae73d56..d4a5582 100644
+index 8079ddf..022f072 100644
--- a/Makefile
+++ b/Makefile
-@@ -42,7 +42,7 @@ FOODB=$(PREFIX)/share/foomatic/db/source
+@@ -43,7 +43,7 @@ FOODB=$(PREFIX)/share/foomatic/db/source
# User ID's
LPuid=-oroot
@@ -20,7 +20,7 @@ index ae73d56..d4a5582 100644
ifeq ($(UNAME),Darwin)
LPuid=-oroot
LPgid=-gwheel
-@@ -385,8 +385,8 @@ JBGOPTS=-m 16 -d 0 -p 92 # Equivalent options for pbmtojbg
+@@ -392,8 +392,8 @@ JBGOPTS=-m 16 -d 0 -p 92 # Equivalent options for pbmtojbg
#
# The usual build rules
#
@@ -31,7 +31,7 @@ index ae73d56..d4a5582 100644
all-done
all-test:
-@@ -611,8 +611,8 @@ command2foo2lava-pjl.o: command2foo2lava-pjl.c
+@@ -626,8 +626,8 @@ command2foo2lava-pjl.o: command2foo2lava-pjl.c
#
# Installation rules
#
@@ -42,7 +42,7 @@ index ae73d56..d4a5582 100644
install-gui install-desktop install-filter \
install-man install-doc
#
-@@ -661,8 +661,8 @@ install-prog:
+@@ -676,8 +676,8 @@ install-prog:
$(INSTALL) -d $(BIN)
$(INSTALL) -c $(PROGS) $(SHELLS) $(BIN)/
if [ "$(BINPROGS)" != "" ]; then \
@@ -53,7 +53,7 @@ index ae73d56..d4a5582 100644
fi
#
# Install gamma correction files. These are just templates,
-@@ -742,7 +742,7 @@ install-crd:
+@@ -757,7 +757,7 @@ install-crd:
# Install prebuilt CRD files (from m2300w project)
#
$(INSTALL) -d $(SHAREZJS)/
@@ -62,7 +62,7 @@ index ae73d56..d4a5582 100644
for i in crd/zjs/*.*; do \
$(INSTALL) -c -m 644 $$i $(SHAREZJS)/crd/; \
done
-@@ -750,7 +750,7 @@ install-crd:
+@@ -765,7 +765,7 @@ install-crd:
# Install prebuilt CRD files for CLP-300/CLP-600
#
$(INSTALL) -d $(SHAREQPDL)/
@@ -71,7 +71,7 @@ index ae73d56..d4a5582 100644
for i in crd/qpdl/*cms* crd/qpdl/*.ps; do \
$(INSTALL) -c -m 644 $$i $(SHAREQPDL)/crd/; \
done
-@@ -760,7 +760,7 @@ install-psfiles:
+@@ -775,7 +775,7 @@ install-psfiles:
# Install prebuilt psfiles files (from m2300w project)
#
$(INSTALL) -d $(SHAREHP)/
@@ -80,7 +80,7 @@ index ae73d56..d4a5582 100644
for i in psfiles/*.*; do \
$(INSTALL) -c -m 644 $$i $(SHAREHP)/psfiles/; \
done
-@@ -774,14 +774,14 @@ install-extra:
+@@ -789,14 +789,14 @@ install-extra:
#
$(INSTALL) -d $(SHAREZJS)/
# foo2zjs ICM files (if any)
@@ -97,7 +97,7 @@ index ae73d56..d4a5582 100644
for i in sihp1*.img; do \
if [ -f $$i ]; then \
base=`basename $$i .img`; \
-@@ -790,7 +790,7 @@ install-extra:
+@@ -805,7 +805,7 @@ install-extra:
fi; \
done
# foo2xqx Firmware files (if any)
@@ -106,7 +106,7 @@ index ae73d56..d4a5582 100644
for i in sihpP*.img; do \
if [ -f $$i ]; then \
base=`basename $$i .img`; \
-@@ -799,49 +799,49 @@ install-extra:
+@@ -814,49 +814,49 @@ install-extra:
fi; \
done
# foo2oak ICM files (if any)
@@ -163,7 +163,7 @@ index ae73d56..d4a5582 100644
for i in hbpl*.icm; do \
if [ -f $$i ]; then \
$(INSTALL) -c -m 644 $$i $(SHAREHBPL)/icm/; \
-@@ -858,14 +858,14 @@ install-ppd:
+@@ -873,14 +873,14 @@ install-ppd:
# Install PPD files for CUPS
#
export PATH=$$PATH:`pwd`:; \
@@ -180,7 +180,7 @@ index ae73d56..d4a5582 100644
done; \
ppdmgr -u; \
elif [ -d $(PPD) ]; then \
-@@ -881,7 +881,7 @@ install-ppd:
+@@ -896,7 +896,7 @@ install-ppd:
cd PPD; \
for ppd in *.ppd; do \
modify-ppd <$$ppd | gzip > $(PPD)/foo2zjs/$$ppd.gz; \
@@ -189,7 +189,7 @@ index ae73d56..d4a5582 100644
done; \
fi
#
-@@ -891,21 +891,21 @@ install-ppd:
+@@ -906,21 +906,21 @@ install-ppd:
cd PPD; \
for ppd in *.ppd; do \
modify-ppd <$$ppd | gzip > $(MODEL)/$$ppd.gz; \
@@ -214,7 +214,7 @@ index ae73d56..d4a5582 100644
done; \
fi
-@@ -946,7 +946,7 @@ DEVDDIR=/etc/devd
+@@ -961,7 +961,7 @@ DEVDDIR=/etc/devd
ifeq ($(UNAME),Darwin)
install-hotplug: install-hotplug-test install-hotplug-osx
else
@@ -223,7 +223,7 @@ index ae73d56..d4a5582 100644
endif
install-hotplug-test:
-@@ -1049,8 +1049,8 @@ install-hotplug-osx:
+@@ -1064,8 +1064,8 @@ install-hotplug-osx:
install-filter:
if [ "$(CUPS_SERVERBIN)" != "" ]; then \