summarylogtreecommitdiffstats
path: root/0002-Use-llvm-from-cling.patch
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-07-21 21:28:50 -0500
committerCarlos Aznarán Laos2023-07-21 21:28:50 -0500
commitb9f64964e8c3375e90648d55bc704887a1545e51 (patch)
tree320fbaeb85b065b04ca55cd8e7a0171079b48436 /0002-Use-llvm-from-cling.patch
parent86dc2d70a33b7901d50c923d2e4a30b331acd048 (diff)
downloadaur-b9f64964e8c3375e90648d55bc704887a1545e51.tar.gz
Bump version to 0.15.2
Diffstat (limited to '0002-Use-llvm-from-cling.patch')
-rw-r--r--0002-Use-llvm-from-cling.patch15
1 files changed, 8 insertions, 7 deletions
diff --git a/0002-Use-llvm-from-cling.patch b/0002-Use-llvm-from-cling.patch
index 7a2d45985063..b463fd81bc12 100644
--- a/0002-Use-llvm-from-cling.patch
+++ b/0002-Use-llvm-from-cling.patch
@@ -1,9 +1,10 @@
---- xeus-cling-0.15.0/CMakeLists.txt 2023-01-30 21:26:07.000000000 +0100
-+++ xeus-cling-0.15.0-fixed/CMakeLists.txt 2023-02-01 18:35:36.914901732 +0100
+diff --color --unified --recursive --text ../xeus-cling-0.15.2-fixed/CMakeLists.txt xeus-cling-0.15.2/CMakeLists.txt
+--- ../xeus-cling-0.15.2-fixed/CMakeLists.txt 2023-07-12 10:01:11.000000000 -0500
++++ xeus-cling-0.15.2/CMakeLists.txt 2023-07-21 21:05:07.308285729 -0500
@@ -50,59 +50,6 @@
"${CMAKE_CURRENT_SOURCE_DIR}/share/jupyter/kernels/xcpp17/kernel.json"
)
-
+
-#######################
-# Rely on llvm-config #
-#######################
@@ -63,20 +64,20 @@
@@ -112,8 +59,10 @@
find_package(xeus-zmq ${xeus-zmq_REQUIRED_VERSION} REQUIRED)
find_package(pugixml REQUIRED)
-
+
-find_package(Clang REQUIRED)
find_package(Cling REQUIRED)
+find_package(Clang REQUIRED)
+find_package(LLVM REQUIRED)
+add_definitions(-DLLVM_DIR="${LLVM_INSTALL_PREFIX}")
find_package(argparse REQUIRED)
-
+
#########
@@ -219,6 +168,7 @@
-
+
target_include_directories(xeus-cling
PUBLIC
-+ $<BUILD_INTERFACE:${LLVM_INCLUDE_DIR}>
++ $<BUILD_INTERFACE:${LLVM_INCLUDE_DIR}>
$<BUILD_INTERFACE:${XEUS_CLING_INCLUDE_DIR}>
$<INSTALL_INTERFACE:include>)
target_link_libraries(xeus-cling PUBLIC clingInterpreter clingMetaProcessor clingUtils xeus-zmq pugixml argparse::argparse)