summarylogtreecommitdiffstats
path: root/0002-Use-sh-to-resolve-hooks-in-services.patch
diff options
context:
space:
mode:
authorArenM2022-04-28 22:22:10 -0400
committerArenM2023-04-05 21:20:25 -0400
commite39ac8fee0451598b8b9997962b935886a1cbcad (patch)
treeafde85b41017beb9a6154b67cac6e1cb51f84adf /0002-Use-sh-to-resolve-hooks-in-services.patch
downloadaur-e39ac8fee0451598b8b9997962b935886a1cbcad.tar.gz
initial commit
This is forked from the sxmo-utils package in danctnix https://github.com/dreemurrs-embedded/Pine64-Arch/blob/master/PKGBUILDS/sxmo/sxmo-utils/PKGBUILD Notable changes include: - Add patches to use systemd instead of superd - Disable dwm variant. None of the sxmo versions of the suckless utilities are in the aur, and I don't want to maintain aur versions of them.
Diffstat (limited to '0002-Use-sh-to-resolve-hooks-in-services.patch')
-rw-r--r--0002-Use-sh-to-resolve-hooks-in-services.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/0002-Use-sh-to-resolve-hooks-in-services.patch b/0002-Use-sh-to-resolve-hooks-in-services.patch
new file mode 100644
index 000000000000..7ce388221259
--- /dev/null
+++ b/0002-Use-sh-to-resolve-hooks-in-services.patch
@@ -0,0 +1,35 @@
+From 4e4fa35e0538611fd4260bbd750e4367a4035be4 Mon Sep 17 00:00:00 2001
+From: ArenM <aren@peacevolution.org>
+Date: Wed, 20 Apr 2022 20:37:03 -0400
+Subject: [PATCH sxmo-utils 2/9] Use sh to resolve hooks in services
+
+systemd uses a path configured at build time, so we need to use a shell
+to launch hooks in order to find them correctly.
+---
+ configs/superd/services/sxmo_desktop_widget.service | 2 +-
+ configs/superd/services/sxmo_hook_lisgd.service | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configs/superd/services/sxmo_desktop_widget.service b/configs/superd/services/sxmo_desktop_widget.service
+index c161bb1..199d9a6 100644
+--- a/configs/superd/services/sxmo_desktop_widget.service
++++ b/configs/superd/services/sxmo_desktop_widget.service
+@@ -4,4 +4,4 @@ Description=Sxmo: start desktop widget (ie. clock)
+ [Service]
+ Type=simple
+ Restart=always
+-ExecStart=sxmo_hook_desktop_widget.sh
++ExecStart=sh -c sxmo_hook_desktop_widget.sh
+diff --git a/configs/superd/services/sxmo_hook_lisgd.service b/configs/superd/services/sxmo_hook_lisgd.service
+index 202510c..182d995 100644
+--- a/configs/superd/services/sxmo_hook_lisgd.service
++++ b/configs/superd/services/sxmo_hook_lisgd.service
+@@ -4,4 +4,4 @@ Description=run user defined lisgd start hook
+ [Service]
+ Type=simple
+ Restart=always
+-ExecStart=sxmo_hook_lisgdstart.sh
++ExecStart=sh -c sxmo_hook_lisgdstart.sh
+--
+2.39.2
+