summarylogtreecommitdiffstats
path: root/0002-binutils.2.34.sysexit.patch
diff options
context:
space:
mode:
authorChris Severance2020-03-19 22:08:16 -0400
committerChris Severance2020-03-19 22:08:16 -0400
commita6998d891998785ba88d5db86388e7579ad9d685 (patch)
treef5dd9ae0f26673b0b0ba3ccdef738d0de5d3ccad /0002-binutils.2.34.sysexit.patch
parent59734d1cfc8369fffe61bac6d4863706c5d09a0f (diff)
downloadaur-a6998d891998785ba88d5db86388e7579ad9d685.tar.gz
autu: Update to 3.16.82-1
Diffstat (limited to '0002-binutils.2.34.sysexit.patch')
-rw-r--r--0002-binutils.2.34.sysexit.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/0002-binutils.2.34.sysexit.patch b/0002-binutils.2.34.sysexit.patch
new file mode 100644
index 000000000000..dcaf62b1520d
--- /dev/null
+++ b/0002-binutils.2.34.sysexit.patch
@@ -0,0 +1,18 @@
+diff -up linux-4.4/arch/x86/Makefile.orig linux-4.4/arch/x86/Makefile
+--- linux-4.4/arch/x86/Makefile.orig 2020-03-19 03:08:53.569999999 -0600
++++ linux-4.4/arch/x86/Makefile 2020-03-19 03:38:57.889999999 -0600
+@@ -218,6 +218,14 @@ KBUILD_CFLAGS += -fno-asynchronous-unwin
+ KBUILD_CFLAGS += $(mflags-y)
+ KBUILD_AFLAGS += $(mflags-y)
+
++#
++# Binutils 2.34 cannot handle sysexit, this corrects for now.
++#
++ifdef CONFIG_X86_64
++KBUILD_AFLAGS += -Wa,-mintel64
++KBUILD_CFLAGS += -Wa,-mintel64
++endif
++
+ # Avoid indirect branches in kernel to deal with Spectre
+ ifdef CONFIG_RETPOLINE
+ RETPOLINE_CFLAGS += $(call cc-option,-mindirect-branch=thunk-extern -mindirect-branch-register)