summarylogtreecommitdiffstats
path: root/0002-dist-libev.diff
diff options
context:
space:
mode:
authorayekat2018-12-08 00:19:54 +0100
committerayekat2018-12-08 00:19:54 +0100
commit4c7bfe92b88cf9b45f8246c6a04584196924ec8c (patch)
tree3ca0ab9f82fe494886077035d6293d9a12caefb1 /0002-dist-libev.diff
parentaa750c4f20af4011060436f07bbfda53a1ab7644 (diff)
downloadaur-4c7bfe92b88cf9b45f8246c6a04584196924ec8c.tar.gz
Initial overhaul after adopting
Upstream: * Use native libev rather than the one bundled with upstream (no libfiber-specific changes have been applied there anyway). * Use the `dist` scheduler rather than `wsd` (work-stealing): the latter schedules fibers in a rather bizarre way (keeps jumping back and forth between the last to fibers created, and never schedules any of the others). This may require further investigation. Downstream: * Fix license information: it's ISC. * Install headers and pkgconf files as well. * Add gitignore file to ignore build artifacts (except package files).
Diffstat (limited to '0002-dist-libev.diff')
-rw-r--r--0002-dist-libev.diff20
1 files changed, 20 insertions, 0 deletions
diff --git a/0002-dist-libev.diff b/0002-dist-libev.diff
new file mode 100644
index 000000000000..1c966772ede8
--- /dev/null
+++ b/0002-dist-libev.diff
@@ -0,0 +1,20 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,7 @@
+
+ all: libfiber.so bin/echo_server runtests
+
+-VPATH += example src test submodules/libev
++VPATH += example src test
+
+ CFILES = \
+ fiber_context.c \
+@@ -49,7 +49,7 @@ ifeq ($(ARCH),x86)
+ CFLAGS += -m32 -march=i686 -DARCH_x86
+ endif
+
+-CFLAGS += -pthread -Wall -Iinclude -Isubmodules/libev -D_REENTRANT -ggdb -O3
++CFLAGS += -pthread -Wall -Iinclude -D_REENTRANT -ggdb -O3
+
+ #don't use split-stack on gcc 4.6 since it doesn't implement getcontext, setcontext, or makecontext
+ GCC46 = $(shell $(CC) -v 2>&1 | grep "gcc.*4.6" > /dev/null; echo $$?)