summarylogtreecommitdiffstats
path: root/0002-install-redist-headers.patch
diff options
context:
space:
mode:
authorChristoph Haag2020-05-08 02:06:39 +0200
committerChristoph Haag2020-05-08 02:06:39 +0200
commit17491d23ae528b95ea1724df2070c0a4927f1335 (patch)
tree37d44d798a02aa1da14502c947a8651e4ce6880d /0002-install-redist-headers.patch
downloadaur-17491d23ae528b95ea1724df2070c0a4927f1335.tar.gz
initial commit
Diffstat (limited to '0002-install-redist-headers.patch')
-rw-r--r--0002-install-redist-headers.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/0002-install-redist-headers.patch b/0002-install-redist-headers.patch
new file mode 100644
index 000000000000..06fef4079476
--- /dev/null
+++ b/0002-install-redist-headers.patch
@@ -0,0 +1,39 @@
+From 457a0a53c49a656424c51898b1150d0753c39673 Mon Sep 17 00:00:00 2001
+From: Christoph Haag <christoph.haag@collabora.com>
+Date: Thu, 7 May 2020 14:53:54 +0200
+Subject: [PATCH 2/2] install redist headers
+
+---
+ CMakeLists.txt | 5 +++++
+ survive.pc.in | 2 +-
+ 2 files changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4ab40e9..78a76a5 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -236,6 +236,11 @@ INSTALL(CODE "execute_process(COMMAND ${CMAKE_COMMAND} -E create_symlink survive
+
+ install(DIRECTORY include/libsurvive DESTINATION include)
+
++file(GLOB REDIST_HEADERS
++ "redist/*.h"
++)
++install(FILES ${REDIST_HEADERS} DESTINATION include/libsurvive/redist)
++
+ find_program(CTYPESGEN ctypesgen PATHS $ENV{HOME}/anaconda3/bin)
+ if(CTYPESGEN)
+ get_property(include_directories DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR} PROPERTY INCLUDE_DIRECTORIES)
+diff --git a/survive.pc.in b/survive.pc.in
+index 5e3ce69..1a6a1d2 100644
+--- a/survive.pc.in
++++ b/survive.pc.in
+@@ -7,4 +7,4 @@ Name: @CMAKE_PROJECT_NAME@
+ Description: Libsurvive
+ Version: 0
+ Libs: -L${libdir} -lsurvive @EXTRA_LIBS@
+-Cflags: -I${includedir}
++Cflags: -I${includedir} -I${includedir}/redist
+--
+2.26.2
+