summarylogtreecommitdiffstats
path: root/0002-meson-Fix-typos-in-crypto-library-detection.patch
diff options
context:
space:
mode:
authorNicola Murino2020-10-20 17:06:51 +0200
committerNicola Murino2020-10-20 17:06:51 +0200
commit3f4095f10ed032277911acf112aeaf382d817e90 (patch)
tree678549efd69eb918bcf2f3c21be95ebcad8b2bbd /0002-meson-Fix-typos-in-crypto-library-detection.patch
parentdcbaa1959960c83abc5daee9ce0325ce27b64a4c (diff)
downloadaur-3f4095f10ed032277911acf112aeaf382d817e90.tar.gz
Update to 0.1.17
Diffstat (limited to '0002-meson-Fix-typos-in-crypto-library-detection.patch')
-rw-r--r--0002-meson-Fix-typos-in-crypto-library-detection.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/0002-meson-Fix-typos-in-crypto-library-detection.patch b/0002-meson-Fix-typos-in-crypto-library-detection.patch
new file mode 100644
index 000000000000..5ccfcc6bddfc
--- /dev/null
+++ b/0002-meson-Fix-typos-in-crypto-library-detection.patch
@@ -0,0 +1,34 @@
+From e75f9730c64301f68aaf42bb8d1e8d7ccf9cd6d5 Mon Sep 17 00:00:00 2001
+From: Nirbheek Chauhan <nirbheek@centricular.com>
+Date: Tue, 16 Jun 2020 03:54:28 +0530
+Subject: [PATCH 2/2] meson: Fix typos in crypto-library detection
+
+---
+ meson.build | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 0004d91..5b876de 100644
+--- a/meson.build
++++ b/meson.build
+@@ -189,7 +189,7 @@ gthread_dep = dependency('gthread-2.0',
+
+ # Cryto library
+ opt_cryptolib = get_option('crypto-library')
+-message('Crypto librar requested: ' + opt_cryptolib)
++message('Crypto library requested: ' + opt_cryptolib)
+ if opt_cryptolib != 'openssl'
+ crypto_dep = dependency('gnutls', version: gnutls_req, required: false)
+ cdata.set('HAVE_GNUTLS', crypto_dep.found())
+@@ -243,7 +243,7 @@ endif
+ if not crypto_dep.found()
+ if opt_cryptolib == 'gnutls'
+ error('GnuTLS requested as crypto library, but not found')
+- elif opt_cryptolib == 'gnutls'
++ elif opt_cryptolib == 'openssl'
+ error('OpenSSL requested as crypto library, but not found')
+ else
+ error('Either GnuTLS or OpenSSL is required as crypto library, but neither was found')
+--
+2.27.0.windows.1
+