summarylogtreecommitdiffstats
path: root/0002-musicplayer-cmake314.patch
diff options
context:
space:
mode:
authorMichael Straube2020-05-12 22:45:34 +0200
committerMichael Straube2020-05-12 22:45:34 +0200
commit6d8b2678f0826aac38264a0b9e5f98beb2c32ec7 (patch)
treecd7b597da8c6002d82f3eb20fed74356fec34ede /0002-musicplayer-cmake314.patch
parentf9d50677b55d2a692786ce124269743b80b51e2a (diff)
downloadaur-6d8b2678f0826aac38264a0b9e5f98beb2c32ec7.tar.gz
Fix build (gcc10)
Diffstat (limited to '0002-musicplayer-cmake314.patch')
-rw-r--r--0002-musicplayer-cmake314.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/0002-musicplayer-cmake314.patch b/0002-musicplayer-cmake314.patch
new file mode 100644
index 000000000000..8530cf665799
--- /dev/null
+++ b/0002-musicplayer-cmake314.patch
@@ -0,0 +1,13 @@
+diff --git a/plugins/uadeplugin/CMakeLists.txt b/plugins/uadeplugin/CMakeLists.txt
+index 5491e7e..cc1b09c 100644
+--- a/plugins/uadeplugin/CMakeLists.txt
++++ b/plugins/uadeplugin/CMakeLists.txt
+@@ -69,7 +69,7 @@ add_custom_command(OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/cpuemu.c ${CMAKE_CURRENT_B
+ COMMENT "Running gencpu")
+
+ add_library(uade OBJECT ${UADE_SOURCES} ${CMAKE_CURRENT_BINARY_DIR}/cpuemu.c ${CMAKE_CURRENT_BINARY_DIR}/cpudefs.c ${CMAKE_CURRENT_BINARY_DIR}/cpustbl.c)
+-target_link_libraries(uade PRIVATE ws2_32)
++target_link_libraries(uade PRIVATE ${EXTRA_LIBS})
+ target_compile_definitions(uade PRIVATE -DPART_1 -DPART_2 -DPART_3 -DPART_4 -DPART_5 -DPART_6 -DPART_7 -DPART_8)
+ #target_compile_options(uade PRIVATE -Wno-format -Wno-implicit-function-declaration)
+ target_include_directories(uade PRIVATE