summarylogtreecommitdiffstats
path: root/0002_lpthread.patch
diff options
context:
space:
mode:
authorSammysHP2018-09-24 14:12:05 +0200
committerSammysHP2018-09-24 14:14:56 +0200
commit6b041dc53814c4f0d2259df714a6732b2663cb20 (patch)
tree47d7dd6dca1788fa1db7b16b2bbd2dc1dc193908 /0002_lpthread.patch
parentfb7c3b3c5e8d60303eaa827ac0acf6f602aa326c (diff)
downloadaur-6b041dc53814c4f0d2259df714a6732b2663cb20.tar.gz
qt5 compatibility
The patches are taken from Gentoo [1]. Thanks to simplexe who made me aware of these patches and for sending me a patched PKGBUILD (which I have modified slightly). [1] https://packages.gentoo.org/packages/dev-db/sqliteman
Diffstat (limited to '0002_lpthread.patch')
-rw-r--r--0002_lpthread.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/0002_lpthread.patch b/0002_lpthread.patch
new file mode 100644
index 000000000000..a9bf4f4f9528
--- /dev/null
+++ b/0002_lpthread.patch
@@ -0,0 +1,19 @@
+Resolves underlinking issue causing build failure on uclibc.
+
+Author: René Rhéaume <rene.rheaume@gmail.com>
+Gentoo-bug: 587076
+
+--- a/sqliteman/CMakeLists.txt
++++ b/sqliteman/CMakeLists.txt
+@@ -183,7 +183,10 @@ IF (WIN32)
+ # don't use console subsystem
+ IF (MINGW)
+ TARGET_LINK_LIBRARIES(${EXE_NAME} "-mwindows")
+- ENDIF (MINGW)
++ ENDIF (MINGW)
++ELSE (WIN32)
++ FIND_PACKAGE(Threads)
++ TARGET_LINK_LIBRARIES(${EXE_NAME} ${CMAKE_THREAD_LIBS_INIT})
+ ENDIF (WIN32)
+
+